Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Bridging Loop issue

Hi all,

i have a core switch, 6509, and an edge switch, 2960,which i need to connect using 2 uplinks. whenever i do this, my network experiences a loop, and behavior is very shaky.

the 6509 is acting as STP root for all vlans, and the 2 ports connecting to the 2960 are:

interface GigabitEthernet9/1

description Imatco_2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-1005,1024-4094

switchport mode trunk

no ip address

end

SW6509#sh run int g9/2

Building configuration...

Current configuration : 204 bytes

!

interface GigabitEthernet9/2

description Imatco_2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-1005,1024-4094

switchport mode trunk

no ip address

shutdown

end

the 2960 interfaces are:

interface GigabitEthernet0/1

switchport trunk allowed vlan 1-1005,1024-4094

switchport mode trunk

end

interface GigabitEthernet0/2

switchport trunk allowed vlan 1-1005,1024-4094

switchport mode trunk

shutdown

end

what am i missing?

thanks.

4 REPLIES
Cisco Employee

Re: Bridging Loop issue

Why do you need to connect 2 links between the switches ? What is the design you are setting up?

Do you have STP enabled on all the 4 ports. If you have STP enabled on all the 4 ports, STP will eventually block one of the port and there should be no loop in the network. Chec using " "show spanning-tree details " or "show spanning-tree summary "/ "show spanning-tree gig x/y "

If you have to connect the 2 links directly to 6500, I would suggest creating an ether-channel and bundle the ports together. This will give you enhanced bandwidth and also as per STP this is only a single virtual link. Both the ports will also forward the traffic simultaneously

-amit singh

New Member

Re: Bridging Loop issue

Hi Amit,

actually i did try to create an etherchannel bundle, and i grouped the interfaces from both sides. The 6509 config i did is:

interface Port-channel13

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-1005,1024-4094

switchport mode trunk

no ip address

int g9/1 {and 9/2}

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-1005,1024-4094

switchport mode trunk

no ip address

channel-group 13 mode on

on the 2960, i used:

interface Port-channel1

switchport mode trunk

interface GigabitEthernet0/1

switchport trunk allowed vlan 1-1005,1024-4094

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/2

switchport trunk allowed vlan 1-1005,1024-4094

switchport mode trunk

channel-group 1 mode on

and this is what actually caused the loop.

what do you think?

Cisco Employee

Re: Bridging Loop issue

Config seems to be perfectly fine. We have same seetings on all the 4 ports.Please let me know the IOS version on 6500 and 2960's.

-amit singh

New Member

Re: Bridging Loop issue

Hi Amit,

the 2960 is running c2960-lanbase-mz.122-25.SEE2; the 6509 is running s222-ipservices_wan-mz.122-18.SXF6.bin

what do you think?

-Mohamad.

150
Views
0
Helpful
4
Replies
CreatePlease to create content