Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Bridging on Router sub-interfaces

Hi,

I need help with bridging 2 subinterfaces; F0/0.301 and F0/0.302 on a single router.

The router interfaces with a Cisco 2960 (LAYER-2) switch.

QUESTION is, does a Cisco router support bridging on subinterfaces on the same physical interface?

Currently this is NOT operational

Spaiing-tree on F0/0.301 and F0/0.302 is down, switch side is forwarding for both Vlans.

show ip interface brief shows up/down status of F0/0.301, F0/0.301 and BVI6 is down/down

Thanks for ANY help!!!

Frank

:

SETUP:

bridge irb

!

!

Interface F0/0

no ip address

!

F0/0.6

Desc MGT

encapsulation dot1q 6 native

ip addresss 192.168.1.7 255.255.255.0

!

F0/0.301

encapsulation dot1q 301

bridge-group 6

!

F0/0.302

encapsulation dot1q 302

bridge-group 6

!

!

interface BVI6

ip address 172.16.3.1 255.255.255.0

!

!

!

bridge 6 protocol ieee

bridge 6 route ip

!

Everyone's tags (3)
4 REPLIES
Bronze

Re: Bridging on Router sub-interfaces

Ok this is very strange.

For all of you that provided help with my problem, THANK YOU!!!

:

As you can see, all responce's have been removed from this  question - not sure why.

:

:

The config presented above does now work (the issue was an err-disable switch port) and has now been corrected.

Thanks again your assistance.

Frank

New Member

Hello Frank,

Hello Frank,

I know its old and 3 years ago, but I need help and still don’t know how to configure IRB, I

I am trying to make a vlans/subnet span across multiple (three) subinterfaces (i have three vlans configured on a layer 2 switch) using IRB. (Ref.: http://www.cisco.com/c/en/us/support/docs/lan-switching/integrated-routing-bridging-irb/17054-741-10.html)

three layer 2 switches are directly connected to 4431 router, each physical interface on a router have three sub interfaces and tagged, assigned to a bridge group.

However, my setup does not seem to work properly:

What am I doing wrong? Can someone please help find a solution?

I have been Google'd and searched for the answer to these questions, but I cannot find a simple answer.

Here is the configuration I am currently using on the router


bridge irb
!
interface Ethernet0/0
 no ip address
 full-duplex
!
interface Ethernet0/0.10
 encapsulation dot1Q 10
 bridge-group 1
!
interface Ethernet0/0.11
 encapsulation dot1Q 11
 bridge-group 2
!
interface Ethernet0/0.255
 encapsulation dot1Q 255
 bridge-group 3
!
interface Ethernet0/1
 no ip address
 full-duplex
!
interface Ethernet0/1.10
 encapsulation dot1Q 10
 bridge-group 1
!
interface Ethernet0/1.11
 encapsulation dot1Q 11
 bridge-group 2
!
interface Ethernet0/1.255
 encapsulation dot1Q 255
 bridge-group 3 
!
interface BVI1
 ip address 10.111.10.254 255.255.255.0
!
interface BVI2
 ip address 10.111.11.254 255.255.255.0
!
interface BVI3
 ip address 172.16.255.254 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
bridge 3 protocol ieee
bridge 3 route ip

########################################

Switch 1

interface FastEthernet0/0
 switchport mode trunk
interface Vlan1
 no ip address
!
interface Vlan255
 ip address 172.16.255.1 255.255.255.0
!
ip default-gateway 172.16.255.254

 

 

########

 

SW2

 


interface FastEthernet0/0
 switchport mode trunk

interface Vlan1
 no ip address
!
interface Vlan255
 ip address 172.16.255.2 255.255.255.0
!
ip default-gateway 172.16.255.254!

 

 

New Member

Hello anas.awad,

Hello anas.awad,

I have such problem, I need to transfer config from my old 3825 to the new 4431 router running with (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.5(3)S2

Bridge-group command not available for me to configure it on subinterface.

I want to bridge each subinterface with corresponding vlan on the my network, like Vlan1 = bridge 1 and so on.

interface Ethernet0/1.10
 encapsulation dot1Q 10
 bridge-group 1

Also I can't configure as "bridge 1 protocol ieee". I only have these protocols:dec, ibm, vlan-bridge.

How did you get this on your 4431?

New Member

Hello Alexey,I never have 

Hello Alexey,


I never have  been worked before on IRB so the above configuration i have attached was created on a lab simulation for precaution, it works after i had removed the default gateway and configured a static routes on the switches.

But the real dilemma here is once i have received the 4000 series routers for the implementation i could not find the all needed commands for bridge features like ieee protocol was not supported so i had to change the design and connect the switches back to back then use only one physical interface on router, configured sub-interfaces and tagged them then router all my subnets.
I have looked and searched but with no results.

i wish i can help you more, you can try and check the below

1.  http://www.cisco.com/c/en/us/support/docs/lan-switching/integrated-routing-bridging-irb/17054-741-10.html

2. http://www.cisco.com/c/en/us/td/docs/ios/12_2/ibm/configuration/guide/fibm_c/bcftb.html


3830
Views
0
Helpful
4
Replies
CreatePlease login to create content