Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Bridging Wired and Wireless

Hi,

Cisco 3725

IOS: (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T9

Wireless Module NME

Brief current running config below:

interface FastEthernet0/0

description WAN LINK

bandwidth 8192

ip address #### 255.255.255.252

ip access-group SECURE_INBOUND in

ip access-group SECURE_OUTBOUND out

ip nbar protocol-discovery

ip nat outside

ip virtual-reassembly max-reassemblies 64

no ip mroute-cache

!

interface FastEthernet0/1

description LAN LINK

no ip address

no ip mroute-cache

speed 100

full-duplex

!

interface FastEthernet0/1.101

description CLIENT VLAN 101

encapsulation dot1Q 101

ip address 192.168.101.1 255.255.255.0

ip access-group p101 in

ip nat inside

no ip mroute-cache

!

interface FastEthernet0/1.999

description MGMT SWITCH VLAN

encapsulation dot1Q 1 native

ip address #### 255.255.255.0

!

interface Integrated-Service-Engine2/0

description Cisco Wireless LAN Controller Module

ip address #### 255.255.255.240

!

interface Integrated-Service-Engine2/0.995

description WIRELESS

encapsulation dot1Q 995

ip address #### 255.255.255.0

ip nat inside

By enabling bridging on the router, we can setup our clients on VLAN 101 Ethernet connection to bridge with our Wireless connection using the same VLAN 101. This feature allows us to provide and manage wired and wiress service to one client on the same VLAN as well as easy accounting/billing.

When I apply the following config below, the link to our LAN Switch stack goes down:

no interface GigabitEthernet0/1.101

!

bridge irb

bridge 101 protocol ieee

bridge 101 route ip

!

interface BVI 101

description CLIENT VLAN 101

ip address 192.168.101.1 255.255.255.0

ip access-group p101 in

ip nat inside

no ip mroute-cache

!

interface GigabitEthernet0/1.101

encapsulation dot1Q 101

bridge-group 101

!

interface Integrated-Service-Engine1/0.101

encapsulation dot1Q 101

bridge-group 101

Our router log shows FastEthernet0/1, changed state to up after we place the BVI127 interface on down status.

000039: Jan 30 2012 08:54:19.343 GMT: %LINK-5-CHANGED: Interface BVI127, changed state to administratively down

000040: Jan 30 2012 08:54:20.343 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI127, changed state to down

000045: Jan 30 2012 08:56:32.066 GMT: %SYS-3-CPUHOG: Task is running for (2008)msecs, more than (2000)msecs (37/32),process = Virtual Exec.

-Traceback= 0x60744564 0x607445C0 0x61535A6C 0x610EA800 0x614D3618 0x614F738C 0x62B100C4 0x62B100A8

000047: Jan 30 2012 08:56:59.403 GMT: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up

000048: Jan 30 2012 08:57:41.281 GMT: %SYS-3-CPUHOG: Task is running for (2008)msecs, more than (2000)msecs (32/11),process = Virtual Exec.

-Traceback= 0x60744568 0x607445C0 0x61535A6C 0x610EA694 0x614D3618 0x614F738C 0x62B100C4 0x62B100A8

000053: Jan 30 2012 09:00:31.314 GMT: %LINK-3-UPDOWN: Interface BVI127, changed state to down

000054: Jan 30 2012 09:00:48.163 GMT: %LINK-3-UPDOWN: Interface BVI127, changed state to up

000055: Jan 30 2012 09:00:49.163 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI127, changed state to up

000056: Jan 30 2012 09:01:09.268 GMT: %LINK-3-UPDOWN: Interface BVI127, changed state to down

000057: Jan 30 2012 09:01:10.268 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI127, changed state to down

000059: Jan 30 2012 09:02:05.503 GMT: %LINK-5-CHANGED: Interface BVI127, changed state to administratively down

Please help.

Thanks

2 REPLIES
VIP Super Bronze

Bridging Wired and Wireless

Have you configured the switch stack with dot1q and  the same vlan tag (101)?

HTH

New Member

Re: Bridging Wired and Wireless

Hi HTH,

Here are the configs on my Cisco 3560 switch on both TRUNK port between switch and router, aswell as the port on the switch for VLAN 101:

interface FastEthernet0/1

description LINK TO ROUTER

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

storm-control broadcast level 20.00

spanning-tree portfast

!

interface FastEthernet0/13

description LINK TO VLAN 101

switchport access vlan 101

switchport mode access

Thanks

258
Views
0
Helpful
2
Replies