Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

BUG ID:CSCts29063 %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve

Dear Team,

 

We have faced the the following error on one of my cisco c7609 router with code Version 15.2(4)S4a.

 

 %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve

 

Pls let me know the reason and impact due the perticular BUG.

 

 

regards

Gaurav

  • LAN Switching and Routing
21 REPLIES
New Member

I am seeing the same message

I am seeing the same message on 3560 after upgrading to 15.0(2)SE6. Before it was running SE5, in which DHCP Snooping was broken, and SE4. Both did not show this messages.

The %ADJ-3-RESOLVE_REQ messages is populating the log very frequent. It seems that every time there is a ARP-reguest sent out to a non existent destination, causing INCOMPLETE in the ARP-table, this message is generated.

New Bug?

May  6 10:04:08.646: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve x.x.x.142 Vlan11
May  6 10:04:15.223: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve x.x.x.161 Vlan11
May  6 10:04:21.699: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve x.x.x.171 Vlan11

 

 

New Member

Hello,This bug is seen on

Hello,

This bug is seen on 2960S after upgrading to 15.0(2)SE6. 

May 19 08:30:00.200: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.96 Vlan4
May 19 08:30:05.601: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.12 Vlan4
May 19 08:30:10.723: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.204 Vlan3
May 19 08:30:15.987: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.10 Vlan4
May 19 08:30:21.707: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.7 Vlan4
May 19 08:30:28.728: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.204 Vlan3
May 19 08:30:33.950: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.10 Vlan4
May 19 08:30:40.740: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.209 Vlan3
May 19 08:30:46.727: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve *.*.*.209 Vlan3

 

New Member

I am having this issue too

I am having this issue too the log is filling up with Failed arp. This is on a 3750X stack and this is the recommended IOS version for this platform.

c3750e-universalk9-mz.150-2.SE6.

How do I stop the logs filling up I tried changing the console logging levels but it does not stop. Is there is fix for this...

000963: Jul 10 01:46:48 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.206 Vlan40

000964: Jul 10 01:46:58 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.205 Vlan40
000965: Jul 10 01:47:08 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.205 Vlan40
000966: Jul 10 01:47:18 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.205 Vlan40
000967: Jul 10 01:47:28 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.206 Vlan40
000968: Jul 10 01:47:38 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.205 Vlan40
000969: Jul 10 01:47:48 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.205 Vlan40
000970: Jul 10 01:47:58 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.206 Vlan40
000971: Jul 10 01:48:08 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.205 Vlan40
000972: Jul 10 01:48:18 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.205 Vlan40
000973: Jul 10 01:48:29 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.206 Vlan40
000974: Jul 10 01:48:39 AEST: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve 10.27.40.206 Vlan40

Devices are WS-C3750X-48P

 

 

New Member

Was this issue resolved? We

Was this issue resolved? We just added a 3750X to a switch stack and are on 15.0.2(SE6) and experiencing the issues with the logs showing

Jul 20 03:34:08.686: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve x.x.x.x Vlan251
Jul 20 03:34:16.177: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve x.x.x.x Vlan251
Jul 20 03:34:22.175: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve x.x.x.x Vlan251
Jul 20 03:34:41.820: %ADJ-3-RESOLVE_REQ: Adj resolve request: Failed to resolve x.x.x.x Vlan251

Any fix besides a downgrade?

 

New Member

Hi, We ran into this problem

Hi,

 

We ran into this problem when we upgraded our 3750Xs to 15.0(2)SE6. 

This was resolved by disabling ip cef optimize neighbor resolution

No ip cef optimize neighbor resolution

As reference in this forum:

https://supportforums.cisco.com/discussion/12215721/3750x-stack-repeatedly-showing-error-adj-3-resolvereq-adj-resolve-request-failed 

The other option is to remove all arp incomplete entries by checking all the issues. According to the notes in this forum, optimized neighbor resolution is disabled by default on IOS 12 and it is enable on IOS 15. I haven't been able to confirm this but disabling it removed the problem without affecting routing.

 

New Member

The "No ip cef optimize

The "No ip cef optimize neighbor resolution"  command worked and we are no longer seeing the messages in logging.

 

Thanks

New Member

thanks!...this fixed our

thanks!...this fixed our issue as well. :)

This turn around for this

This turn around for this particular problem works, but also we found out that our config to WLC erased and when we reconfigure our WLC for our wireless config.our wireless didn't materialize anymore.

this config resolved problem about our EIGRP neighbor but cannot resolve the issue in wifi thru WLC.

This turn around for this

This turn around for this particular problem works, but also we found out that our config to WLC erased and when we reconfigure our WLC for our wireless config.our wireless didn't materialize anymore.

this config resolved problem about our EIGRP neighbor but cannot resolve the issue in wifi thru WLC.

135
Views
45
Helpful
21
Replies