Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cable modem and cisco 2600

Hi!

I'm trying to configure a cisco router 2600, my internet connection is via a cable modem. I get a dynamic IP from the cable modem but when I ping to any external IP I have errors.Copy show config and show interface f0/1

GUEST#show config

Using 1103 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname GUEST

!

enable secret 5 $1$JK3y$ns4oiH0tN0XAPk8G7JOwS/

enable password 123456789

!

ip subnet-zero

!

!

ip name-server dns provider1

ip name-server dns provider2

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool LAN-INTERNA

   network 192.168.1.0 255.255.255.0

   dns-server dns provider1 dns provider2

!

!

call rsvp-sync

!

!

interface FastEthernet0/0

description LAN-INTERNA

ip address 192.168.1.1 255.255.255.0

ip nat inside

no ip mroute-cache

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1

description INTERNET

ip address dhcp

ip nat outside

no ip mroute-cache

duplex auto

speed auto

!

ip nat inside source list 100 interface FastEthernet0/1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

no ip http server

!

access-list 100 permit ip any any

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password 123456789

login

!

end

GUEST#show interface f0/1

FastEthernet0/1 is up, line protocol is up

  Hardware is AmdFE, address is 0005.5e63.77c1 (bia 0005.5e63.77c1)

  Description: INTERNET

  Internet address is a.b.c.d/24

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:02, output hang never

  Last clearing of "show interface" counters never

  Input queue: 2/75/556/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 26000 bits/sec, 41 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     10632 packets input, 666156 bytes

     Received 10632 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     45 packets output, 5319 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

GUEST#ping www.google.com

Translating "www.google.com"...domain server (dns provider1) (dns provider2)

% Unrecognized host or address, or protocol not running.

GUEST#ping w.x.y.z

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to w.x.y.z, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

3 REPLIES

cable modem and cisco 2600

Favio,

Try changing your acl for nat to:

no access-list 100

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

And delete the ip route statement:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

cable modem and cisco 2600

Your DHCP server is not serving a default gateway, so any traffic you send from a PC will not be able to get off the network. Also, for you to ping by name, make sure you use a valid DNS provider for the name server.

I would try pinging 4.2.2.2 which is a known good internet DNS server. Kind of two birds with one stone, it's handy to ping to test and you can use it for DNS in a pinch. 8.8.8.8 and 8.8.4.4 are good to use also, they are google DNS servers.

Good luck!

Andy

New Member

cable modem and cisco 2600

Thanks its working!

669
Views
0
Helpful
3
Replies