Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

can not able to ping router ip using cisco layer 3 switch

Hello,

router ip 192.168.9.1 directally connceted to 192.168.9.254 (fa0/1 of layer 3 switch).

vlan ip 172.16.30.254/23

i can able to ping 192.168.9.1 if my source is 192.168.9.254 (fa0/1 of layer 3 switch)

i am not able to ping 192.168.9.1 from switch if source is 172.16.30.254

you can see runnig and ip route configuration

Switch#show ip route

Gateway of last resort is not set

C    192.168.9.0/24 is directly connected, FastEthernet0/1

     172.16.0.0/23 is subnetted, 1 subnets

C       172.16.30.0 is directly connected, Vlan30

Switch#show run

Building configuration...

Current configuration : 2262 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

ip routing

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0/1

no switchport

ip address 192.168.9.254 255.255.255.0

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

!

interface FastEthernet0/30

!

interface FastEthernet0/31

!

interface FastEthernet0/32

!

interface FastEthernet0/33

!

interface FastEthernet0/34

!

interface FastEthernet0/35

!

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

!

interface FastEthernet0/46

!

interface FastEthernet0/47

!

interface FastEthernet0/48

switchport access vlan 30

switchport mode access

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface Vlan1

ip address 172.16.4.31 255.255.248.0

!

interface Vlan30

ip address 172.16.30.254 255.255.254.0

!

ip classless

ip http server

ip http secure-server

!

!

control-plane

!

!

line con 0

line vty 5 15

!

end

Switch#

upour help is highly appreciated.

1 REPLY
Hall of Fame Super Silver

Re: can not able to ping router ip using cisco layer 3 switch

Hello Dipak,

the router needs a static route for network 172.16.30.0/23 in order to answer to ICMP request sourced by 192.168.30.254

on the router

config t

ip route 172.16.30.0 255.255.254.0 192.168.9.254

exit

wr mem

This should fix your issue, to be noted it is not the switch the one that needs a configuration change.

Hope to help

Giuseppe

3381
Views
0
Helpful
1
Replies
CreatePlease to create content