Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can see MAC address but can't ping device

Guys,

I was just wondering if you can help me - we successfully moved our DC from our corporate HQ to our colo DC that is managed. This all went to plan apart from one thing - our netbackup server isn't joining the network - this was previously fine and the only change that is different is that the netbackup server was on an old 3750 switch that didn't have any gig uplinks but the new 3750 does (hopefully that makes sense).

So this is the topology that has been created by the infrastructure team (and verified by myself a former UNIX sysadmin):

a bonded interface with 4 nic's inside vlan 21 - I confirmed this with ifconfig -a but can't confirm it now as I don't have access to the server. I checked the IP, gateway and mask and they are all correct and it's participating in pagp.

Now the switch side - we can see the MAC addresses with no issues but can't seem to ping the device on 172.16.21.51 - we understand that historically this was a bitch to setup but we don't remember the actual setup even though we've checked the old config and there isn't anything different.

SLC-3750-Rack7#sh mac address-table vlan 21

          Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

All    ffff.ffff.ffff    STATIC      CPU

  21    0015.17f8.a81a    DYNAMIC     Po7

  21    0015.17f8.a81b    DYNAMIC     Po7

  21    286e.d497.2cf3    DYNAMIC     Po7

Total Mac Addresses for this criterion: 24

As above the 3 interfaces are in po7 - we have taken the interfaces out of the port channel and set them up as access and trying just 1 port - still the same, we've also tried setting the port up as a trunk and this also is the same. I can also confirm that the group of interfaces need to be kept on the same 3750 switch and not across the stack.

SLC-3750-Rack7#sh vlan bri

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Gi1/0/12, Gi1/0/19, Gi1/0/27, Gi1/0/28, Gi2/0/12, Gi2/0/27, Gi2/0/28

21   Backup                           active    Gi1/0/15, Gi1/0/16, Gi1/0/23, Gi2/0/15, Gi2/0/16, Po6, Po7

And as you see above the vlan is present on the switch

SLC-3750-Rack7#sh run int po7

Building configuration...

Current configuration : 176 bytes

!

interface Port-channel7

description ..nbu5000

switchport access vlan 21

switchport trunk encapsulation dot1q

switchport trunk native vlan 21

switchport mode access

SLC-3750-Rack7#sh etherchannel 7 summ

Number of channel-groups in use: 8

Number of aggregators:           8

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

7      Po7(SU)          -        Gi1/0/21(P) Gi1/0/22(P) Gi1/0/23(D)

                                 Gi1/0/24(P)

SLC-3750-Rack7#sh run int g1/0/21

Building configuration...

Current configuration : 186 bytes

!

interface GigabitEthernet1/0/21

switchport access vlan 21

switchport trunk encapsulation dot1q

switchport trunk native vlan 21

switchport mode access

channel-group 7 mode on

If anyone can help with this it would be greatly appreciated.

Thanks,

Thomas.

Everyone's tags (3)
3 REPLIES
Hall of Fame Super Silver

Can see MAC address but can't ping device

I am puzzled that port channel 7 is configured with switchport mode access(especially since it also is configured to specify trunk encapsulation and native vlan). What happens is you make port channel 7 switchport mode trunk?

HTH

Rick

New Member

Can see MAC address but can't ping device

Hi Rick,

I should really point out that I just copy and pasted the current config - I have tried it as plain access, trunk and other configs, simple access without any port channels and trunks but nothing seems to work. I am going to pick up the older 3750 tomorrow and put it in place and see if that works connecting back to the nexus 7k as it was previously in situ.

I am also going to run 10meter cables directly from the netbackup 5000 device straight back to the core and see if that makes any difference.

I will update the post tomorrow night with further details of any working configurations but we have churned through all the previous configs and the config looks good...but we all know that a simple difference in hardware or IOS can screw things up.

Thanks,

Tam.

Hi, did you try to delete the

Hi,

 

did you try to delete the arp cache and connect again?

4816
Views
0
Helpful
3
Replies
CreatePlease login to create content