Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't access router via CCP

I can telnet into my router (Interface FastEthernet0, 10.10.10.126 255.255.255.128)) from 10.10.10.107 255.255.255.128, but cannot discover on CCP (Discovery Details: Connection to the device could not be established. Either the device is not reachable or the HTTP service is not enabled on the device.)

Can anyone see what is wrong?

Building configuration...

Current configuration : 2005 bytes
!
! Last configuration change at 23:41:08 UTC Mon Mar 1 2010 by admin1
! NVRAM config last updated at 23:41:13 UTC Mon Mar 1 2010 by admin1
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Peters_Gallery
!
logging queue-limit 100
enable secret 5 xxxxxxx.
!
username xxxx privilege 15 password 7 xxxxxxx
username xxxxx privilege 15 password 7 xxxxxx

ip subnet-zero
!
!
ip domain name gpgallery.com
!
ip cef
!
!
!
!
interface FastEthernet0
description corp lan
ip address 10.10.10.126 255.255.255.128
ip access-group 100 in
speed auto
!
interface Serial0
ip address 10.3.0.37 255.255.255.252
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 10.10.10.128 255.255.255.224 10.3.0.38
ip route 172.16.4.0 255.255.252.0 10.3.0.38
ip http server
ip http access-class 1
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
access-list 100 remark MRC
access-list 100 permit tcp 10.10.10.0 0.0.0.127 host 10.10.10.126 eq telnet
access-list 100 permit tcp 10.10.10.0 0.0.0.127 host 10.10.10.126 eq 22
access-list 100 permit tcp 10.10.10.0 0.0.0.127 host 10.10.10.126 eq www
access-list 100 permit tcp 10.10.10.0 0.0.0.127 host 10.10.10.126 eq cmd
access-list 100 deny   tcp any host 10.10.10.126 eq telnet
access-list 100 deny   tcp any host 10.10.10.126 eq 22
access-list 100 deny   tcp any host 10.10.10.126 eq www
access-list 100 deny   tcp any host 10.10.10.126 eq cmd
access-list 100 permit ip any any
access-list 101 remark MRC
access-list 101 permit ip 10.10.10.0 0.0.0.127 any
access-list 101 permit ip 10.10.10.128 0.0.0.31 any
access-list 102 permit ip 10.10.10.128 0.0.0.31 any
access-list 102 permit ip 10.10.10.0 0.0.0.127 any
!
!
line con 0
line aux 0
line vty 0 4
access-class 102 in
login local
transport input telnet
line vty 5 15
access-class 101 in
login local
transport input telnet
!
no scheduler allocate
end

1 ACCEPTED SOLUTION

Accepted Solutions
Green

Can't access router via CCP

Hi,

I think you are right

Even looking at older versions of CCP your IOS is not supported

You could try Cisco Config Maker if you can find a CD lying around the comms room etc

Sorry , I was not much help here.

Regards

Alex

Regards, Alex. Please rate useful posts.
4 REPLIES
Green

Can't access router via CCP

Hi,

Can you remove this command

ip http access-class 1

!

no ip http access-class 1

!

Then retest

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Can't access router via CCP

I removed that command. Result is the same (Discovery Details: Connection to the device could not be established. Either the device is not reachable or the HTTP service is not enabled on the device.)

Building configuration...

Current configuration : 1982 bytes
!
! Last configuration change at 00:37:12 UTC Tue Mar 2 2010 by admin1
! NVRAM config last updated at 00:37:22 UTC Tue Mar 2 2010 by admin1
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Peters_Gallery
!
logging queue-limit 100
enable secret 5 xxxxxxxxx
username xxxx privilege 15 password 7 xxxx
username xxx privilege 15 password 7 xxxx
ip subnet-zero
!
!
ip domain name gpgallery.com
!
ip cef
!
!
!
!
interface FastEthernet0
description corp lan
ip address 10.10.10.126 255.255.255.128
ip access-group 100 in
speed auto
!
interface Serial0
ip address 10.3.0.37 255.255.255.252
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 10.10.10.128 255.255.255.224 10.3.0.38
ip route 172.16.4.0 255.255.252.0 10.3.0.38
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
access-list 100 remark MRC
access-list 100 permit tcp 10.10.10.0 0.0.0.127 host 10.10.10.126 eq telnet
access-list 100 permit tcp 10.10.10.0 0.0.0.127 host 10.10.10.126 eq 22
access-list 100 permit tcp 10.10.10.0 0.0.0.127 host 10.10.10.126 eq www
access-list 100 permit tcp 10.10.10.0 0.0.0.127 host 10.10.10.126 eq cmd
access-list 100 deny   tcp any host 10.10.10.126 eq telnet
access-list 100 deny   tcp any host 10.10.10.126 eq 22
access-list 100 deny   tcp any host 10.10.10.126 eq www
access-list 100 deny   tcp any host 10.10.10.126 eq cmd
access-list 100 permit ip any any
access-list 101 remark MRC
access-list 101 permit ip 10.10.10.0 0.0.0.127 any
access-list 101 permit ip 10.10.10.128 0.0.0.31 any
access-list 102 permit ip 10.10.10.128 0.0.0.31 any
access-list 102 permit ip 10.10.10.0 0.0.0.127 any
!
!
line con 0
line aux 0
line vty 0 4
access-class 102 in
login local
transport input telnet
line vty 5 15
access-class 101 in
login local
transport input telnet
!
no scheduler allocate
end

New Member

Can't access router via CCP

I think I found the problem. The IOS version is 12.2, whereas 12.4 is required:

http://www.cisco.com/en/US/prod/collateral/routers/ps9422/data_sheet_c78_462210.html

Green

Can't access router via CCP

Hi,

I think you are right

Even looking at older versions of CCP your IOS is not supported

You could try Cisco Config Maker if you can find a CD lying around the comms room etc

Sorry , I was not much help here.

Regards

Alex

Regards, Alex. Please rate useful posts.
1072
Views
0
Helpful
4
Replies
CreatePlease login to create content