Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

can't change native vlan on trunk port ?

I have several closets with Cisco 3560 on the edge that I'd like to change the vlan that's used for the management

vlan on each. In the core I have a Cisco 6509 with Sup720's.

I'd like to do this by changing the native vlan on the trunk port on the core 6509 interface that connects to the 3560.

and leave the management vlan on the 3560 as vlan 1.

Seems trivial but what I tried didn't work and I didn't have the window to troubleshoot. I'll paste the simplified configs

for  the interfaces  below, any suggestions would be appricieated.

Thanks

Pete

!

6509 configs:

!

interface Vlan50
ip address 172.16.50.2 255.255.255.0
!
interface FastEthernet 8/22
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 50

no ip address
!

!

3560 configs:

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

ip address 172.16.50.100 255.255.255.0

Everyone's tags (4)
5 REPLIES

can't change native vlan on trunk port ?

Why would you want to have native vlan mismatches?

And why dont you have

switchport trunk native vlan 50

for fa0/24?

Curious Jim.

New Member

can't change native vlan on trunk port ?

Currently I have over 200 switches all using the same vlan for management, topology is 2 to 6 switches stacked in each closet with with about 50 closets. Uplinks are fiber or ehternet depending on closet, all are dual homed with an uplink from

each of the dual 6509's in the core.

That's a huge spanning tree loop and I've see unstability when I get a bounce or when we loose power and UPS's die and then all get powered up at the same time.

My thought is that insteaad of going into each closet and creating the vlan for management, adding the VLand interface ect ect, I can just change the Vlan1 IP to match whatever the vlan is for that closet then in the core set the native vlan for management to that rack.

Even if it's not the recommended what to go I'd still like to know why it's not working.

New Member

Re: can't change native vlan on trunk port ?

Sent from my Android phone using TouchDown (www.nitrodesk.com)

Purple

Re: can't change native vlan on trunk port ?

  you can try  on the 6509 to remove vlan 50 from the trunk , "switchport trunk allowed vlan remove 50"  . It may still be trying to tag vlan 50 because it is allowed in the trunk.  It doesn't need to be allowed in the trunk if you are making it the native (untagged vlan) . Still not a great idea.  Going to make it a nightmare to try and troubleshoot if you have issues mixing vlan 1 and 50 together . 

New Member

Re: can't change native vlan on trunk port ?

From knowledge and experience, learned that point-to-point trunks will not route if the native VLAN is mismatch.  If the 3560 is in transparent mode, you should still be able to mismatch the management VLAN'S once you correct the native VLAN mismatch.  Symptoms are misleading.  Trunks will be up/up but unable to ping.

Jonathan,

2391
Views
0
Helpful
5
Replies