Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Can't ping 2950 switch from hosts

Using a Win 7 laptop and a linux PC, I fail to connect to a 2950 switch.  Here is the Show Run:

Current configuration : 1324 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch_1
!
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 ip address 192.168.10.1 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.10.1
ip http server
!
line con 0
 exec-timeout 30 0
 password cisco
 logging synchronous
line vty 0 4
 exec-timeout 30 0
 password cisco
 login
line vty 5 15
 exec-timeout 30 0
 password cisco
 login
!
!
end

 

Here is the Show Mac-Address table.  I confirmed on the respective hosts that the MACs are correct:


Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
 All    0011.bbb0.99c0    STATIC      CPU
 All    0100.0ccc.cccc    STATIC      CPU
 All    0100.0ccc.cccd    STATIC      CPU
 All    0100.0cdd.dddd    STATIC      CPU
   1    047d.7ba1.42ab    DYNAMIC     Fa0/7
   1    b827.ebeb.b987    DYNAMIC     Fa0/6
Total Mac Addresses for this criterion: 6

 

The problem is that I can't even ping the switch from either device.  Linux gives back a "Network is unreachable" error while Win7 "Transmit failed. General Failure".

 

I've reset the switch to factory defaults by:

  1. Doing a write/erase, deleted the vlan.dat file and reload.  Seeing how that didn't work...
  2. Held the mode button for 10+ seconds

 

Neither method has fixed the issue.  I am well and truly stumped.

 

Any ideas?

 

 

 

6 REPLIES
Purple

Hi,Can you confirm your vlan

Hi,

Can you confirm your vlan interface is up/up with following command on the switch:

show ip interface brief | i Vlan

 

Regards

 

Alain

Don't forget to rate helpful posts.
Bronze

Hi,Have you ruled out any

Hi,

Have you ruled out any firewall issues on the client machines?

 

very best wishes

 

Mike

 

 

 

 

Community Member

Hi,first off remove the

Hi,

first off remove the default gateway address as it's wrong not required and won't help. Have you confirmed the workstations have ip addresses on the same network?

try pinging the workstations from the switch and check they are in the arp cache.

regards

ken

Bronze

As said, it's most likely the

As said, it's most likely the interface is shutdown (Assuming you have established a console session to the switch).

It's also a good idea to encrypt your passwords to prevent 'shoulder surfing'!

Martin

 

 

Community Member

Turns out I had to force an

Turns out I had to force an IP address on the host (didn't think I had to).

 

Thanks for the assist everyone.  I'll go bury my head in shame.  :)

Bronze

What you mean is you had to

What you mean is you had to manually assign an address, which you will have to seen as you don't have a DHCP server. The Windows client would have had an 'APIPA'.

Martin

486
Views
0
Helpful
6
Replies
CreatePlease to create content