Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can't ping from core switch to other VLANs.

Hi all,

Here is my network diagram:

router.on.a.stick.jpg

From the core switch, I can only ping to vlan 1 (10.65.0.0/24). I can't ping to other vlans (2 & 3). I'm using Router-on-a-stick configuration. This is just a lab environment for practice for a newbie like me..

Any help will be much appreciated...

7 REPLIES
New Member

Re: Can't ping from core switch to other VLANs.

please attach the configs of your core switch and your router. Looking at your diagram I think you might be missing sub interfaces for the other two vlans on your router.

New Member

Re: Can't ping from core switch to other VLANs.

Core_Switch#show run
Building configuration...

Current configuration : 1521 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Core_Switch
!
!
!

username cisco\admintest privilege 15 password 7 0822455D0A16
!
!
!
no ip domain-lookup
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 10.65.0.6 255.255.255.0
!
ip classless
!
!
!
line con 0
line vty 0 4
login local
line vty 5 15
login local
!
!
!
end

=======================================

Router1#show run
Building configuration...

Current configuration : 2111 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router1
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
username cisco\admintest privilege 15 password 7 0822455D0A16
!
!
!
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex full
speed 100
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 10.65.0.1 255.255.255.0
!
interface FastEthernet0/1.2
encapsulation dot1Q 2
ip address 10.65.1.1 255.255.255.0
!
interface FastEthernet0/1.3
encapsulation dot1Q 3
ip address 10.65.2.1 255.255.255.0
!
interface Serial0/0/0
no ip address
!
interface Serial0/0/1
no ip address
shutdown
!
interface Serial0/1/0
no ip address
shutdown
!
interface Serial0/1/1
no ip address
shutdown
!
interface FastEthernet1/0
switchport mode access
shutdown
!
interface FastEthernet1/1
switchport mode access
shutdown
!
interface FastEthernet1/2
switchport mode access
shutdown
!
interface FastEthernet1/3
switchport mode access
shutdown
!
interface FastEthernet1/4
switchport mode access
shutdown
!
interface FastEthernet1/5
switchport mode access
shutdown
!
interface FastEthernet1/6
switchport mode access
shutdown
!
interface FastEthernet1/7
switchport mode access
shutdown
!
interface FastEthernet1/8
switchport mode access
shutdown
!
interface FastEthernet1/9
switchport mode access
shutdown
!
interface FastEthernet1/10
switchport mode access
shutdown
!
interface FastEthernet1/11
switchport mode access
shutdown
!
interface FastEthernet1/12
switchport mode access
shutdown
!
interface FastEthernet1/13
switchport mode access
shutdown
!
interface FastEthernet1/14
switchport mode access
shutdown
!
interface FastEthernet1/15
switchport mode access
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
line con 0
line vty 0 4
logging synchronous
login local
line vty 5 15
logging synchronous
login local
!
!
!
end

New Member

Re: Can't ping from core switch to other VLANs.

Hi,

can you ping from your servers the gateway of their vlans?

did you create Layer 2 vlans on your coreswitch?

New Member

Re: Can't ping from core switch to other VLANs.

Yes, I can..

I think, I did..

======================================

Core_Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gig0/1, Gig0/2
2    USERS                            active   
3    SERVERS                          active   
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0  
1003 tr    101003     1500  -      -      -        -    -        0      0  
1004 fdnet 101004     1500  -      -      -        ieee -        0      0  
1005 trnet 101005     1500  -      -      -        ibm  -        0      0 

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

New Member

Re: Can't ping from core switch to other VLANs.

maybe it doesn't work in packet tracer.. it may work in lab enviroments with real equipments, i think...

Re: Can't ping from core switch to other VLANs.

Hi,

Use traceroute and ping while specifying the source IP address.

New Member

Re: Can't ping from core switch to other VLANs.

i've fixed it.. i added a static routes for vlan 2 & 3 in the core switch..

Core_Switch(config)#ip routing

Core_Switch(config)#ip route 10.65.1.0 255.255.255.0 10.65.0.1
Core_Switch(config)#ip route 10.65.2.0 255.255.255.0 10.65.0.1

2432
Views
0
Helpful
7
Replies