Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can't ping hosts on same vlan over switches

Good morning,

 

  Trying to ping hosts on the same vlan (vlan 10) across a pair of 2950s.  Oddly, each host cannot even ping its own switch or vice versa.  Here are the shows:

 

Switch_1:

Switch_1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID                    Local Intrfce     Holdtme    Capability  Platform          Port ID
Switch_2.paquin.com       Fas 0/23           151          S I        WS-C2950-2   Fas 0/23

 

Switch_1#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
Vlan1                      192.168.10.1    YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES unset  down                  down
FastEthernet0/2            unassigned      YES unset  up                    up          (host 192.168.10.3)
FastEthernet0/3            unassigned      YES unset  down                  down
FastEthernet0/4            unassigned      YES unset  down                  down
FastEthernet0/5            unassigned      YES unset  down                  down
FastEthernet0/6            unassigned      YES unset  down                  down
FastEthernet0/7            unassigned      YES unset  down                  down
FastEthernet0/8            unassigned      YES unset  down                  down
FastEthernet0/9            unassigned      YES unset  down                  down
FastEthernet0/10           unassigned      YES unset  down                  down
FastEthernet0/11           unassigned      YES unset  down                  down
FastEthernet0/12           unassigned      YES unset  down                  down
FastEthernet0/13           unassigned      YES unset  down                  down
FastEthernet0/14           unassigned      YES unset  down                  down
FastEthernet0/15           unassigned      YES unset  down                  down
FastEthernet0/16           unassigned      YES unset  down                  down
FastEthernet0/17           unassigned      YES unset  down                  down
FastEthernet0/18           unassigned      YES unset  down                  down
FastEthernet0/19           unassigned      YES unset  down                  down
FastEthernet0/20           unassigned      YES unset  down                  down
FastEthernet0/21           unassigned      YES unset  down                  down
FastEthernet0/22           unassigned      YES unset  down                  down
FastEthernet0/23           unassigned      YES unset  up                       up          (trunk port)
FastEthernet0/24           unassigned      YES unset  down                  down

 

Switch_1#show vlan br

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                            active    Fa0/16, Fa0/17, Fa0/18, Fa0/19, Fa0/20, Fa0/21, Fa0/22, Fa0/24
10   DECK                            active    Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5
20   OPS                              active    Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10
30   ENG                              active    Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15
1002 fddi-default                   act/unsup
1003 token-ring-default          act/unsup
1004 fddinet-default               act/unsup
1005 trnet-default                  act/unsup

 

Switch_1#show vtp status
VTP Version                     : 2
Configuration Revision          : 3
Maximum VLANs supported locally : 128
Number of existing VLANs        : 8
VTP Operating Mode              : Server
VTP Domain Name                 : paquin.com
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x23 0xDE 0xEC 0xAD 0x40 0xBD 0x2E 0xD3
Configuration last modified by 192.168.10.1 at 3-1-93 07:25:05
Local updater ID is 192.168.10.1 on interface Vl1 (lowest numbered VLAN interface found)

 

Switch_1#show mac-address-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
 All    0011.bbb0.99c0    STATIC      CPU
 All    0100.0ccc.cccc    STATIC      CPU
 All    0100.0ccc.cccd    STATIC      CPU
 All    0100.0cdd.dddd    STATIC      CPU
  10    0011.bbde.d2d7    DYNAMIC     Fa0/23
  10    047d.7ba1.42ab    DYNAMIC     Fa0/23
  10    b827.ebeb.b987    DYNAMIC     Fa0/2    (host mac, verified correct)
   1    0011.bbde.d2c0    DYNAMIC     Fa0/23
   1    0011.bbde.d2d7    DYNAMIC     Fa0/23
  20    0011.bbde.d2d7    DYNAMIC     Fa0/23
  30    0011.bbde.d2d7    DYNAMIC     Fa0/23
Total Mac Addresses for this criterion: 11

 

Switch_1#ping 192.168.10.3 (trying to ping the host, ip is hard-coded)

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

Trying to ping the Switch, I get destination host unreachable (0% loss)

 

Switch_2:

 

Switch_2#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID                        Local Intrfce     Holdtme    Capability  Platform               Port ID
Switch_1.paquin.com         Fas 0/23           172          S I          WS-C2950-2        Fas 0/23
Switch_3                          Fas 0/24           143          S I           WS-C3550-2        Fas 0/23

 

Switch_2#show ip int br
Interface                  IP-Address      OK? Method Status      Protocol
Vlan1                      192.168.20.1    YES NVRAM   up         up
FastEthernet0/1            unassigned       YES unset  up         up      (hard-coded on host 192.168.20.2)
FastEthernet0/2            unassigned       YES unset  down     down
FastEthernet0/3            unassigned       YES unset  down     down
FastEthernet0/4            unassigned       YES unset  down     down
FastEthernet0/5            unassigned       YES unset  down     down
FastEthernet0/6            unassigned       YES unset  down     down
FastEthernet0/7            unassigned       YES unset  down     down
FastEthernet0/8            unassigned       YES unset  down     down
FastEthernet0/9            unassigned       YES unset  down     down
FastEthernet0/10           unassigned      YES unset  down     down
FastEthernet0/11           unassigned      YES unset  down     down
FastEthernet0/12           unassigned      YES unset  down     down
FastEthernet0/13           unassigned      YES unset  down     down
FastEthernet0/14           unassigned      YES unset  down     down
FastEthernet0/15           unassigned      YES unset  down     down
FastEthernet0/16           unassigned      YES unset  down     down
FastEthernet0/17           unassigned      YES unset  down     down
FastEthernet0/18           unassigned      YES unset  down     down
FastEthernet0/19           unassigned      YES unset  down     down
FastEthernet0/20           unassigned      YES unset  down     down
FastEthernet0/21           unassigned      YES unset  down     down
FastEthernet0/22           unassigned      YES unset  down     down
FastEthernet0/23           unassigned      YES unset  up         up      (trunk port)
FastEthernet0/24           unassigned      YES unset  up         up      (trunk port, connected to a 3950 switch)

 

Switch_2#show vlan br

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                             active    Fa0/16, Fa0/17, Fa0/18, Fa0/19, Fa0/20, Fa0/21, Fa0/22
10   DECK                             active    Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5
20   OPS                               active    Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10
30   ENG                               active    Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15
1002 fddi-default                    act/unsup
1003 token-ring-default           act/unsup
1004 fddinet-default                act/unsup
1005 trnet-default                   act/unsup

 

Switch_2#show vtp status
VTP Version                     : 2
Configuration Revision          : 3
Maximum VLANs supported locally : 128
Number of existing VLANs        : 8
VTP Operating Mode              : Client
VTP Domain Name                 : paquin.com
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x23 0xDE 0xEC 0xAD 0x40 0xBD 0x2E 0xD3
Configuration last modified by 192.168.10.1 at 3-1-93 07:25:05

 

Switch_2#show mac-address-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
 All    0011.bbde.d2c0    STATIC      CPU
 All    0100.0ccc.cccc    STATIC      CPU
 All    0100.0ccc.cccd    STATIC      CPU
 All    0100.0cdd.dddd    STATIC      CPU
   1    0011.bb7d.5997    DYNAMIC     Fa0/24
   1    0011.bbb0.99d7    DYNAMIC     Fa0/23
  10    0011.bb7d.5997    DYNAMIC     Fa0/24
  10    047d.7ba1.42ab    DYNAMIC     Fa0/1    (host mac, verified correct)
  10    b827.ebeb.b987    DYNAMIC     Fa0/23
  20    0011.bb7d.5997    DYNAMIC     Fa0/24
  30    0011.bb7d.5997    DYNAMIC     Fa0/24
Total Mac Addresses for this criterion: 11

 

Switch_2#ping 192.168.20.2 (trying to ping the host, ip is hard-coded)

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

Destination host unreachable when host trying to ping Switch_2

 

The switches are connected with a crossover cable.

Any other information I should supply?

 

Thanks,

 

Marc

2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

In switch 1 you have SVI for

In switch 1 you have SVI for Vlan1 192.168.10.1 but the access port is assigned to vlan 10 having a host 192.168.10.3. Please create vlan 10 SVI with 192.168.10.1 and it should be able to ping the connected host in vlan 10.

Similarly in Switch2, create vlan 10 SVI inteface with an IP address from the same subnet 192.168.10.0/24. And also configure the connected host from this same IP range. (not from 192.168.20.0/24).

 

Regards,

Kumar

New Member

Hi Marc,  Both ip are in

Hi Marc,

 

 

Both ip are in different subnet with out having a layer 3 device you cant ping between each other ..Please let me know have you connected your switch with any router or layer 3 switch

 

6 REPLIES
New Member

 Hi paquinjrm ,       It

 

Hi 

       It would be nice if  you post the output of following commands
 
 1.  show runnig-config command output for both swithes
2. show interfaces fastEthernet 0/23 trunk  for both switches
3.  Ip address and mask details of both the hosts 
New Member

Host 1: ip: 192.168.10.3    

Host 1: 

ip: 192.168.10.3     mask: 255.255.255.0     gateway:192.168.10.1

 

Host 2: 

ip: 192.168.20.2     mask: 255.255.255.0     gateway:192.168.20.1

 

Switch_1:

 

Switch_1#show running-config

Building configuration...

Current configuration : 1934 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch_1
!
enable secret 5 $1$6Q1L$tvd8C55hnxUo482I/LL3u/
!
username marc password 0 cisco
ip subnet-zero
!
no ip domain-lookup
ip domain-name paquin.com
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 10
!
interface FastEthernet0/2
 switchport access vlan 10
!
interface FastEthernet0/3
 switchport access vlan 10
!
interface FastEthernet0/4
 switchport access vlan 10
!
interface FastEthernet0/5
 switchport access vlan 10
!
interface FastEthernet0/6
 switchport access vlan 20
!
interface FastEthernet0/7
 switchport access vlan 20
!
interface FastEthernet0/8
 switchport access vlan 20
!
interface FastEthernet0/9
 switchport access vlan 20
!
interface FastEthernet0/10
 switchport access vlan 20
!
interface FastEthernet0/11
 switchport access vlan 30
!
interface FastEthernet0/12
 switchport access vlan 30
!
interface FastEthernet0/13
 switchport access vlan 30
!
interface FastEthernet0/14
 switchport access vlan 30
!
interface FastEthernet0/15
 switchport access vlan 30
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
 switchport mode trunk
!
interface FastEthernet0/24
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.10.1 255.255.255.0
 no ip route-cache
!
ip http server
!
line con 0
 exec-timeout 0 0
 password cisco
 logging synchronous
line vty 0 4
 exec-timeout 30 0
 password cisco
 login local
 transport input telnet ssh
line vty 5 15
 exec-timeout 30 0
 password cisco
 login local
 transport input telnet ssh
!
!
end

 

Switch_1#show interfaces fastEthernet 0/23


FastEthernet0/23 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0011.bbb0.99d7 (bia 0011.bbb0.99d7)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 100BaseTX
  input flow-control is unsupported output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1000 bits/sec, 3 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     32637 packets input, 3019724 bytes, 0 no buffer
     Received 31559 broadcasts (30430 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 30425 multicast, 0 pause input
     0 input packets with dribble condition detected
     2859 packets output, 297693 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

 

Switch_2:

 

Switch_2#show running-config

Building configuration...

Current configuration : 1961 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch_2
!
enable secret 5 $1$C1vV$wL/rG/zP.EzrsYwHAXMXD.
!
username marc password 0 cisco
ip subnet-zero
!
ip domain-name paquin.com
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
 --More--
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 10
!
interface FastEthernet0/2
 switchport access vlan 10
!
interface FastEthernet0/3
 switchport access vlan 10
!
interface FastEthernet0/4
 switchport access vlan 10
!
interface FastEthernet0/5
 switchport access vlan 10
!
interface FastEthernet0/6
 switchport access vlan 20
!
interface FastEthernet0/7
 switchport access vlan 20
!
interface FastEthernet0/8
 switchport access vlan 20
!
interface FastEthernet0/9
 switchport access vlan 20
!
interface FastEthernet0/10
 switchport access vlan 20
!
interface FastEthernet0/11
 switchport access vlan 30
!
interface FastEthernet0/12
 switchport access vlan 30
!
interface FastEthernet0/13
 switchport access vlan 30
!
interface FastEthernet0/14
 switchport access vlan 30
!
interface FastEthernet0/15
 switchport access vlan 30
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
 switchport mode trunk
!
interface FastEthernet0/24
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.20.1 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.20.1
ip http server
banner motd ^C
********
Switch_2
********^C
!
line con 0
 exec-timeout 30 0
 logging synchronous
line vty 0 4
 exec-timeout 30 0
 password cisco
 login
 transport input telnet ssh
line vty 5 15
 exec-timeout 30 0
 password cisco
 login
 transport input telnet ssh
!
!
end

 

Switch_2#show interfaces fastEthernet 0/23

FastEthernet0/23 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0011.bbde.d2d7 (bia 0011.bbde.d2d7)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 100BaseTX
  input flow-control is unsupported output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:19, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 1000 bits/sec, 3 packets/sec
     2917 packets input, 303919 bytes, 0 no buffer
     Received 1771 broadcasts (959 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 959 multicast, 0 pause input
     0 input packets with dribble condition detected
     33672 packets output, 3093977 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

New Member

In switch 1 you have SVI for

In switch 1 you have SVI for Vlan1 192.168.10.1 but the access port is assigned to vlan 10 having a host 192.168.10.3. Please create vlan 10 SVI with 192.168.10.1 and it should be able to ping the connected host in vlan 10.

Similarly in Switch2, create vlan 10 SVI inteface with an IP address from the same subnet 192.168.10.0/24. And also configure the connected host from this same IP range. (not from 192.168.20.0/24).

 

Regards,

Kumar

New Member

That did the trick.  The

That did the trick.  The material I learned from didn't specify having to duplicate the IP range on switches when routers are not used.

 

Thanks for the help yes

New Member

Hi Marc,  Both ip are in

Hi Marc,

 

 

Both ip are in different subnet with out having a layer 3 device you cant ping between each other ..Please let me know have you connected your switch with any router or layer 3 switch

 

New Member

The switches were not

The switches were not connected to a router. I was brushing up on VTP at the L2 device before moving on to VTP through routers.

 

Thanks for the assist.smiley

12586
Views
0
Helpful
6
Replies