Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Can't ping the default gateway

Hi Guys,

This would probably sound like a stupid question but it took at least 2 hours of my time so far. I have a 3750 switch where a router and a server is connected. From the switch I can ping the router and server with no issue (directely connected). But from the server I am not able to ping the router. The router and the server are in the same subnet. The router is configured as the default router for the server. I am not able to ping the server from the router either. Here's the output of the ip route from the router. The server IP address is 10.1.200.21 and the router IP address is 10.10.200.1

     10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks

C       10.1.30.0/24 is directly connected, FastEthernet0/0.30

C       10.1.20.0/24 is directly connected, FastEthernet0/0.20

C       10.10.33.0/25 is directly connected, Serial0/2/0.1

C       10.10.32.1/32 is directly connected, Loopback0

O       10.10.32.2/32 [110/65] via 10.10.33.2, 02:33:32, Serial0/2/0.1

O       10.10.32.3/32 [110/65] via 10.10.33.130, 02:33:32, Serial0/2/0.2

C       10.10.33.128/25 is directly connected, Serial0/2/0.2

C       10.1.200.0/24 is directly connected, FastEthernet0/0.1

Could you please let me know what am I missing.

Thanks,

MK

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Can't ping the default gateway

He got it from your ping result

HQ_Rtr#ping

Protocol [ip]:

Target IP address: 10.2.200.1

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: fastethernet0/0.1

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.2.200.1, timeout is 2 seconds:

Packet sent with a source address of 10.1.200.1

.....

Success rate is 0 percent (0/5)

I believe your problem is that you're not allowing vlan 1 over the trunk. Allow that and you should be good....

John

HTH, John *** Please rate all useful posts ***
14 REPLIES
Bronze

Can't ping the default gateway

Sorry the router IP address is 10.1.200.1

Can't ping the default gateway

Are you tagging traffic from fa0/0.1? Can you post the config of that interface? My first thought is to try to tag the traffic with your native vlan since you made a subinterface out of it.

int fa0/0.1

encapsulation dot1q native

HTH, John *** Please rate all useful posts ***

Re: Can't ping the default gateway

The router does not have a route back to the server.

You can try to test ping 10.1.200.1 source FastEthernet0/0.1, if it fails this is the issue.

Dan

Re: Can't ping the default gateway

The switch and the server are on 10.1.200.0/24 ?

Dan

Bronze

Can't ping the default gateway

The server is directely connected to the switch port fastethernet 1/0/1 and there's a trunk from the switch to the router port fastethernet 1/0/24. And the test ping fails:

HQ_Rtr#ping

Protocol [ip]:

Target IP address: 10.2.200.1

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: fastethernet0/0.1

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.2.200.1, timeout is 2 seconds:

Packet sent with a source address of 10.1.200.1

.....

Success rate is 0 percent (0/5)

Can't ping the default gateway

If this is the Hq_Rtr routing table :

     10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks

C       10.1.30.0/24 is directly connected, FastEthernet0/0.30

C       10.1.20.0/24 is directly connected, FastEthernet0/0.20

C       10.10.33.0/25 is directly connected, Serial0/2/0.1

C       10.10.32.1/32 is directly connected, Loopback0

O       10.10.32.2/32 [110/65] via 10.10.33.2, 02:33:32, Serial0/2/0.1

O       10.10.32.3/32 [110/65] via 10.10.33.130, 02:33:32, Serial0/2/0.2

C       10.10.33.128/25 is directly connected, Serial0/2/0.2

C       10.1.200.0/24 is directly connected, FastEthernet0/0.1

You miss a route to 10.2.200.0/24 toward the 3750

If I understood well   :

(router) ----- 10.1.200.0----------------(3750) ------ 10.2.200.0 ----- server

Dan

New Member

Can't ping the default gateway

Can you post the config of the 2 switch ports and the 1 router interface?

Bronze

Re: Can't ping the default gateway

Dan,

Where did you get the 10.2.200.0 subnet?

Here's the config for the port (trunk) going from 3750 to the HQ RTR:

interface FastEthernet1/0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,30,100,102,202

switchport mode trunk

duplex full

speed 100

interface FastEthernet0/0.1

description VOICE SERVER VLAN

encapsulation dot1Q 1 native

ip address 10.1.200.1 255.255.255.0

router ospf 1

log-adjacency-changes

network 10.1.20.0 0.0.0.255 area 0

network 10.1.30.0 0.0.0.255 area 0

network 10.10.32.1 0.0.0.0 area 0

network 10.10.33.0 0.0.0.255 area 0

Re: Can't ping the default gateway

He got it from your ping result

HQ_Rtr#ping

Protocol [ip]:

Target IP address: 10.2.200.1

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: fastethernet0/0.1

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.2.200.1, timeout is 2 seconds:

Packet sent with a source address of 10.1.200.1

.....

Success rate is 0 percent (0/5)

I believe your problem is that you're not allowing vlan 1 over the trunk. Allow that and you should be good....

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Can't ping the default gateway

Yup looks like missing vlan on trunk, assuming the server is on vlan 1:

conf t

interface FastEthernet1/0/24

switchport trunk allowed vlan add 1

Bronze

Re: Can't ping the default gateway

Thanks John,

That was the issue. After allowing Vlan 1 over the trunk everything started working. Your help is very much appreciated.

MK

Bronze

Re: Can't ping the default gateway

Thanks Colin, you were very helpful.

Bronze

Re: Can't ping the default gateway

I have got another question for you guys.

There's a router at the remotre site which is not able to ping the server either. Do I need a static route stating

ip route 10.1.200.0 255.255.255.0 Ser 0/2/0.1 ?

BR1#sh cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

HQ_Rtr           Ser 0/2/0.1        166         R S I     2811      Ser 0/2/0.1

SEP0023EB54104E  Fas 0/1/1          143           H       IP Phone  Port 1

SEP0023EB5410BE  Fas 0/1/0          143           H       IP Phone  Port 1

------------------------------------------------------------------------------------------

BR1# sh ip route

     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks

O       10.1.30.0/24 [110/65] via 10.10.33.1, 04:31:44, Serial0/2/0.1

O       10.1.20.0/24 [110/65] via 10.10.33.1, 04:31:44, Serial0/2/0.1

C       10.10.33.0/25 is directly connected, Serial0/2/0.1

O       10.10.32.1/32 [110/65] via 10.10.33.1, 04:51:17, Serial0/2/0.1

C       10.10.32.2/32 is directly connected, Loopback0

O       10.10.32.3/32 [110/129] via 10.10.33.1, 04:51:17, Serial0/2/0.1

C       10.1.120.0/24 is directly connected, Vlan120

C       10.1.130.0/24 is directly connected, Vlan130

O       10.10.33.128/25 [110/128] via 10.10.33.1, 04:51:18, Serial0/2/0.1

Can't ping the default gateway

Not quite , on HQ_Rtr

router ospf 1

net 10.1.200.1 0.0.0.0 area 0

Dan

35470
Views
10
Helpful
14
Replies
CreatePlease login to create content