Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

can't seem to get ip policy route-map working

Hi,

Anyone see what I'm doing wrong here?

interface FastEthernet0/0

......

ip policy route-map mytestroute

....

access-list 164 permit tcp host 192.168.1.20 any

!

route-map mytestroute permit 10

match ip address 164

set interface Dialer0

!

route-map mytestroute permit 20

TIA,

Lee

5 REPLIES
Hall of Fame Super Blue

Re: can't seem to get ip policy route-map working

Lee

Are you seeing matches on the access-list 164 ?

Perhaps you could post the full config ?

Jon

New Member

Re: can't seem to get ip policy route-map working

Hi Jon,

It occured to me over the weekend what the problem likely is.

Basically what I'm trying to do is,

I have 4 lines that are using CEF load balacing. I wanted to stop everyone except myself from using one of the lines so I can try and resolve a issue I am having with static PAT (port forwarding).

Basically what I had done is removed one of the default routes and a nat route-map for the line I want to stop people using then set up a IP policy on the FastEthernet0/0 interface for my IP address telling it to use that particular Dialer.

It occured to me the reason its not working is because there is no default route defined for the Dialer.

So I guess the question is how can you define a default route but only for a paricular IP address to use (myself). Is this possible?

TIA,

Lee

Hall of Fame Super Blue

Re: can't seem to get ip policy route-map working

Lee

Is it not possible to use the "set ip next-hop ..." command rather than the "set interface" and then use the next-hop address of the upstream router to your dialer0 interface (if you know it !).

Jon

New Member

Re: can't seem to get ip policy route-map working

Hi Jon,

I'm not sure how this will help me as all lines connect to the same route at our ISP.

Lee

New Member

Re: can't seem to get ip policy route-map working

Would this work? before I break sommat (again lol)

If I put back my 4 default routes like so

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

ip route 0.0.0.0 0.0.0.0 Dialer3

but then only define 3 route maps like so

ip nat inside source route-map rmd0 interface Dialer0 overload

ip nat inside source route-map rmd1 interface Dialer1 overload

ip nat inside source route-map rmd2 interface Dialer2 overload

My ACL's are

access-list 6 permit 192.168.1.0 0.0.0.255

access-list 164 permit host 192.168.1.100 any

Route maps are

! rmd3 not used for now

route-map rmd3 permit 10

match ip address 6

match interface Dialer3

!

route-map rmd2 permit 10

match ip address 6

match interface Dialer2

!

route-map rmd1 permit 10

match ip address 6

match interface Dialer1

!

route-map rmd0 permit 10

match ip address 6

match interface Dialer0

!

route-map mytestroute permit 10

match ip address 164

set interface Dialer3

!

route-map mytestroute permit 20

!

then on the main ethernet interface

interface FastEthernet0/0

ip policy route-map mytestroute

..

Lee.

179
Views
0
Helpful
5
Replies
CreatePlease to create content