Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't setup static route asa 5020 - get connected route exists

I am trying to setup a static route on a ASA 5520  for the inside interface.Keep getting error " Cannot add route, connected route exists"

The outside static route worked fine?

Thanks

Dave

Everyone's tags (1)
8 REPLIES
VIP Purple

What do you want to achieve?

What do you want to achieve? In general, you don't need static routes for all your directly attached networks/interfaces.


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
Hall of Fame Super Silver

I agree with Karsten that

I agree with Karsten that some explanation of what you are trying to achieve would be helpful. Also the detail of what you tried to configure along with the interface configuration might help us understand the issue.

 

HTH

 

Rick

New Member

Thanks for the response.This

Thanks for the response.

This ASA is in the middle of an external ASA and a 3750 switch.

I thought I would need a static for both 0.0.0.0 and the internal interface.

Its when I try to setup the internal interface I get the connection exist message.

Note the external interface is a C mask while the internal interfafe an network is a /23 mask.

 

VIP Purple

In that scenario a static

In that scenario a static route is needed. Probably you just configured it wrong.

route inside 10.10.10.0 255.255.254.0 10.10.1.2

In this example, 10.10.10.0 is the internal network behind the 3750 and 10.10.1.2 is the Next-hop IP of the 3750.

And make sure that you have the correct subnet-mask on the inside ASA interface.

--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

No matter how I setup the

No matter how I setup the internal static route I keep getting an error with message that the connected route already exists .

Again here are the details

Internal interface 172.16.100.250  \23

Next hop 172.16.100.254 \23   - Ciisco 2750 Switch 

Static Route  172.16.100.0\23 network Gateway is 172.16.100.254 \23

External route 0.0.0.0 0.0.0.0 172.16.3.1 (external interface) this seems to be working.

At least I didn't get an errors when I configure this one.

Again thanks

VIP Purple

If your internal switch is

If your internal switch is not configured as a router or L3-switch, then you don't need any static route. Are all your systems in the network 172.16.100.0/23? Then your systems are directly connected to the ASA and you are done. If there are other networks configured on the 3750, then you need a static route only for these networks.


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

I tried one more time  Inside

I tried one more time  

Inside interface  172.16.100.250 
Network  172.16.100.0/23
Gateway 172.16.100.254  ( switch IP) 

This time it didn't error off.

So now I think I may have a rules issue.

On the switch side I can ping up to the ASS internal port (172.16.100.250) but not to 172.16.3.0 network

 

On the ASA side, I can ping the interface 172.16.100.250 but not the switch 172.16.100.254.

 

Again thanks

VIP Purple

If you didn't get an error,

If you didn't get an error, then you did something wrong. And that's probably the reason for the following problems. But unless you show us exactly what you did and what your setup is, there is no way to help any further.


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
696
Views
0
Helpful
8
Replies
CreatePlease login to create content