Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't SSH into my new Catalyst 2960-S Switch

Hi, Title describes my problem.

I can use Putty to SSH into my new switch (Directly connected to my laptop  with ethernet cable), but I cant log into my switch.

Sent username "admin"

admin@192.168.251.1's password:

Access denied

It doesnt like my password, but I have only set 1 password (king) on this switch. I've configured 3 other switches with SSH and had no problem. Been trouble shooting for awhile and It'd be great if I could have a 2nd set of eyes take a peek, it may be something simple im missing. Also, my running config is attached. THANK YOU!!

Everyone's tags (5)
2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Can't SSH into my new Catalyst 2960-S Switch

Hi,

try configuring -

aaa new-model

aaa authentication login default local

its should work... Hopefully

Regards,

Pawan Sharma

http://www.ebrahma.com

I know this is an old thread,

I know this is an old thread, but for future arrivals running into a similar issue:

You can fix it via the aaa method above, or often times, under line vty 0 15, you just need to put 'login local'.

Just the 'login' command like in Nick's config will cause the issue reported above, but configuring 'login local' under the lines will address this as well.

You can only use the 'login local' command if the router is in 'no aaa new-model'.

-Tony

8 REPLIES

Can't SSH into my new Catalyst 2960-S Switch

Nick,

I believe all you'll need to do is enable aaa. Try:

aaa new-model

Then try to connect with your username and password.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Thank you guys, I was just

Thank you guys, I was just faced with the same problem and above suggestion helped me out. Thanks again.

New Member

Can't SSH into my new Catalyst 2960-S Switch

Hi,

try configuring -

aaa new-model

aaa authentication login default local

its should work... Hopefully

Regards,

Pawan Sharma

http://www.ebrahma.com

New Member

Can't SSH into my new Catalyst 2960-S Switch

Perfect. The below commands solved my issue. Thank y'all so much for taking a look. Have a great day!

aaa new-model

aaa authentication login default local

New Member

Can't SSH into my new Catalyst 2960-S Switch

Hey Nick,

I am glad that those commands solved your problem. Everybody here is happy to help and so I am.

Regards,

Pawan Sharma

http://www.ebrahma.com

New Member

Re: Can't SSH into my new Catalyst 2960-S Switch

Thank you from me as well. Total newb here and was heartbroken when I knew I had everything set spot on, but I couldn't connect. I have no idea why those commands did the trick, but they did and now I can SSH into my switch!

Thanks again!

Dave

I know this is an old thread,

I know this is an old thread, but for future arrivals running into a similar issue:

You can fix it via the aaa method above, or often times, under line vty 0 15, you just need to put 'login local'.

Just the 'login' command like in Nick's config will cause the issue reported above, but configuring 'login local' under the lines will address this as well.

You can only use the 'login local' command if the router is in 'no aaa new-model'.

-Tony

New Member

Thanks Tony, you are

Thanks Tony, you are absolutely correct. There will likely be someone who comes across this thread and this will be helpful. This post was from when I first got into the field! :)

-Nick Chenault

17711
Views
25
Helpful
8
Replies
CreatePlease login to create content