Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CANNOT_BUNDLE2 MTU of Gi2/0/37 is 9000, Gi1/0/37 is 1500

Hi,

I have this issue and I have to admit I am not sure what should I do.

So I have Cisco 3750 stack and ASA 5510 I would like to connect through LACP

3750 cross stack 1/0/37 and 2/0/37 -> Port-channel 33

ASA LACP Po2.150

                - et0/2

                -et0/3

But immediately when I make this configuration I am getting this error 

Jun  3 16:21:57: %EC-5-CANNOT_BUNDLE2: Gi2/0/37 is not compatible with Gi1/0/37 and will be suspended (MTU of Gi2/0/37 is 9000, Gi1/0/37 is 1500) (vvlansw06-2)

But as you can see, all interface are setting with MTU 1500.

 

But if I don't use command "switchport trunk allowed vlan 150" everything works.  How is it possible, I need to send through this trunk only this vlan I need to limited number of broadcast.

And how is it possible that this command cause this error ? 

C3750

------------------------------

vvlansw06#sh system mtu 

 

System MTU size is 1500 bytes

System Jumbo MTU size is 1500 bytes

System Alternate MTU size is 1500 bytes

Routing MTU size is 1500 bytes

vvlansw06#

 

interface Port-channel33

 description VPN_ASA_HB

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 150

 switchport mode trunk

end

 

interface GigabitEthernet1/0/37

 description VPN_ASA_HB

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 150

 switchport mode trunk

 spanning-tree portfast

 channel-group 33 mode active

 

interface GigabitEthernet2/0/37

 description VPN_ASA_HB

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 150

 switchport mode trunk

 spanning-tree portfast

 channel-group 33 mode active

Port-channel33 is up, line protocol is up (connected) 

  Hardware is EtherChannel, address is e8b7.4852.e3a5 (bia e8b7.4852.e3a5)

  Description: VPN_ASA_HB

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, link type is auto, media type is unknown

  Media-type configured as  connector

  input flow-control is off, output flow-control is unsupported 

  Members in this channel: Gi1/0/37 

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:01, output hang never

  Last clearing of "show interface" counters 4d07h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1006194503

 

GigabitEthernet1/0/37 is up, line protocol is up (connected) 

  Hardware is Gigabit Ethernet, address is e8b7.4852.e3a5 (bia e8b7.4852.e3a5)

  Description: VPN_ASA_HB

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

  Media-type configured as  connector

  input flow-control is off, output flow-control is unsupported 

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:22, output 00:00:03, output hang never

  Last clearing of "show interface" counters 4d07h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 255

 

GigabitEthernet2/0/37 is up, line protocol is down (suspended) 

  Hardware is Gigabit Ethernet, address is e8b7.4851.8ba5 (bia e8b7.4851.8ba5)

  Description: VPN_ASA_HB

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

  Media-type configured as  connector

  input flow-control is off, output flow-control is unsupported 

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 2y12w, output 00:12:17, output hang never

  Last clearing of "show interface" counters 4d07h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 61

 

 

Group: 33 

----------

Group state = L2 

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Minimum Links: 0

        Ports in the group:

        -------------------

Port: Gi1/0/37

------------

 

Port state    = Up Mstr Assoc In-Bndl 

Channel group = 33          Mode = Active          Gcchange = -

Port-channel  = Po33        GC   =   -             Pseudo port-channel = Po33

Port index    = 0           Load = 0x00            Protocol =   LACP

 

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

 

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Gi1/0/37  SA      bndl      32768         0x21      0x21    0x126       0x3D  

 

Partner's information:

          

                  LACP port                        Admin  Oper   Port    Port

Port      Flags   Priority  Dev ID          Age    key    Key    Number  State

Gi1/0/37  SA      32768     a44c.1177.007a  17s    0x0    0x2    0x4     0x3D  

 

Age of the port in the current state: 0d:00h:40m:12s

 

Port: Gi2/0/37

------------

 

Port state    = Up Cnt-bndl Suspend Not-in-Bndl 

Channel group = 33          Mode = Active          Gcchange = -

Port-channel  = null        GC   =   -             Pseudo port-channel = Po33

Port index    = 0           Load = 0x00            Protocol =   LACP

 

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

 

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Gi2/0/37  SA      susp      32768         0x21      0x0     0x226       0x45  

 

Age of the port in the current state: 0d:00h:20m:57s

 

Probable reason: MTU of Gi2/0/37 is 9000, Gi1/0/37 is 1500

        Port-channels in the group: 

        ---------------------------

 

Port-channel: Po33    (Primary Aggregator)

 

------------

 

Age of the Port-channel   = 0d:00h:42m:24s

Logical slot/port   = 10/33          Number of ports = 1

HotStandBy port = null 

Port state          = Port-channel Ag-Inuse 

Protocol            =   LACP

Port security       = Disabled

 

Ports in the Port-channel: 

 

Index   Load   Port     EC state        No of bits

------+------+------+------------------+-----------

  0     00     Gi1/0/37 Active             0

 

Time since last port bundled:    0d:00h:40m:14s    Gi1/0/37

 

-----------------------

ASA

connect# sh run all | i mtu        

mtu VPN 1500

 

interface Port-channel2

!

interface Port-channel2.150

 description LAN/STATE Failover Interface

 vlan 150

!

!

interface Ethernet0/2

 channel-group 2 mode active

!

interface Ethernet0/3

 channel-group 2 mode active

!

Interface Port-channel2 "", is up, line protocol is up

  Hardware is EtherChannel/LACP, BW 100 Mbps, DLY 100 usec

    Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)

    Input flow control is unsupported, output flow control is off

    MAC address a44c.1177.007c, MTU not set

    IP address unassigned

  Members in this channel:

      Active:   Et0/3 

      Inactive: Et0/2 

Interface Port-channel2.150 "FAILOVER", is up, line protocol is up

  Hardware is EtherChannel/LACP, BW 100 Mbps, DLY 100 usec

    VLAN identifier 150

    Description: LAN/STATE Failover Interface

    MAC address a44c.1177.007c, MTU 1500

    IP address 10.90.22.201, subnet mask 255.255.255.248

  Traffic Statistics for "FAILOVER":

    24310302 packets input, 2489893984 bytes

    53074252 packets output, 29470503852 bytes

    6090480 packets dropped

 

Interface Ethernet0/2 "", is up, line protocol is up

  Hardware is i82546GB rev03, BW 100 Mbps, DLY 100 usec

    Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)

    Input flow control is unsupported, output flow control is off

    MAC address a44c.1177.007c, MTU not set

    IP address unassigned

    1971600089 packets input, 200370000339 bytes, 0 no buffer

    Received 437076592 broadcasts, 0 runts, 0 giants

    874304559 input errors, 0 CRC, 0 frame, 874304559 overrun, 0 ignored, 0 abort

    0 pause input, 0 resume input

    0 L2 decode drops

        10549967 packets output, 6060935772 bytes, 0 underruns

    0 pause output, 0 resume output

    0 output errors, 0 collisions, 8 interface resets

    0 late collisions, 0 deferred

    0 input reset drops, 0 output reset drops, 0 tx hangs

    input queue (blocks free curr/low): hardware (255/254)

    output queue (blocks free curr/low): hardware (255/253)

 

Interface Ethernet0/3 "", is up, line protocol is up

  Hardware is i82546GB rev03, BW 100 Mbps, DLY 100 usec

    Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)

    Input flow control is unsupported, output flow control is off

    MAC address a44c.1177.007d, MTU not set

    IP address unassigned

    1744354887 packets input, 139512113546 bytes, 0 no buffer

    Received 535379035 broadcasts, 0 runts, 0 giants

    897050895 input errors, 0 CRC, 0 frame, 897050895 overrun, 0 ignored, 0 abort

    0 pause input, 0 resume input

    0 L2 decode drops

    43414310 packets output, 24691626112 bytes, 0 underruns

    0 pause output, 0 resume output

    0 output errors, 0 collisions, 1 interface resets

    0 late collisions, 0 deferred

    0 input reset drops, 0 output reset drops, 0 tx hangs

    input queue (blocks free curr/low): hardware (255/246)

        output queue (blocks free curr/low): hardware (255/238)

------------------

 

 

Is there anything else what I can change? 

 

I have the second ASA and second 3750 stack and there is same configuration works. 

 

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Hi,Try removing  switchport

Hi,

Try removing  "switchport trunk allowed vlan 150" under the physical interfaces and po33.

Then shut po33 and then add  "switchport trunk allowed vlan 150"

now, no shut on interface po33.

This should apply  "switchport trunk allowed vlan 150" to both physical interfaces.

test again

HTH

5 REPLIES
VIP Super Bronze

Hi,Try removing  switchport

Hi,

Try removing  "switchport trunk allowed vlan 150" under the physical interfaces and po33.

Then shut po33 and then add  "switchport trunk allowed vlan 150"

now, no shut on interface po33.

This should apply  "switchport trunk allowed vlan 150" to both physical interfaces.

test again

HTH

New Member

ThanksI will try it later, it

Thanks a lot

It works, I did it exactly how you described and really it works.

 

 

 

VIP Super Bronze

Glad to help and thanks for

Glad to help and thanks for the rating and the feedback.

Hi There, Can you try hard

Hi There,

 

Can you try hard coding the MTU on both the interfaces on 3750?

 

HTH

Hitesh

New Member

I have thought it isn't

I have thought it isn't possible to change MTU on interface at least Cisco 3750. Am I wrong?

I found out the only way to change MTU is change system MTU.

92
Views
0
Helpful
5
Replies