cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
746
Views
0
Helpful
5
Replies

Cannot figure out why my 2nd switch wont ping router vlan

villard21
Level 1
Level 1

S1 can ping R1 vlan 99 192.168.99.1 and vlan 31 192.168.31.1, but S3 cannot ping R1 vlan 99 192.168.99.1 or vlan 33 192.168.33.1 and help please?

R1#sho run
Building configuration...

Current configuration : 1300 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R1
!
!
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO1941/K9 sn FTX152457PR
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.31
 description Accounting LAN
 encapsulation dot1Q 31
 ip address 192.168.31.1 255.255.255.0
!
interface GigabitEthernet0/1.33
 description Engineering Lan
 encapsulation dot1Q 33
 ip address 192.168.33.1 255.255.255.0
!
interface GigabitEthernet0/1.99
 description Management LAN
 encapsulation dot1Q 99
 ip address 192.168.99.1 255.255.255.0
!
interface Serial0/0/0
 description connection to R2
 ip address 172.16.12.1 255.255.255.252
 clock rate 128000
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0 
!
!
!
banner motd ^CAuth use only^C
!
!
!
!
line con 0
 password 7 0822455D0A16
 logging synchronous
 login
!
line aux 0
!
line vty 0 4
 password 7 0822455D0A16
 login
line vty 5 15
 login
!
!
!
end

-----------------------------------------------------------------------

S1#sho run
Building configuration...

Current configuration : 2195 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname S1
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode access
 shutdown
!
interface FastEthernet0/2
 switchport mode access
 shutdown
!
interface FastEthernet0/3
 switchport trunk allowed vlan 1-30,32,34-98,100-1001
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk allowed vlan 1-30,32,34-98,100-1001
 switchport mode access
 shutdown
!
interface FastEthernet0/5
 switchport mode trunk
!
interface FastEthernet0/6
 switchport access vlan 31
 switchport mode access
!
interface FastEthernet0/7
 switchport mode access
 shutdown
!
interface FastEthernet0/8
 switchport mode access
 shutdown
!
interface FastEthernet0/9
 switchport mode access
 shutdown
!
interface FastEthernet0/10
 switchport mode access
 shutdown
!
interface FastEthernet0/11
 switchport mode access
 shutdown
!
interface FastEthernet0/12
 switchport mode access
 shutdown
!
interface FastEthernet0/13
 switchport mode access
 shutdown
!
interface FastEthernet0/14
 switchport mode access
 shutdown
!
interface FastEthernet0/15
 switchport mode access
 shutdown
!
interface FastEthernet0/16
 switchport mode access
 shutdown
!
interface FastEthernet0/17
 switchport mode access
 shutdown
!
interface FastEthernet0/18
 switchport mode access
 shutdown
!
interface FastEthernet0/19
 switchport mode access
 shutdown
!
interface FastEthernet0/20
 switchport mode access
 shutdown
!
interface FastEthernet0/21
 switchport mode access
 shutdown
!
interface FastEthernet0/22
 switchport mode access
 shutdown
!
interface FastEthernet0/23
 switchport mode access
 shutdown
!
interface FastEthernet0/24
 switchport mode access
 shutdown
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 192.168.99.2 255.255.255.0
!
ip default-gateway 192.168.99.1
!
banner motd ^CAuth use only^C
!
line con 0
 password 7 0822455D0A16
 login
!
line vty 0 4
 password 7 0822455D0A16
 login
line vty 5 15
 login
!
!
end

----------------------------------------------------------------

S3#sho run
Building configuration...

Current configuration : 2195 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname S3
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode access
 shutdown
!
interface FastEthernet0/2
 switchport mode access
 shutdown
!
interface FastEthernet0/3
 switchport trunk allowed vlan 1-30,32,34-98,100-1001
 switchport mode trunk
!
interface FastEthernet0/4
 switchport mode access
 shutdown
!
interface FastEthernet0/5
 switchport mode access
 shutdown
!
interface FastEthernet0/6
 switchport mode access
 shutdown
!
interface FastEthernet0/7
 switchport mode access
 shutdown
!
interface FastEthernet0/8
 switchport mode access
 shutdown
!
interface FastEthernet0/9
 switchport mode access
 shutdown
!
interface FastEthernet0/10
 switchport mode access
 shutdown
!
interface FastEthernet0/11
 switchport mode access
 shutdown
!
interface FastEthernet0/12
 switchport mode access
 shutdown
!
interface FastEthernet0/13
 switchport mode access
 shutdown
!
interface FastEthernet0/14
 switchport mode access
 shutdown
!
interface FastEthernet0/15
 switchport mode access
 shutdown
!
interface FastEthernet0/16
 switchport mode access
 shutdown
!
interface FastEthernet0/17
 switchport mode access
 shutdown
!
interface FastEthernet0/18
 switchport access vlan 33
 switchport mode access
!
interface FastEthernet0/19
 switchport mode access
 shutdown
!
interface FastEthernet0/20
 switchport mode access
 shutdown
!
interface FastEthernet0/21
 switchport mode access
 shutdown
!
interface FastEthernet0/22
 switchport mode access
 shutdown
!
interface FastEthernet0/23
 switchport mode access
 shutdown
!
interface FastEthernet0/24
 switchport mode access
 shutdown
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 192.168.99.3 255.255.255.0
!
ip default-gateway 192.168.99.1
!
banner motd ^Cauth use onluy^C
!
line con 0
 password 7 0822455D0A16
 logging synchronous
 login
!
line vty 0 4
 password 7 0822455D0A16
 logging synchronous
 login
line vty 5 15
 login
!
!
end

1 Accepted Solution

Accepted Solutions

On S1 does fa0/5 connect to the router ?

If so then that means fa0/3 connects to fa0/3 on S3.

If you look at the configuration for both those ports you have not included either of the vlans you are having issues with in the "switchport trunk allowed vlan ...." command.

You need to add those vlans to the trunk link.

Jon

View solution in original post

5 Replies 5

nkarthikeyan
Level 7
Level 7

Could you please brief about the connectivity??

 

Is that R1-S1-S3 ?

 

 

Regards

Karthik

Yes it is R1-S1-S3, I know I must be over looking something. Thanks guys.

On S1 does fa0/5 connect to the router ?

If so then that means fa0/3 connects to fa0/3 on S3.

If you look at the configuration for both those ports you have not included either of the vlans you are having issues with in the "switchport trunk allowed vlan ...." command.

You need to add those vlans to the trunk link.

Jon

Thank you so much, I knew it was something so simple, sometimes I overlook the littlest things.

edit

Review Cisco Networking products for a $25 gift card