Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot FTP new IOS from PC to Switch

Hi all. I'm pretty new to Cisco equipment and I'm working on a lab where I am trying to load a new IOS onto a 3750V2 switch. 

Here are the details.

Network. /24

Switch IP 192.168.1.1

PC IP 192.168.1.3                  

Switch1.1#show run
Building configuration...

Current configuration : 3954 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch1.1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vlQ8$l6iwnwKA7aZMT0mbCkYr30
!
no aaa new-model
switch 1 provision ws-c3750v2-48ps
system mtu routing 1500
ip subnet-zero
!
!
!
!
crypto pki trustpoint TP-self-signed-1798202752
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1798202752
revocation-check none
rsakeypair TP-self-signed-1798202752
!
!
crypto pki certificate chain TP-self-signed-1798202752
certificate self-signed 01
  30820242 308201AB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31373938 32303237 3532301E 170D3933 30333031 30303031
  31365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 37393832
  30323735 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100F7D6 E9E3F51D 9ED18BAC 3FD06D8D 439E7CB8 604F73F7 53CA622D 3DD8FAB6
  60ABEBE2 8C745C62 C59D4A23 03232A21 ABAEF59B 31CC24FD 77064E79 A2B424B1
  E0EC73CA 7584B1FC F7096D9A D6F49DF2 DA37E957 A83431F2 CD2716C6 3E9874EC
  B4410434 88130B77 BC9B688B 9929BAE2 3ADD5392 1BD3780F 039C671B EFFB7371
  B5130203 010001A3 6A306830 0F060355 1D130101 FF040530 030101FF 30150603
  551D1104 0E300C82 0A537769 74636831 2E312E30 1F060355 1D230418 30168014
  4451F312 B52852CF 84DCA727 35139497 227B454A 301D0603 551D0E04 16041444
  51F312B5 2852CF84 DCA72735 13949722 7B454A30 0D06092A 864886F7 0D010104
  05000381 81000156 691C09A2 C41FFD82 82987E16 DF3C2A6F 60F09039 4D8671A9
  DC6B71F9 A24754B9 7550734E C8F6407F FE1B6986 12682B65 AECB55F0 A08F30FD
  82976A6D 39006E20 2C4173F3 C955B3D3 1FDD30D3 6C902358 4739033C 23784E16
  AD78ABC8 916FB850 4B5BB8A8 F2E3B0F4 62642B91 D9907517 753BC361 857ECE99
  EAD77454 803B
  quit
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet1/0/1
!
interface FastEthernet1/0/2
!
interface FastEthernet1/0/3
!
interface FastEthernet1/0/4
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
!
interface FastEthernet1/0/7
!
interface FastEthernet1/0/8
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
!
interface FastEthernet1/0/13
!
interface FastEthernet1/0/14
!
interface FastEthernet1/0/15
!
interface FastEthernet1/0/16
!
interface FastEthernet1/0/17
!
interface FastEthernet1/0/18
!
interface FastEthernet1/0/19
!
interface FastEthernet1/0/20
!
interface FastEthernet1/0/21
!
interface FastEthernet1/0/22
!
interface FastEthernet1/0/23
!
interface FastEthernet1/0/24
!
interface FastEthernet1/0/25
!
interface FastEthernet1/0/26
!
interface FastEthernet1/0/27
!
interface FastEthernet1/0/28
!
interface FastEthernet1/0/29
!
interface FastEthernet1/0/30
!
interface FastEthernet1/0/31
!
interface FastEthernet1/0/32
!
interface FastEthernet1/0/33
!
interface FastEthernet1/0/34
!
interface FastEthernet1/0/35
!
interface FastEthernet1/0/36
!
interface FastEthernet1/0/37
!
interface FastEthernet1/0/38
!
interface FastEthernet1/0/39
!
interface FastEthernet1/0/40
!
interface FastEthernet1/0/41
!
interface FastEthernet1/0/42
!
interface FastEthernet1/0/43
!
interface FastEthernet1/0/44
!
interface FastEthernet1/0/45
!
interface FastEthernet1/0/46
!
interface FastEthernet1/0/47
!
interface FastEthernet1/0/48
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
end

Switch1.1#copy ftp:192.168.1.3/c:\c3750-ipbasek9-mz.122-55.SE1 flash:c3750-ipbasek9-mz.122-55.SE1

Address or name of remote host [192.168.1.3]?

Source filename [192.168.1.3/c:\c3750-ipbasek9-mz.122-55.SE1]? c:\c3750-ipbasek9-mz.122-55.SE1

Destination filename [c3750-ipbasek9-mz.122-55.SE1]? flash:c3750-ipbasek9-mz.122-55.SE1

Accessing

ftp://192.168.1.3/c:\c3750-ipbasek9-mz.122-55.SE1

...

%Error opening

ftp://192.168.1.3/c:\c3750-ipbasek9-mz.122-55.SE1

(Undefined error)

I'm not sure what I'm doing wrong so I'm looking for help.  I'm connected into FA1/0/1 which was showing up/up.  I would really appreciate any help I can get.

For the record, I've also tried FileZilla which doesn't seem to want to connect to the switch either.  So maybe there is something with the config that I'm doing wrong.

Everyone's tags (2)
7 REPLIES
New Member

Re: Cannot FTP new IOS from PC to Switch

just for the hell of it..

conf t

int fa1/0/1

no shutdown

switchport mode access

switchport access vlan 1

end

conf t

int vlan 1

no shutdown

end

Can tyhe PC ping the switch?

Can the switch ping the PC?

You may also need to supply the username and password on the FTP command line from the switch.

Note: Your filezilla wont be able to ftp to the switch, the switch is ftping to the pc..

ftp:

[[//[username[:password]@]location]/directory]/filename

For example:

ftp://network-config (prefix://filename)

ftp://user1:secret@example.com/3600-configsecret@example.com/3600-config

-Graham
Please note: My comments are simply suggestions. I cannot be held liable for any loss of data, life or marbles due to following my instructions.

Got a website? Need some live chat software?

Hall of Fame Super Silver

Re: Cannot FTP new IOS from PC to Switch

Hello Jason,

you need an FTP server running on the PC and also in the switch configuration you need to specify the username and password to be used to authenticate with the FTP server

config t

ip ftp username

ip ftp password

this is because these parameters are not asked by the IOS prompt so you need to instruct the switch on what to use.

The FTP account has to exist on the FTP server and to have at least reading rights, the IOS image has to be present at the working directory of the FTP server.

see

http://www.cisco.com/en/US/docs/ios-xml/ios/fundamentals/command/F_through_K.html#GUID-60FE32B0-16EC-49BA-BA73-AD043D430804

Hope to help

Giuseppe

New Member

Re: Cannot FTP new IOS from PC to Switch

Hi guys. Thanks for the responses. 

I have verified all of this information and made the config changes accordingly.  I'm still getting the undefined error.  I have even tried FileZilla thinking maybe that I could connect that way, and no luck.  I put in the username and password that I set, and it gives an EConnRefused- Connection refused by the server".  I wonder if there is still a setting incorrect that I'm not thinking of.

Any other ideas?

New Member

Re: Cannot FTP new IOS from PC to Switch

Seems that either you have a firewall enabled on your server or your username / password is incorrect.

On your server/pc  open up internet explorer..

Now type in the url bar:  ftp://username@localhost

Enter the pasword in the popup box.

Does it let you in? can you see the files?

if you can, then the server is running fine and it may be a firewall issue.

if you cant login then your server may not be running or your details are wrong..

Just to make like easy, It may be better to just use tftp..

Ie: http://tftpd32.jounin.net/tftpd32_download.html

Then just use copy tftp://yourip/filename.bin flash:

tftp is slower but no need to passwords etc..

-Graham
Please note: My comments are simply suggestions. I cannot be held liable for any loss of data, life or marbles due to following my instructions.

Got a website? Need some live chat software?

Gold

Re: Cannot FTP new IOS from PC to Switch

Hi Jason,

Hop your doing good!!!

Cisco has removed FTP command from most of recent IOS ,as Its saying there is bug ,due to router gets crashed and reload

Better you can use TFTP

follow below procedure

conf t

itn vl 1

ip add x.x.x.x/24

no sh

int fa1/0

description to tftp server

switchport

switchport mode access

switchport access vlan 1

no sh

exit

#ping x.x.x.x (ip address of tftp server)

copy tftp: flash:

Address or name of remote host []?x.x.x.x

Source filename []?(copy n paste ur file name with .bin extension)

Destination filename?

It will start uploading IOS to ur flash:

verification

sh flash: or sh bootflash:/ sh supbootdisk:

Go to

conf t

boot system flash:(copy new ios name with .bin extension)

do wr

exit

#sh boor var

reload

I hop this is informative

Thanks

Ashish

Gold

Re: Cannot FTP new IOS from PC to Switch

Hi ,

forgote to mention Some good points ,If your using Window 7 please check firewall and you need to enable

telnet,ftp,tftp as by default they are turn off.

Please let us know if you still unable to upload IOS into switch.

Thanks

Ashish

Hall of Fame Super Gold

Re: Cannot FTP new IOS from PC to Switch

copy ftp:192.168.1.3/c:\c3750-ipbasek9-mz.122-55.SE1 flash:c3750-ipbasek9-mz.122-55.SE1

Hold on ... This is NOT the filename.

This command means "I want to copy the file 'c3750-ipbasek9-mz.122-55.SE1' and put into the flash as 'c3750-ipbasek9-mz.122-55.SE1'."

Ok, the command syntax could be correct (haven't used FTP option so wouldn't know if you can run the "C:\").

But do you have the file "c3750-ipbasek9-mz.122-55.SE1" or "c3750-ipbasek9-mz.122-55.SE1.BIN"???

%Error opening

This is possibly the reason why you are getting this error message.

7155
Views
10
Helpful
7
Replies
CreatePlease login to create content