Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cannot get 2811 connected to internet

Hi-

I'm a bit of a noob with Cisco gear, so please excuse any blatantly dumb configuration.

I have a site that has a 2811 installed and I cannot get the LAN connected to the network. This is a seemingly simple configuration. f0/0 is wan- uses static address from ISP, f0/1 is LAN 10.10.10.1 with dhcp and doing nat.

Building configuration...

Current configuration : 1344 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname <removed>

!

boot-start-marker

boot-end-marker

!

! card type command needed for slot/vwic-slot 0/0

! card type command needed for slot/vwic-slot 0/1

enable secret 5 <removed>

enable password <removed>

!

no aaa new-model

no ip routing

!

!

no ip cef

no ip dhcp use vrf connected

!

ip dhcp pool cash

   network 10.10.10.0 255.255.255.0

   default-router 10.10.10.1

   dns-server 10.10.10.1

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address x.x.x.x 255.255.255.252

ip nat outside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

no mop enabled

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 0.0.0.0 0.0.0.0 74.43.98.105

!

!

ip http server

no ip http secure-server

!

access-list 101 permit ip any any

!

!

!

control-plane

!

!

!

!

!

!

!

gateway

timer receive-rtp 1200

!

!

!

!

line con 0

line aux 0

line vty 0 4

password <removed>

login

!

scheduler allocate 20000 1000

!

end

Please take a moment and let me know where I screwed up at?  Thanks

*edited to correct word wrap

5 REPLIES

Re: Cannot get 2811 connected to internet

With no line breaks it's a bit hard to read, but I see no nat statement defined. Also, your dhcp pool defines the router as a dns server, but you have no dns servers defined for the router to lookup.

Sent from Cisco Technical Support iPad App

New Member

Cannot get 2811 connected to internet

Sorry, I'm not sure why the first post got word wrapped, I've edited it to read correctly.

Purple

Cannot get 2811 connected to internet

Hi,

en

conf t

ip routing

ip dns server

ip name-server x.x.x.x  x.x.x.x                          <------Your primary and secondary  ISP DNS servers

access-list 1 permit 10.10.10.0 0.0.0.255

ip nat inside source list1 interface f0/0

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Cannot get 2811 connected to internet

Cadet- Thanks for posting the syntax. I'll give it a shot.

I also need to define QoS UDP port priority to 5060 and 10000 through 20000. Could you be so kind as to help by providing the recommended commands?

Cannot get 2811 connected to internet

Hi,

you can add or modify below point on your running configuration:

1- for dhcp configuration you can modified it as below:

ip dhcp excluded-address 10.10.10.1

ip dhcp pool cash

   network 10.10.10.0 255.255.255.0

   import all

   default-router 10.10.10.1

   dns-server 4.2.2.2 8.8.8.8   (this is depending on your service provider configuration)

2- static routing:

  only you need to configure one line ;

   ip route 0.0.0.0 0.0.0.0 X.X.X.X                  (X; is the gateway of your public IP address)

3- you need to configure NAT for your users:

     ip nat inside sourcelist 1 interface interface fastethernet 0/0 overload

and creat an access-list rool to apply this traffic;

access-list 1 permit 10.10.10.0 0.0.0.255

regards,

195
Views
5
Helpful
5
Replies