Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cannot get out of Rommon mode Model 1760

Hello everyone,

I'm currently pursuing to take my CCNA and am currently studying for it, but have recently encountered a problem with one of my 1760 routers that I can not solve.

Yesterday I went to boot up my router like normal, however when I went into hyperterminal I noticed the router was in Rommon mode. Thinking I could change the configuration registry, I tried to bypass the NVRAM by using confreg 0x2142. However this still causes the router to go into Rommon mode. I am getting an error that states that there is insufficient memory to load the IOS image. It looks like this..

Memory required: 108916994 bytes, Memory available: 100663296 bytes


The difference between Memory required and Memory available is the additional

memory you need to run the router. Alternately, use a smaller image; this

may cause the memory requirement to decrease, and may allow you to at least

use the router with reduced functionality until you get more memory.

*** System received a Software forced crash ***

signal= 0x17, code= 0x200, context= 0x800062b4

PC = 0xffffffff, Vector = 0x200, SP = 0xffffffff


System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

TAC Support:

Copyright (c) 2003 by cisco Systems, Inc.

C1700 platform with 98304 Kbytes of main memory


I have used the dir flash: command and can see the IOS image, and try to boot from it (boot flash:iosimagename) but it will still go back into rommon mode. I also just swapped the RAM from my other 1760 into this 1760 and it booted up and went into normal configuraiton mode without any issues. However, the other router now will not load it's IOS image and I get the exact same error.

Im at a loss here, and have searched to figure out where or how I can just wipe the router clean to try and start fresh, but cannot get out or Rommon mode. The only thing I can think of is that the RAM went bad since it wont boot up either machine. Any thoughts?? Please help so I can resume my studies. Thank you!

Everyone's tags (2)

Re: Cannot get out of Rommon mode Model 1760

Probably the ram bank is damaged.

Can you replace the memory with a new bank?

If no, you can try to adjust ram usage with command iomem. Following these instructions:

Identifying a Continuous/Boot Loop Due to a Wrong Iomem  Size

The following symptoms might be observed on the console during the boot  sequence:

Not enough memory in the system for IO memory
IO memory available 4110105 required 5242880 _> 2600




Not enough memory in the system to run this image 
Required pmem/iomem: 39435385/524288
*** System received a Software forced crash *** 

Recovery Procedure

Step A

  • If your router doesn't have enough Dynamic RAM (DRAM) memory, go to Step  D.

  • If your router has enough DRAM memory, go to Step B.

Step B

Follow the steps in the order outlined:

  1. Turn the router off.

  2. Remove all the Network Modules (NMs) and WAN Interface Cards (WICs) from the  router.

  3. Turn the router on.

  4. If the router does not come up after removing the NM and WIC, go to Step  C.

    If it comes up fine, change the iomem configuration percentage

Router(config)#memory-size iomem 5  !-- The command above adjusts the percentage of DRAM to use for I/O Memory
Router(config)#exitRouter#copy running-config startup-config
Destination filename [startup-config]? Building [OK] Router#
  1. Turn the router off and reseat the NM and WIC cards.

  2. Turn the router on. It should boot up fine with the NM and WIC  cards.

Step C

Follow the steps as described below:

  1. Attach a terminal or PC with terminal emulation to the console port of the  router. Use the following terminal settings:

    • 9600 baud rate

    • No parity

    • 8 data bits

    • 1 stop bit

    • No flow control

    The required console cable specifications are described in Cabling Guide for Console and AUX Ports.

    Using the power switch, turn the router off and then turn it back  on.

  2. Press Break on the terminal keyboard within 60 seconds of the power-up to put  the router into ROMMON - diagnostic test mode.

    Tip: If the break sequence does not work, refer to Standard Break Key Sequence Combinations During Password  Recovery for other key combinations.

  3. Type confreg 0x2142 at the rommon 1> prompt to boot from Flash  without loading the configuration.

  4. Type reset at the rommon 2> prompt. The router reboots, but ignores  its saved configuration. Thus, it ignores the iomem command and uses the  default value.

  5. Type no after each setup question, or press Ctrl-C to skip the initial  setup procedure.

  6. Type enable at the Router> prompt. This puts you in enable mode  where you will see the Router# prompt.

  7. Note: Do not type, at this point, configure terminal.

    Type copy startup-config running-config to copy the non-volatile RAM  (NVRAM) into memory.

  8. Type show running-config. The show running-config command shows  the configuration of the router. In this configuration, you can see the  "memory-size iomem" line.

  9. Type configure terminal and remove the memory-size iomem command, or change it to the correct one.

    The prompt is now Router(config)#.

  10. Type config-register 0x2102.

  11. Press Ctrl-z or type end to leave the configuration mode.

    The prompt is now Router#.

  12. Type copy running-config startup-config to commit the  changes.

  13. Turn off the router, reseat the NM and WIC, and turn the router on again. It  should boot up fine.

Step D

If your router doesn't have enough DRAM memory, you can:

  • upgrade the DRAM memory of your router, or

  • load a Cisco IOS software image in Flash which requires less I/O and  processor memory using TFTPDNLD command from rommon

CreatePlease to create content