Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot navigate through the Cisco download software page

Hi, I have this weird issue with cisco software download navigation page. Here is just an example.

https://software.cisco.com/download/navigator.html?mdfid=284135358

So on the page within Firefox v50.0 OR IE 11, I tried to click "Catalyst 2960S-24PS-L Switch" from the 3rd column. Nothing happens...

I can not get into the product detail to choose the ios i need to download...

My account does have the valid contract access.

But I am not sure if it is an issue with my laptop OR just cisco website. So I tried the same link on my iphone as well...nothing happens either...

Ideas?

6 REPLIES
VIP Super Bronze

Hi, It works for me.

Hi, It works for me.

Here is the latest IOS posted for this product:

c2960s-universalk9-mz.150-2.SE10a.bin Link:

https://software.cisco.com/download/release.html?mdfid=282867574&flowid=46696&softwareid=280805680&release=15.0.2-SE10a&relind=AVAILABLE&rellifecycle=MD&reltype=latest

HTH

New Member

Thanks for the link but I am

Thanks for the link but I am mainly trying to figure out why I could not navigate on that page to select the Switch model... which browser did you use?

(No subject)

New Member

So you are telling me to not

So you are telling me to not use Internet anymore...

I actually do not think Firefox consumes too much CPU but memory...

New Member

I think I found the issue..

I think I found the issue...It is at least the cookie in Firefox. I use firefox in private mode all the time and it doesnot accept cookie. Once I started accepting cookie, it is good...

However still not sure why IE11 doesnot work either...But I guess it doesnot matter anymore :)

New Member

Hi, the download site is

Hi, the download site is broken again for me...This time I factory reset latest firefox and chrome but none of them worked...Anything going on with Cisco site?

88
Views
0
Helpful
6
Replies
CreatePlease to create content