Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot ping a new 2950

I have installed a new 2950 switch, connected to a 6509 with GBIC's.

I cannot ping the 2950, it is on the same subnet as the 6509. If I run 'sh cdp n 3/9 detail' on the 6509 it gives me details of the 2950. If I run the same command on the 2950 it gives me details of the 6509, including the 2950's IP address, but a ping gets no replies. Both are on vlan 1.

Mike

22 REPLIES
Gold

Re: Cannot ping a new 2950

Do a show int vlan1 on the 2950 and make sure it is up/up. You may have a VTP issue. Make sure the connection between them came up as trunk and has the correct vlans allowed. If it came up as a access port then the assigned access vlan is not vlan 1 on both sides.

New Member

Re: Cannot ping a new 2950

Port 3/9 on the 6509 shows connection type trunk.

On the 2950 -

sh int vlan 1, shows vlan 1 is up and protocol is up.

sh int gig 0/1 trunk, shows status trunking, native vlan 1, vlans allowed 1-4094.

Broadcasts are being sent and received.

Mike

Cisco Employee

Re: Cannot ping a new 2950

Hi Mike,

Can you please update the ip with mask which you have configured on your cat6k as well as 2950.

Also is your cat6k is running CATOS or IOS? If IOS can you check if vlan 1 on CAT6k is up and up and if CATOS can you check sc0 interface is up and up.

Also can you update the IOS version on 2950 switch.

Regards,

Ankur

New Member

Re: Cannot ping a new 2950

Hi Ankur

6509 is running IOS.

I have configured 8 other 2950's on vlan 1 on the 6509 and they are all working OK.

I think the 2950 is running the latest version - C2950-i6q4l2-mz.121-22.EA6.

Mask on 6509 and 2950's is 255.255.0.0, as are all switches and P.C's.

I have been called out to a remote site, I will not be able to check your reply until 07:00 CET tomorrow.

Mike

New Member

Re: Cannot ping a new 2950

Hi

Is it possible to post the sh cdp n de output?

Bronze

Re: Cannot ping a new 2950

can you please try deleting the vlan.dat file and rebooting the switch. i faced a similar problem and deleting the vlan.dat file resolved the issue. it seems that the vlan database is corrupted

New Member

Re: Cannot ping a new 2950

Hi

Thanks for your input.

Unfortunately already tried that one.

Mike

New Member

Re: Cannot ping a new 2950

Hi

Attached cdp output, hope it helps.

Mike

New Member

Re: Cannot ping a new 2950

I am out of the office on Thursday and Friday so I will be unable to reply to any replies until Monday 13th.

Mike

New Member

Re: Cannot ping a new 2950

Do a show VTP on both switches.

Do the versions match?

New Member

Re: Cannot ping a new 2950

Sorry for delay in replying, I am off work with flu.

I will look at VTP as soon as I get back to work.

Mike

New Member

Re: Cannot ping a new 2950

A colleague checked vtp for me, on the 6509, the 2950 that will not communicate and an existing 2950 that is in use. All are version 2.

The results of sh vtp s on both the 2950's are identical.

Mike

Cisco Employee

Re: Cannot ping a new 2950

Hi Mike,

VTP will never ever make ping stop between switches. Can you please confirm your normal data is working and passing fine through the switch.

Also can you confirm if you reload the switch can you ping it?

Ankur

New Member

Re: Cannot ping a new 2950

Hi Ankur

I have added seven other 2950's on the same blade on the 6509, they are all working fine.

The only difference that I can see is the version of the OS. The working ones are C2950-i6q4l2-mz.121-19.EA1c, the one that does not work is running C2950-i6q4l2-mz.121-22.EA6.

Mike

Re: Cannot ping a new 2950

HI,

I guess int VLAN 1 on C2950 is in Shutdown state.

Do the following steps to resolve this

on C2950

Switch2950# config terminal

Switch2950(cinfig)# int vlan 1

Switch2950(cinfig)#no shut

Switch2950(cinfig)#end

Switch2950#write mem

and now try it. When you configure a brand new switch you need to bring the Int VLAN 1 up stated as above.

Hope this helps

Shaheen

New Member

Re: Cannot ping a new 2950

Hi Shaheen

Tried that, no change.

The only difference that I can see between this switch and a live switch is the live one is in vlan 1, the test one is a vlan trunk.

If I run 'sh vlan bri gig 0/1' is shown as a port on vlan 1.

If I run sh vlan name default gig 0/1 does not appear in the list of ports.

On 'sh int gig 0/1 summ' TXBS, TXPS and TRTL are all zero, RXBS and RXPS increase in value.

Mike

New Member

Re: Cannot ping a new 2950

Mike, I had a similar issue last week with a 2960 to a 4507. Typoed the VTP password.

If you haven't checked the vtp password, do a 'sh vtp password' and make sure they match.

Sheila

Re: Cannot ping a new 2950

Lets take a step further

Lets Say Switch A is live and Switch B is a test Switch...

ensure int Valn 1 has ip address from the same range on both switches. (i.e 172.30.1.1/24 and 172.30.1.2/24) for example

select a port on Switch A that you will use to connect to Switch B and apply follwoing configs

int FA0/1

switchport access vlan 1

switch mode trunk

Now ensure Int VLAn 1 o Switch B is not in shutdown.

Choose a port say FA0/1

and apply same config as Switch A. Use a crossover or Fibre crossed patch lead to connect both switches together.

give 2 minutes and you should be able to ping each other.

ensure trunk encapsulation is same if both switches are not C2950 models)

You should also be able to connect your pc to one of the port on your test switch and ensure pc has ip from the same range as in vlan 1 and port is assigned tto vlan 1. you should be able to ping both switches. Be carefull if you have more than 1 vlan on your production.

hope this helps !!!

If you still have a problem then post the configs from both switches here and we will be able to help you. remember to remove passwords and confidential info before posting configs here.

Regards

Shaheen

New Member

Re: Cannot ping a new 2950

Hi Shaheen

Taking switch A as live and switch B as test.

Switch A is in blade 3 on the 6509.

I unplugged the gbic from switch A gig 0/1 and plugged it into gig 0/1 on switch B.

I could not ping the 6509.

I plugged the gbic on switch B into gig 0/2 on switch A, I could then ping the 6509.

I have attached the configs of the 6509 and switch B.

Hope this helps.

Mike

New Member

Re: Cannot ping a new 2950

Further to above, in desperation I copied the OS and running config from a live 2950.

The results are the same. Connected to the 6509 it cannot see the network, connected to gig 0/2 of a 2950 it can see the network.

Mike

New Member

Re: Cannot ping a new 2950

Hi saw you post and the configuration on 2950... it shows....

Interface: GigabitEthernet0/1, Port ID (outgoing port): 3/5

here it shows g0/1 is connected to g3/5 and the configuration of 3/5 in 6509 is not configured...... and also g0/1 is also not configured....

please let me know if i am correct and please rate all posts.... :)

New Member

Re: Cannot ping a new 2950

Problem solved by adding following to gig port

switchport mode access

Do not understand why this should be, but swich can now be used.

Mike

219
Views
0
Helpful
22
Replies
CreatePlease login to create content