Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cannot ping a sub-int but can ping the other.

I have a simple router and switch setup and my problem is I cannot ping anything on the 192.168.x.x network. Below is the switch and router config. Not sure, what I am missing

SWITCH:

ip subnet-zero

ip routing

!

!

interface Vlan1

no ip address

shutdown

!

interface Vlan12

description DATA VLAN

ip address 192.168.12.99 255.255.255.0

!

interface Vlan14

description VOICE VLAN

ip address 10.10.12.2 255.255.255.0

!

router rip

network 10.0.0.0

network 192.168.12.0

!

ip classless

ip http server

!

!

=====================

ROUTER:

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.12.1 10.10.12.15

!

ip dhcp pool VOICE

network 10.10.12.0 255.255.255.0

option 150 ip 10.10.12.10

default-router 10.10.12.1

!

!

ip domain name yourdomain.com

!

!

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.12

description DATA VLAN

encapsulation dot1Q 12 native

ip address 192.168.12.98 255.255.255.0

!

interface GigabitEthernet0/0.14

description VOICE VLAN

encapsulation dot1Q 14

ip address 10.10.12.1 255.255.255.0

h323-gateway voip interface

!

interface GigabitEthernet0/1

ip address 192.168.15.1 255.255.255.0

duplex auto

speed auto

!

router rip

network 10.0.0.0

network 192.168.12.0

THANKS

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Cannot ping a sub-int but can ping the other.

Hello Anacleto,

nice to hear that you solved the issue.

native vlan mismatch is the first item to verify when you experience L3 problems on only some subinterfaces.

If you like you can rate the post and click on the solved flag to indicate that the story had an happy end

Best Regards

Giuseppe

14 REPLIES
New Member

Re: Cannot ping a sub-int but can ping the other.

Hi,

I think as u r useing ip classless command so it will not work unless u r useing RIP version 1 so suggest u to pls use Rip ver 2 insteade of ver1 as it is a classfull routing protocal.

New Member

Re: Cannot ping a sub-int but can ping the other.

So, you mean to say if I do a "no ip classless", this should work?

Or, if I do a RIP v2, it will work this way too?

I tried to use EIGRP in this setup and it didnt work, why?

Hall of Fame Super Silver

Re: Cannot ping a sub-int but can ping the other.

Hello Anacleto,

one info is missing: how have you configured the layer2 trunk on the switch ?

If you haven't declared vlan 12 as the native vlan you have a native vlan mismatch because on router you have configured:

encapsulation dot1Q 12 native = untagged

in the router rip process a network statement for net 192.168.15.0 is missing

For these reasons you could be unable to ping anything in 192.168.x.y from the multilayer switch.

Hope to help

Giuseppe

New Member

Re: Cannot ping a sub-int but can ping the other.

I have VLAN 12 as the native vlan. The network 192.168.15.x was there before although still not working. I can ping anything on 10.x.x.x. though. In the switch, I have native vlan 12 and voice vlan 14

Hall of Fame Super Silver

Re: Cannot ping a sub-int but can ping the other.

Hello Anacleto,

what type of switch are you using and what IOS version is on it ?

We need to verify that it can really act as a multilayer switch.

Another point: have you created the L2 Vlans 12 and 14 ?

sh vlan 12

sh vlan 14

what do they say ?

they are treated as separate objects from the SVIs.

the native vlan mismatch was the first point to verify in a scenario like yours.

Hope to help

Giuseppe

Purple

Re: Cannot ping a sub-int but can ping the other.

If its a simple router/switch setup not sure why you have routing on both devices . I would get rid of the routing on the switch and run a trunk connection between the switch and router and let the router do the routing .Looks like you are trying to do the same routing in 2 different places. This is based on if you just have a single link between the switch and router. If there are other connections then you would have to show us how everything is setup.

New Member

Re: Cannot ping a sub-int but can ping the other.

I disable the routing in the 3560 switch and made RIP as version 2 in the router and still not working. Here are the config in the switch. I have the connection to the CallManager, my laptop and the port connecting to the router 0/3

!

interface FastEthernet0/1

description Connection to CUCMBE

switchport access vlan 14

switchport mode access

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust cos

auto qos voip trust

!

interface FastEthernet0/2

description MY LAPTOP

switchport access vlan 14

switchport mode access

!

interface FastEthernet0/3

description CONNECTION TO ROUTER

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos trust dscp

!

++++++++++++++++++++++++++++

Router:

^

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.12

description DATA VLAN

encapsulation dot1Q 12 native

ip address 192.168.12.98 255.255.255.0

!

interface GigabitEthernet0/0.14

description VOICE VLAN

encapsulation dot1Q 14

ip address 10.10.12.1 255.255.255.0

h323-gateway voip interface

!

interface GigabitEthernet0/1

ip address 192.168.15.1 255.255.255.0

duplex auto

speed auto

!

router rip

version 2

network 10.0.0.0

network 192.168.12.0

network 192.168.15.0

!

New Member

Re: Cannot ping a sub-int but can ping the other.

The problem here is the "native" keyword. The native VLAN is the VLAN that it will use when it is NOT in trunking mode.

Try removing it and see if it works

New Member

Re: Cannot ping a sub-int but can ping the other.

I tested with almost similar config(attached below) in my test-bed. I could easily ping from 9.14.20.* to 192.168.1.*

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.99

description vlan 99

encapsulation dot1Q 99

ip address 9.14.20.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/0.199

encapsulation dot1Q 199 native

ip address 192.168.1.100 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/1

ip address 192.168.2.100 255.255.255.0

duplex auto

speed auto

!

switch

------

hostname SW3550

!

enable secret xxx

!

ip subnet-zero

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 199

switchport mode trunk

!

interface FastEthernet0/2

switchport mode dynamic desirable

!

interface FastEthernet0/3

switchport access vlan 99

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 99

switchport mode access

spanning-tree portfast

Do let me know if I missed out anything

New Member

Re: Cannot ping a sub-int but can ping the other.

How about the VLAN interface IP addresses in the switch.

Try to put into the switch the following and tell me if it works and you can ping the VLAN interface in the switch to the router and vice versa

Switch:

Int vlan99

ip address 9.14.20.2 255.255.255.0

Int vlan199

ip address 192.168.1.101 255.255.255.0

Regards

Hall of Fame Super Silver

Re: Cannot ping a sub-int but can ping the other.

Hello Anacleto,

with this config:

interface FastEthernet0/3

description CONNECTION TO ROUTER

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos trust dscp

!

you have a native vlan mismatch because a command here is missing to say that vlan 12 and not vlan 1 is the native vlan

add

int f0/3

switchport trunk native vlan 12

see

Router(config-if)# switchport trunk native vlan vlan_ID

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/layer2.html#wp1020628

Hope to help

Giuseppe

New Member

Re: Cannot ping a sub-int but can ping the other.

Giuseppe, I will try this config tonight. thanks

New Member

Re: Cannot ping a sub-int but can ping the other.

Thanks Giuseppe. Solved!

Hall of Fame Super Silver

Re: Cannot ping a sub-int but can ping the other.

Hello Anacleto,

nice to hear that you solved the issue.

native vlan mismatch is the first item to verify when you experience L3 problems on only some subinterfaces.

If you like you can rate the post and click on the solved flag to indicate that the story had an happy end

Best Regards

Giuseppe

228
Views
0
Helpful
14
Replies
CreatePlease to create content