Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cannot ping loopback

I have a 2811 hook up to a 3750. For some reason I cannot ping loopback address, The loopback is for a cme.

configuration  of  2811 looks like this as well as 3750.. any ideas

IP phones seem to register and work. I noticed while trying to upgrade code on the 2811 and it kept failing.  I tried extended ping using other sources no luck..

I do this all the time so I am surprised at this I think I am loosing my mind

Thanks in advance

****** 2811 ******    ios 15.1.3  advipservices

interface Loopback0

ip address 192.168.151.1 255.255.255.0

!

interface FastEthernet0/0

description fast 0/0

no ip address

duplex full

speed 100

!

interface FastEthernet0/0.1

encapsulation dot1Q 152

ip address 192.168.152.1 255.255.255.0

p route 0.0.0.0 0.0.0.0 192.168.152.254

ip route 192.168.0.0 255.255.0.0 192.168.152.254

ip route 192.168.20.0 255.255.255.0 192.168.20.1

ip route 192.168.151.2 255.255.255.255 Internal-Service-Module0/0

interface FastEthernet1/0/14

description weir test

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

speed 100

duplex full

interface Vlan151

ip address 192.168.151.254 255.255.255.0

ip helper-address 192.168.151.1

!

interface Vlan152

ip address 192.168.152.254 255.255.255.

ip helper-address 192.168.151.1

ip route 172.16.30.0 255.255.255.0 172.16.30.1

ip route 192.168.151.0 255.255.255.0 192.168.152.1

ip route 192.168.152.0 255.255.255.0 192.168.152.1

C    192.168.123.0/24 is directly connected, Vlan123

C    192.168.122.0/24 is directly connected, Vlan122

C    192.168.121.0/24 is directly connected, Vlan121

C    192.168.151.0/24 is directly connected, Vlan151

C    192.168.110.0/24 is directly connected, Vlan110

C    192.168.162.0/24 is directly connected, Vlan162

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.30.0 is directly connected, Vlan30

C    192.168.161.0/24 is directly connected, Vlan161

C    192.168.141.0/24 is directly connected, Vlan141

S    9.0.0.0/8 [1/0] via 192.168.20.254

C    192.168.20.0/24 is directly connected, Vlan20

C    192.168.142.0/24 is directly connected, Vlan142

C    192.168.172.0/24 is directly connected, Vlan172

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Vlan10

C    192.168.0.0/24 is directly connected, Vlan100

C    192.168.171.0/24 is directly connected, Vlan171

C    192.168.152.0/24 is directly connected, Vlan152

S*   0.0.0.0/0 [1/0] via 192.168.20.254

C 192.168.123.0/24 is directly connected, Vlan123
C 192.168.122.0/24 is directly connected, Vlan122
C 192.168.121.0/24 is directly connected, Vlan121
C 192.168.151.0/24 is directly connected, Vlan151
C 192.168.110.0/24 is directly connected, Vlan110
C 192.168.162.0/24 is directly connected, Vlan162
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.30.0 is directly connected, Vlan30
C 192.168.161.0/24 is directly connected, Vlan161
C 192.168.141.0/24 is directly connected, Vlan141
S 9.0.0.0/8 [1/0] via 192.168.20.254
C 192.168.20.0/24 is directly connected, Vlan20
C 192.168.142.0/24 is directly connected, Vlan142
C 192.168.172.0/24 is directly connected, Vlan172
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Vlan10
C 192.168.0.0/24 is directly connected, Vlan100
C 192.168.171.0/24 is directly connected, Vlan171
C 192.168.152.0/24 is directly connected, Vlan152
S* 0.0.0.0/0 [1/0] via 192.168.20.254

interface Loopback0

ip address 192.168.151.1 255.255.255.0

!

interface FastEthernet0/0

description fast 0/0

no ip address

duplex full

speed 100

!

interface FastEthernet0/0.1

encapsulation dot1Q 152

ip address 192.168.152.1 255.255.255.0

p route 0.0.0.0 0.0.0.0 192.168.152.254
ip route 192.168.0.0 255.255.0.0 192.168.152.254
ip route 192.168.20.0 255.255.255.0 192.168.20.1
ip route 192.168.151.2 255.255.255.255 Internal-Service-Module0/0

PSTN-GWY#sh ip rout
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.152.254 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.152.254
S     192.168.0.0/16 [1/0] via 192.168.152.254
      192.168.151.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.151.0/24 is directly connected, Loopback0
L        192.168.151.1/32 is directly connected, Loopback0
S        192.168.151.2/32 is directly connected, Internal-Service-Module0/0
      192.168.152.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.152.0/24 is directly connected, FastEthernet0/0.1
L        192.168.152.1/32 is directly connected, FastEthernet0/0.1

****************************************************************  3750   IOS 12.2.46  

interface FastEthernet1/0/14
description test

switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
speed 100
duplex full

interface Vlan151
ip address 192.168.151.254 255.255.255.0
ip helper-address 192.168.151.1
!
interface Vlan152
ip address 192.168.152.254 255.255.255.0
ip helper-address 192.168.151.1

ip route 172.16.30.0 255.255.255.0 172.16.30.1
ip route 192.168.151.0 255.255.255.0 192.168.152.1
ip route 192.168.152.0 255.255.255.0 192.168.152.1

C 192.168.123.0/24 is directly connected, Vlan123
C 192.168.122.0/24 is directly connected, Vlan122
C 192.168.121.0/24 is directly connected, Vlan121
C 192.168.151.0/24 is directly connected, Vlan151
C 192.168.110.0/24 is directly connected, Vlan110
C 192.168.162.0/24 is directly connected, Vlan162
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.30.0 is directly connected, Vlan30
C 192.168.161.0/24 is directly connected, Vlan161
C 192.168.141.0/24 is directly connected, Vlan141
S 9.0.0.0/8 [1/0] via 192.168.20.254
C 192.168.20.0/24 is directly connected, Vlan20
C 192.168.142.0/24 is directly connected, Vlan142
C 192.168.172.0/24 is directly connected, Vlan172
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Vlan10
C 192.168.0.0/24 is directly connected, Vlan100
C 192.168.171.0/24 is directly connected, Vlan171
C 192.168.152.0/24 is directly connected, Vlan152
S* 0.0.0.0/0 [1/0] via 192.168.20.254

Everyone's tags (3)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: cannot ping loopback

Hello Mike,

it looks like that the loopback address on the C2811 is overlapping with

interface Loopback0

ip address 192.168.151.1 255.255.255.0

!

interface Vlan151

ip address 192.168.151.254 255.255.255.0

defined on the switch (or internal service module it is not clear)

the static route on the switch is not effective as the switch (or service module) sees IP subnet 192.168.151.0 as directly connected and attempts to make an ARP request for IP 192.168.151.1 no device answers and the communication fails.

One between C2811 loopback and SVI Vlan151 has to be modified with a different IP subnet.

Hope to help

Giuseppe

New Member

cannot ping loopback

Your Loopback is in the same network tha your Vlan 151 and the router gives priority to Vlan 151

C    192.168.151.0/24 is directly connected, Vlan151

4 REPLIES
Hall of Fame Super Silver

Re: cannot ping loopback

Hello Mike,

it looks like that the loopback address on the C2811 is overlapping with

interface Loopback0

ip address 192.168.151.1 255.255.255.0

!

interface Vlan151

ip address 192.168.151.254 255.255.255.0

defined on the switch (or internal service module it is not clear)

the static route on the switch is not effective as the switch (or service module) sees IP subnet 192.168.151.0 as directly connected and attempts to make an ARP request for IP 192.168.151.1 no device answers and the communication fails.

One between C2811 loopback and SVI Vlan151 has to be modified with a different IP subnet.

Hope to help

Giuseppe

New Member

cannot ping loopback

Your Loopback is in the same network tha your Vlan 151 and the router gives priority to Vlan 151

C    192.168.151.0/24 is directly connected, Vlan151

New Member

cannot ping loopback

Both of you were right on.. Another stupid mistake

New Member

Re: cannot ping loopback

Giuseppe Thank You  Great call..  I am not sure how I missed that and I hate to say I worked on for a few hours

I looked at it and just went past it.

Thanks

5254
Views
0
Helpful
4
Replies