Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cannot ping out of my switch

Hi everyone, i'm having a problem with a network in my simulator, i have network with a router making 2 subnets, every subnet have a switch. The problem is i cannot ping from a pc to the router, doesn't reach the router, only the switch.

The simulator says that there's "No communication protocol is presente for router 2600.A protocol needs to be present that allows communication to take place. You need either default/static routes established, RIP running, or IGRP running."

The router active configuration (my subnets are in the FastEthernet ports)(Cisco 2600) :

Router(config)#show running-config

^

% Invalid input detected at '^' marker.

Router(config)#exit

Router#show running-config

Building configuration...

Current configuration : 625 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

!

ip subnet-zero

!

!

!

!

!

interface FastEthernet0/0

ip address 10.87.200.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0/0

ip address 10.82.15.2 255.255.255.0

no ip directed-broadcast

!

interface FastEthernet0/1

ip address 10.87.201.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0/1

ip address 10.82.73.2 255.255.255.0

no ip directed-broadcast

!

router rip

version 2

network 10.0.0.0

!

!

ip classless

no ip http server

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID

Router Ser 0/1 170 R 2621 Ser 0/1

Router Ser 0/0 170 R 2621 Ser 0/0

switch Fas 0/12 170 SI 2950 Fas 0/1

switch Fas 0/12 170 SI 2950 Fas 0/0

Router Con0 is now available

Press RETURN to get started!

Router>enable

Router#show ip protocols

Routing Protocol is "rip"

Sending updates every 30 seconds, next due in 14 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Redistributing: rip

Default version control: send version 2, receive version 2

Interface Send Recv Triggered RIP Key-chain

Serial0/1 1 1 2

Serial0/0 1 1 2

FastEthernet0/1 1 1 2

FastEthernet0/0 1 1 2

Automatic network summarization is in effect

Maximum path: 4

Routing for networks:

10.0.0.0

Routing information sources:

Gateway Distance Last Update

Distance: <default is 120>

Router#show ip route rip

10.0.0.0/24 is subnetted, 4 subnets

Router#

This is the information of switch (Catalyst 2950):

switch#show running-config

Building configuration...

Current configuration : 866 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname switch

!

!

ip subnet-zero

!

!

spanning-tree extend system-id

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface Vlan1

ip address 10.87.200.254 255.255.255.0

no ip route-cache

!

ip default-gateway 10.87.200.1

ip http server

!

!

line con 0

line vty 0 15

login

!

end

If something else is needed, please let me know. Thanks and regards.

2 REPLIES
Hall of Fame Super Silver

Re: Cannot ping out of my switch

Jorge

You have not given us any detail to work with to understand your situation and to identify your problem. I will make these suggestions but having better information about how the switch is set up would allow us to give you better answers,

- is this a layer 2 switch or a layer 3 switch?

- are you pinging from the switch itself or from a PC connected to a switch port/interface?

- if from the switch do you have a valid IP address configured on the management interface of the switch? does the switch have a valid default gateway configured?

- if from a PC do you have a valid IP address and mask configured on the PC? Is the default gateway configured on the PC and is it working?

- are you trying to ping something in your own subnet or is the destination in a remote subnet?

If you can clarify these things then perhaps we can find answers to your issue.

HTH

Rick

Purple

Re: Cannot ping out of my switch

The only way it would work right now is to have a single connection from the router to the switch from router interface F0/0 which is the subnet that the switch ip address is in .What ip address does your client have ? It would have to have a 10.87.200.x address if they are on the switch. Where do the switches hook to the router ? It also looks like everything on the switch is in vlan 1 so no other subnets would work . What you would have to do if you need to have multiple subnets would be to setup trunking on the router with subinterfaces and run a single link to the switch . You then would have to create vlans on the switch itself if you need more than 1 subnet on that same switch.

this might help with the trunking end .

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a00800949fd.shtml

573
Views
0
Helpful
2
Replies