Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot remark DSCP 0 on Catalyst 3750

I’ve got Catalyst 3750 switch. On the ingress port (Gi1/0/4) I am receiving lot of traffic from some Voice equipment.  This is the configuration:

interface GigabitEthernet1/0/4
description "media"
switchport access vlan 113
switchport mode access
service-policy input MEDIA


policy-map MEDIA
  class MEDIA-SPC
   set dscp cs2
  class MEDIA-RTP
   set dscp cs5

class-map match-all MEDIA-SPC
  match ip dscp af11
class-map match-all MEDIA-RTP
  match ip dscp default

I want to remark AF11 to CS2. And this works just fine. ( I can see the packets correctly marked when leaving the switch (uplink monitored with Wireshark).

I would like also to remark DSCP 0 to DSCP 40 (CS50) but the switch doesn’t remark that as expected.

Does anyone know why I can remark AF11 and I cannot do the same for DSCP0?

Regards,

Franjo

Everyone's tags (1)
5 REPLIES

Re: Cannot remark DSCP 0 on Catalyst 3750

Show the outout of

show mls qos

show mls qos maps ip-prec-dscp

New Member

Re: Cannot remark DSCP 0 on Catalyst 3750

CRI31#show mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled

CRI31#show mls qos maps ip-prec-dscp
   IpPrecedence-dscp map:
     ipprec:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 24 32 40 48 56

CRI32#
CRI32#show mls qos maps ip-prec-dscp
   IpPrecedence-dscp map:
     ipprec:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 24 32 40 48 56

Re: Cannot remark DSCP 0 on Catalyst 3750

change your config to:-

policy-map MEDIA
  class MEDIA-RTP
   set dscp 40

New Member

Re: Cannot remark DSCP 0 on Catalyst 3750

I actually configured it this way but in sh running-configuration you see it as CS5. So it is only how IOS prefers to display binary value 101 000.

Silver

Re: Cannot remark DSCP 0 on Catalyst 3750

Hi Franjo

The "match ip dscp default" actally means "match ip dscp 0"

There are a very high chance that the rtp-streams already are marked with some dscp-value (normally 40 or 46), and therefore are not matched.

Try to match something else in the "class-map match-all MEDIA-RTP",  "match dscp 40" or "match dscp 46" or maybe "match any" , if the stream already are marked with dscp 40 you don't need to rewrite it.

/Mikael

1286
Views
0
Helpful
5
Replies