Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cannot remove ip summary-address from SVI on cat 6500 12.2SXF

I have an issue with EIGRP summary-address.

This is on a 6506E sup32 running 12.2 SXF16. The cat65 has a trunk to a 7304 NSE100 and I am running EIGRP between them on an SVI which is part of the trunk. I am trying to remove some summaries but nothing seems to work. I haven't tried removing the vlan config or reloading the box yet.

Any ideas?

cat65-1#
cat65-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
cat65-1(config)#!
cat65-1(config)#interface Vlan101
cat65-1(config-if)#!
cat65-1(config-if)#! remove summaries
cat65-1(config-if)# no ip summary-address eigrp 2130 172.31.144.0 255.255.254.0 5
cat65-1(config-if)# no ip summary-address eigrp 2130 172.30.0.0 255.255.224.0 5
cat65-1(config-if)# no ip summary-address eigrp 2130 172.18.224.0 255.255.224.0 5 
cat65-1(config-if)# no ip summary-address eigrp 2130 10.142.0.0 255.255.0.0 5
cat65-1(config-if)# no ip summary-address eigrp 2130 10.140.0.0 255.255.0.0 5
cat65-1(config-if)# no ip summary-address eigrp 2130 10.130.0.0 255.255.0.0 5
cat65-1(config-if)# no ip summary-address eigrp 2130 10.128.0.0 255.255.0.0 5
cat65-1(config-if)#!
cat65-1(config-if)#do sh run int vlan101
Building configuration...
Current configuration : 1154 bytes
!
interface Vlan101

bandwidth 1000000
ip vrf forwarding foo
ip address 172.31.144.41 255.255.255.248
ip summary-address eigrp 2130 172.31.144.0 255.255.254.0 5
ip summary-address eigrp 2130 172.30.0.0 255.255.224.0 5
ip summary-address eigrp 2130 172.18.224.0 255.255.224.0 5
ip summary-address eigrp 2130 10.142.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.140.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.130.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.128.0.0 255.255.0.0 5
end
cat65-1(config-if)# no ip summary-address eigrp 2130 172.31.144.0 255.255.254.0 5
cat65-1(config-if)# no ip summary-address eigrp 2130 172.30.0.0 255.255.224.0 5
cat65-1(config-if)# no ip summary-address eigrp 2130 172.18.224.0 255.255.224.0 5
cat65-1(config-if)#
cat65-1(config-if)#do sh run int vlan101
Building configuration...
Current configuration : 1154 bytes
!
interface Vlan101
bandwidth 1000000
ip vrf forwarding foo
ip address 172.31.144.41 255.255.255.248
ip summary-address eigrp 2130 172.31.144.0 255.255.254.0 5
ip summary-address eigrp 2130 172.30.0.0 255.255.224.0 5
ip summary-address eigrp 2130 172.18.224.0 255.255.224.0 5 
ip summary-address eigrp 2130 10.142.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.140.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.130.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.128.0.0 255.255.0.0 5
end
cat65-1(config-if)#no ip summary-address eigrp 2130 172.31.144.0 255.255.254.0 5
cat65-1(config-if)#do sh run int vlan101
Building configuration...
Current configuration : 1154 bytes
!
interface Vlan101
bandwidth 1000000
ip vrf forwarding foo
ip address 172.31.144.41 255.255.255.248
ip summary-address eigrp 2130 172.31.144.0 255.255.254.0 5
ip summary-address eigrp 2130 172.30.0.0 255.255.224.0 5
ip summary-address eigrp 2130 172.18.224.0 255.255.224.0 5
ip summary-address eigrp 2130 10.142.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.140.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.130.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.128.0.0 255.255.0.0 5
end
cat65-1(config-if)#
cat65-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
cat65-1(config)#int vlan101
cat65-1(config-if)#shut
cat65-1(config-if)#
cat65-1(config-if)#end
cat65-1#
cat65-1#sh int vlan101
Vlan101 is administratively down, line protocol is down
cat65-1#
cat65-1#
cat65-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
cat65-1(config)#int vlan101
cat65-1(config-if)#no ip summary-address eigrp 2130 172.31.144.0 255.255.254.0
cat65-1(config-if)#end
cat65-1# 
Building configuration...
Current configuration : 1620 bytes
!
interface Vlan101
bandwidth 1000000
ip vrf forwarding foo
ip address 172.31.144.41 255.255.255.248
ip summary-address eigrp 2130 172.31.144.0 255.255.254.0 5
ip summary-address eigrp 2130 172.30.0.0 255.255.224.0 5
ip summary-address eigrp 2130 172.18.224.0 255.255.224.0 5
ip summary-address eigrp 2130 10.142.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.140.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.130.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.128.0.0 255.255.0.0 5
ip summary-address eigrp 2130 172.30.0.0 255.255.224.0 5
ip summary-address eigrp 2130 172.18.224.0 255.255.224.0 5
ip summary-address eigrp 2130 130.144.0.0 255.255.0.0 5
ip summary-address eigrp 2130 130.139.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.142.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.140.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.130.0.0 255.255.0.0 5
ip summary-address eigrp 2130 10.128.0.0 255.255.0.0 5
shutdown
end
cat65-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
cat65-1(config)#int vlan101
cat65-1(config-if)#no shut
Aug 14 17:03:52.998 CET: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 2130: Neighbor 172.31.144.46 (Vlan101) is up: new adjacency
cat65-1(config-if)#

5 REPLIES
Bronze

Re: Cannot remove ip summary-address from SVI on cat 6500 12.2SX

Can you attach a complete running config?

New Member

Re: Cannot remove ip summary-address from SVI on cat 6500 12.2SX

afraid not. a lot of sensitive information. But the switch has a bit of everything. MPLS, vrfs, EoMPLS, IS-IS, EIGRP, BGP...

Hall of Fame Super Gold

Re: Cannot remove ip summary-address from SVI on cat 6500 12.2SX

How about "no int vlan 101" and then put the lines you want back in?

New Member

Re: Cannot remove ip summary-address from SVI on cat 6500 12.2SX

Yes, did that, Also deleted the vlan "no vlan 101" but no success. Planning a reload next maintenance window...:-(

Hall of Fame Super Silver

Re: Cannot remove ip summary-address from SVI on cat 6500 12.2SX

Hello Nasir,

I would suggest an IOS upgrade you have a recent supervisor Sup32 but not a recent IOS image.

I would move to 12.2(33)SXI2a or better.

what you see looks like a bug.

Hope to help

Giuseppe

629
Views
0
Helpful
5
Replies
CreatePlease to create content