Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot Telnet to Switch from Client

Hi,

I recently installed a 3750 switch and cannot telnet to it from any workstation. However, I can telnet to the new 3750 from another 3750 switch stack.

My workstation can ping the switch and the switch can ping my workstation. Same holds through for another workstation I tested from. I've telneted to the new switch from every switch on the way back to my workstation, all can telnet to the switch successfully. Traceroute from my workstation to and from the new switch also works.

Any idea what I might be missing? Here is the VTY configuration:

line vty 0 4

password 7 password

logging synchronous

login

transport input telnet ssh

line vty 5 15

password 7 password

logging synchronous

login

transport input telnet ssh

vlan config:

interface Vlan1

ip address 10.15.127.75 255.255.128.0

ip helper-address 10.15.127.2

!

ip default-gateway 10.15.127.254

I started with 15.02 SE5, but have since backed off to SE2 - no change there either.

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Cannot Telnet to Switch from Client

   Do you accidently have ip routing turned on ?   If ip routing is on then the ip default gateway commmand will not work and you would need a default static route  pointing to 10.15.127.254 .  Also verify you masking matches.  That's a very big subnet mask .

5 REPLIES
Purple

Cannot Telnet to Switch from Client

  Where is the routing for this subnet done ?  Is vlan 1 allowed or configured on the uplink ?  Can you post both ends of the connecting link ?

New Member

Cannot Telnet to Switch from Client

Hi Glen,

Switch side:

interface GigabitEthernet1/0/23

description Core

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet1/0/24

description Core

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

channel-group 1 mode on

Core Side:

int g1/47

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

channel-group 25 mode on

int g2/47

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

channel-group 25 mode on

There isn't much to it and this exact same implementation is being used on 100+ switch stacks.

Purple

Cannot Telnet to Switch from Client

   Do you accidently have ip routing turned on ?   If ip routing is on then the ip default gateway commmand will not work and you would need a default static route  pointing to 10.15.127.254 .  Also verify you masking matches.  That's a very big subnet mask .

New Member

Re: Cannot Telnet to Switch from Client

Thank you, this led me in the right direction. The switch is running OSPF. In my configuration of passive-interfaces I forgot to exclude the interface vlan1. Once I added that as an exclusion, I was able to telnet to the switch.

VIP Purple

Re: Cannot Telnet to Switch from Client

Hi Danial,

Can u please add login local to ur vty line.

line vty 0 4
password 7 password
logging synchronous
login local
transport input telnet ssh
line vty 5 15
password 7 password
logging synchronous
login local
transport input telnet ssh

Regards
Don't forget to rate helpful posts.

Sent from Cisco Technical Support iPhone App

143
Views
0
Helpful
5
Replies
CreatePlease login to create content