Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisco 3750 Switch

I have a new Cisco 2960 S series switch with a basic configuration that needs to be uplinked or daisy chained to a Cisco 3750 switch. I am not getting any connectivity to the network with either a straight through or crossover cable. the port remains in amber but a 'show interface' indicates that the interface is up. I can manage the switch with a PC patched into any port on the switch with a static IP address. Must be something very simple that I am missing. Outlined below is the configuration.

Refresh_SW1#sh ver

Cisco IOS Software, C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(55)SE3,

RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Thu 05-May-11 16:56 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x01B00000

ROM: Bootstrap program is Alpha board boot loader

BOOTLDR: C2960S Boot Loader (C2960S-HBOOT-M) Version 12.2(55r)SE, RELEASE SOFTWA

RE (fc1)

Refresh_SW1 uptime is 1 hour, 13 minutes

System returned to ROM by power-on

System restarted at 14:40:48 UTC Mon Feb 6 2012

System image file is "flash:/c2960s-universalk9-mz.122-55.SE3/c2960s-universalk9

-mz.122-55.SE3.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C2960S-24PS-L (PowerPC) processor (revision D0) with 131072K bytes of m

emory.

Processor board ID FOC1551X07F

Last reset from power-on

1 Virtual Ethernet interface

1 FastEthernet interface

28 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : C4:0A:CB:52:12:80

Motherboard assembly number     : 73-11908-06

Power supply part number        : 341-0393-02

Motherboard serial number       : FOC15496YHB

Power supply serial number      : DCA1546U1F5

Model revision number           : D0

Motherboard revision number     : A0

Model number                    : WS-C2960S-24PS-L

Daughterboard assembly number   : 73-11933-04

Daughterboard serial number     : FOC15495WU9

System serial number            : FOC1551X07F

Top Assembly Part Number        : 800-30945-02

Top Assembly Revision Number    : C0

Version ID                      : V02

CLEI Code Number                : COMGE00ARB

Daughterboard revision number   : A0

Hardware Board Revision Number  : 0x01

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 28    WS-C2960S-24PS-L   12.2(55)SE3           C2960S-UNIVERSALK9-M

Configuration register is 0xF

Refresh_SW1#sh run

Building configuration...

Current configuration : 1852 bytes

!

! Last configuration change at 15:53:49 UTC Mon Feb 6 2012

! NVRAM config last updated at 15:46:39 UTC Mon Feb 6 2012

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Refresh_SW1

!

boot-start-marker

boot-end-marker

!

enable secret 5 ***************.

!

!

!

no aaa new-model

clock summer-time UTC recurring last Sun Mar 1:00 last Sun Oct 2:00

switch 1 provision ws-c2960s-24ps-l

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0

no ip address

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface Vlan1

ip address 128.100.100.110 255.255.0.0

!

ip default-gateway 128.100.1.1

ip http server

ip http secure-server

ip sla enable reaction-alerts

!

line con 0

line vty 0 4

password *****

login

line vty 5 15

password *******

login

!

end

Refresh_SW1#

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisc

the port remains in amber but a 'show interface' indicates that the interface is up.

Amber could mean a few things:

1.  Spanning-tree;

2.  Auto-negotiation between access and trunk port.

Can you please post the config of the 3750?  

If you'd like try the following command on each switches:

2960S

interface

switchport mode trunk

speed auto

duplex auto

3750

default interface

interface

switchport encapsulation dot

switchport mode trunk

speed auto

duplex auto

8 REPLIES
Cisco Employee

Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisco 37

Few questions:

1. From where are you trying to check the connectivity to the network?

2. 2960 is a L2 switch alone. so was the link b/w 2960 and the 3750 configured as Trunk?

3. use the cross over cable for connecting two switches.

4. from the switch can you ping the default -gateway 128.100.1.1 ?

-Vijay

New Member

Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisco 37

1. From where are you trying to check the connectivity to the network?

Ans - From the LAN and a PC(static IP) patched into the switch.

2. 2960 is a L2 switch alone. so was the link b/w 2960 and the 3750 configured as Trunk? No.

3. use the cross over cable for connecting two switches. Tried that already

4. from the switch can you ping the default -gateway 128.100.1.1 ? No

New Member

Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisco 37

Have you forced the port to full duplex and speed 100. Does the switch have a ip address. Are going to pass traffic thru this switch.

New Member

Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisco 37

Have you forced the port to full duplex and speed 100. I will try that.

Does the switch  have a ip address. It does.

Are going to pass traffic thru this switch. Yes.

Hall of Fame Super Gold

Re: Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisc

the port remains in amber but a 'show interface' indicates that the interface is up.

Amber could mean a few things:

1.  Spanning-tree;

2.  Auto-negotiation between access and trunk port.

Can you please post the config of the 3750?  

If you'd like try the following command on each switches:

2960S

interface

switchport mode trunk

speed auto

duplex auto

3750

default interface

interface

switchport encapsulation dot

switchport mode trunk

speed auto

duplex auto

Purple

Re: Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisc

Can you post the 3750 side of the config , really nothing  that should make it not work if you are just running an access port to the 3750 .  I would think about changing that masking  and making it something smaller . 

New Member

Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisco 37

Thamk you everyone for your comments. Spaaning tree was puuting the uplink port in a blocking state. I disable spanning tree and the problem was resolved.

Purple

Cannot Uplink/Daisy Chain Cisco 2960 S Series Switch to Cisco 37

   I would say that was not a wise decision , spanning tree put that port in blocking mode for a reason , somewhere you have a built in loop in your design and you could put your net at risk by shutting off spanning tree between devices.

2295
Views
0
Helpful
8
Replies
CreatePlease to create content