Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot upload IOS via tftp/xmodem

Hello everybody,

I've tried to upload ios image to flash via TFTP in rommon mode. It is the only possibillity to do that - it's 2650xm so there isn't a CF card. What is more, the previous ios image is damaged, so I cannot boot the device.

New IOS image is 33MB whilst my summary flash capacity is 48 MB. Everything is fine up to

33553920 bytes. Than I have unexpected TIMOUT.

TFTP Server log (tftpd32):

Connection received from 10.0.0.2 on port 16358 [16/01 16:28:35.331]

Read request for file <c2600-adventerprisek9-mz.124-15.T14.bin>. Mode octet [16/01 16:28:35.332]

Using local port 49239 [16/01 16:28:35.332]

Ack block 0 ignored (received twice) [16/01 16:30:04.195]

TIMEOUT waiting for Ack block #65536  [16/01 16:30:46.743]

Output from console:

rommon 1 > IP_ADDRESS=10.0.0.2

rommon 2 > IP_SUBNET_MASK=255.0.0.0

rommon 3 > DEFAULT_GATEWAY=10.0.0.1

rommon 4 > TFTP_SERVER=10.0.0.1

rommon 5 > TFTP_FILE=c2600-adventerprisek9-mz.124-15.T14.bin

rommon 6 > tftpdnld

          IP_ADDRESS: 10.0.0.2

      IP_SUBNET_MASK: 255.0.0.0

     DEFAULT_GATEWAY: 10.0.0.1

         TFTP_SERVER: 10.0.0.1

           TFTP_FILE: c2600-adventerprisek9-mz.124-15.T14.bin

Invoke this command for disaster recovery only.

WARNING: all existing data in all partitions on flash will be lost!

Do you wish to continue? y/n:  [n]:  y

Receiving c2600-adventerprisek9-mz.124-15.T14.bin from 10.0.0.1 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

LINES OMITTED

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

.................... [TIMED OUT]

TFTP: Operation terminated.

rommon 7 >

rommon 7 >

rommon 7 >

Also, i have tried upload the image via xmodem, but it is unsuccessful too.

rommon 9 > xmodem -c c2600-adventerprisek9-mz.124-15.T14.bin

Do not start the sending program yet...

         File size           Checksum   File name

    371527 bytes (0x5ab47)    0x4446    crashinfo_20051025-103113

    322459 bytes (0x4eb9b)    0x26c8    crashinfo_20060403-105835

  21523300 bytes (0x1486b64)  0x89ea    c2600-ipvoice-mz.123-8.T11.bin (bad checksum: 0x16d2)

WARNING: All existing data in bootflash will be lost!

Invoke this application only for disaster recovery.

Do you wish to continue? y/n  [n]:  y

Ready to receive file c2600-adventerprisek9-mz.124-15.T14.bin ...

CCCCCCCCCC

Timeout waiting for data - aborting download...

rommon 10 >

What I should do now? Please, help! I used two different computers for this test. In both cases the same.

Everyone's tags (4)
8 REPLIES

Cannot upload IOS via tftp/xmodem

Seems you get the problem around the 32MB border. This is an indication your tftp server might be playing a nasty trick on you. I suggest you try again with a different tftp server implementation.

Probably using Windows eh?

Try any linux-based server or for example Solar Winds.

regards,

Leo

Hall of Fame Super Silver

Cannot upload IOS via tftp/xmodem

Leo

Like you, my first thought was that it was an issue with the PC or the TFTP server. But on further examination I do not think so. The first clue was the the PC is using tftpd32 as the TFTP server and I have used that server numerous times for files larger than 32M without problem. The second clue is that in doing xmodem the router is clearing memory and then gets a timeout for the attempt to clear memory

CCCCCCCCCC

Timeout waiting for data - aborting download...

to the original poster

I am afraid that these symptoms look like there is a hardware problem in flash on this router. I suspect that the only solution that will really work would be to replace the flash, and I am not sure that this is practical.

HTH

Rick

Purple

Re: Cannot upload IOS via tftp/xmodem

  To me it  looks like you are running out of room in flash .  Make sure you 256meg  DRAM and 48 meg of flash in your device to use this .  The image is 34 meg in size so if you only have  48 meg in flash then you don't have enough room to add a second image. Try deleting the old file in flash.

Cannot upload IOS via tftp/xmodem

Hi Rick,

To me, the timeout seen during upload looks like a typical tftp related problem.

After closer investigation I noticed that the existing image has a checksum error and the file is probably too small.

When using xmodem, there are no memory related error messages.

Very often the download does not start correctly which may be what we are seeing here.

Essentially there's only crap on the flash at this moment.

Sometimes it helps to simply erase the flash completely and then try again. That would be my next attempt.

I am also not completely sure whether the message about erasing flash is actually correct.

The device may actually still try to add the file to the existing directory.

If all of this fails, you are probably correct, its not exactly a new box.

regards,

Leo

New Member

Cannot upload IOS via tftp/xmodem

Ok, I solved the problem.

Unfortunately using SolarWinds TFTP server didn't work. In the same moment, uploading was aborted.

So I have uploaded another ios image which requires only 32mb of flash. Automatic erasing and uploading process went well. I've booted router with this image and then copy new ios image and it worked.

Still I have no idea why I couldn't do that in rommon if flash isn't damaged.

Hall of Fame Super Silver

Cannot upload IOS via tftp/xmodem

Thanks for posting back to the thread and telling us that you have resolved the problem. I am glad that you got it worked out. And I am puzzled why it was a problem in rommmon but not from a running image.

HTH

Rick

Cannot upload IOS via tftp/xmodem

Although the issue is resolved but for future reference, when using tftpdnld or xmodem, we can use a parameter of "-r"

so the command would be "tftpdnld -r" and "xmodem -r "

This -r switch would bypass the Flash of router and directly load the IOS into DRAM. This is useful when Flash chip has gone bad and cannot load the complete IOS. One the IOS boots up, we can try and format flash and copy the IOS file once again.

Hope it helps in future.

Neeraj

Cisco Employee

Cannot upload IOS via tftp/xmodem

Hi Neeraj,

A very good point! I have myself used the -r switch a couple of times.

Best regards,

Peter

8887
Views
5
Helpful
8
Replies