Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cant access switch via brower or CNA

I upgraded a Catalyst 2950 switch and there wasn't enough room so I deleted the flash. The upgraded went well using tftp. It booted up fine. The  I0S version includes crypto. But, I can't access switch via web browser or CNA. Port scan shows port 80 0pen. What am I missing?

Here is the flash.

Directory of flash:/

    2  -rwx         112  Mar 01 1993 01:00:48 +00:00  info
    3  -rwx     3722814  Mar 01 1993 01:02:58 +00:00  c2950-i6k2l2q4-mz.121-22.EA14.bin
    4  drwx        4416  Mar 01 1993 01:03:45 +00:00  html
  331  -rwx         112  Mar 01 1993 01:04:19 +00:00  info.ver
  332  -rwx          73  Mar 01 1993 01:08:57 +00:00  env_vars
  333  -rwx          24  Mar 01 1993 01:14:09 +00:00  private-config.text
  334  -rwx         556  Mar 01 1993 00:07:22 +00:00  vlan.dat
  335  -rwx        1184  Mar 01 1993 01:14:09 +00:00  config.text

Below is config that is pretty much unconfigured.

 

show runn
Building configuration...

Current configuration : 1238 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22

!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
ip address 10.1.100.144 255.255.255.0
no ip route-cache
!
ip default-gateway 10.1.100.1
ip http server
!
line con 0
line vty 0 4
login
line vty 5 15
login
!

Tom

5 REPLIES
Hall of Fame Super Silver

Cant access switch via brower or CNA

Thomas

I believe that the root of this problem is in the way that you upgraded the 2950. The graphical management interface for this switch is not in the bin file that is the operating image but is in other files in flash associated with the image file. There are two approaches to upgrading these switches - you can upgrade using the tar file which includes the options like the graphical management interface or you can upgrade by copying just the bin file. It looks like you upgraded using the bin file and not the tar file. This results in not having the files in flash that support the graphical management interface. If you want to use a browser or CNA to manage this switch you probably need to do the upgrade  over again and use the tar file this time.

HTH

Rick

New Member

Cant access switch via brower or CNA

Rick,

I used the tar file to up load what is in the current flash.

C2950 EI AND SI IOS CRYPTO AND WEB BASED DEVICE MANAGER

c2950-i6k2l2q4-tar.121-22.EA14.tar

Release Date: 02/NOV/2010

Could it be wrong tar I uploaded? I see HTML in the flash.

Thanks,

Tom

Hall of Fame Super Silver

Cant access switch via brower or CNA

Tom

Here is what was part of the original post:

Directory of flash:/

    2  -rwx         112  Mar 01 1993 01:00:48 +00:00  info

    3  -rwx     3722814  Mar 01 1993 01:02:58 +00:00  c2950-i6k2l2q4-mz.121-22.EA14.bin

If the code upgrade was done using the tar file I would expect to see a directory entry at the top level of flash showing the version information and the bin file (and html etc) within that directory. But here the bin file is at the top level of the flash.

Did you do the upgrade using the archive download command or using a copy tftp flash command?

HTH

Rick

New Member

Cant access switch via brower or CNA

Rick,

I got it working after adding the lines below. I haven’t determined if it needs them both or just one of them. Thanks for replying to my post though.

snmp-server community public1 RO

snmp-server community private1 RW

!

line con 0

line vty 0 4

password cisco

login

line vty 5 15

password cisco

login

Thanks,

Tom

Hall of Fame Super Silver

Cant access switch via brower or CNA

Tom

Thanks for posting back and telling us that you have fixed the problem. And congratulations on finding the solution.

I would think that the second line would be more important than the first one.

HTH

Rick

676
Views
0
Helpful
5
Replies
CreatePlease login to create content