Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

cant firgure this out??

Guys ,

I have a few users that when i plug their machines spanning tree (or i  think its spanning tree) is putting the port in blocking state. when i  turn on portfast it obviously works. I ran a debug all on the port and  below is what i get . I have no idea why this is happening. its just a

pc

plugged directly in. the only thing i notice is vmware workstation is  installed on the machine but still i don't see that being an issue. i  even tried to set a max

security

of two still just in case extra mac in vmware config, no good. any ideas? the port I'm having an issue is gi4/0/34

STP SW:

BANDWIDTH

CHANGE

: GigabitEthernet4/0/34 new bandwidth 10000(10000) kbits/sec

Sep 27 11:18:43.756: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet4/0/34, changed state to down

Sep 27 11:18:44.385: STP SW: BANDWIDTH CHANGE: GigabitEthernet4/0/34 new bandwidth 100000(100000) kbits/sec

Sep 27 11:18:44.820: CSRT:Not expecting a confirmation on VLAN0010

Sep 27 11:18:45.345: STP SW: RX ISR: 0100.0ccc.cccd<-0c68.03ed.8b00 type/len 0032

Sep 27 11:18:45.345:     encap SNAP linktype sstp vlan 10 len 64 on v10 St1

Sep 27 11:18:45.345:     AA AA 03 00000C 010B SSTP

Sep 27 11:18:45.345:     CFG P:0000 V:02 T:02 F:3D R:200A 0c68.03db.8580 00000000

Sep 27 11:18:45.345:     B:200A 0c68.03db.8580 81.1A A:0000 M:0C00 H:0900 F:0900

Sep 27 11:18:45.345:      T:0000 L:0002 D:000A

Sep 27 11:18:45.345: STP SW: PROC RX: 0100.0ccc.cccd<-0c68.03ed.8b00 type/len 0032

Sep 27 11:18:45.345:     encap SNAP linktype sstp vlan 10 len 64 on v10 St1

Sep 27 11:18:45.345:     AA AA 03 00000C 010B SSTP

Sep 27 11:18:45.345:     CFG P:0000 V:02 T:02 F:3D R:200A 0c68.03db.8580 00000000

Sep 27 11:18:45.345:     B:200A 0c68.03db.8580 81.1A A:0000 M:0C00 H:0900 F:0900

Sep 27 11:18:45.345:      T:0000 L:0002 D:000A

Sep 27 11:18:45.345: STP: VLAN0010 rx BPDU: config protocol = rstp,  packet from StackPort1  , linktype SSTP , enctype 3, encsize 22

Sep 27 11:18:45.345: STP: enc 01 00 0C CC CC CD 0C 68 03 ED 8B 00 00 32 AA AA 03 00 00 0C 01 0B

Sep 27 11:18:45.345: STP:

Data

000002023D200A0C6803DB858000000000200A0C6803DB8580811A00000C0009000900

Sep 27 11:18:45.350: STP: VLAN0010 St1:0000 02 02 3D 200A0C6803DB8580 00000000 200A0C6803DB8580 811A 0000 0C00 0900 0900

Sep 27 11:18:45.350: RSTP(10): St1 other msg

Sep 27 11:18:45.350: STP SW: PROC RX: 0100.0ccc.cccd<-ece1.a9b5.a400 type/len 0032

Sep 27 11:18:45.350:     encap SNAP linktype sstp vlan 10 len 64 on v10 St1

Sep 27 11:18:45.350:     AA AA 03 00000C 010B SSTP

Sep 27 11:18:45.350:     CFG P:0000 V:02 T:02 F:0E R:200A 0c68.03db.8580 00000000

Sep 27 11:18:45.350:     B:200A 0c68.03db.8580 81.1B A:0000 M:0C00 H:0900 F:0900

Sep 27 11:18:45.350:      T:0000 L:0002 D:000A

Sep 27 11:18:45.350: STP SW: RX ISR: 0100.0ccc.cccd<-0c68.03f6.fc00 type/len 0032

Sep 27 11:18:45.350:     encap SNAP linktype sstp vlan 10 len 64 on v10 St1

Sep 27 11:18:45.350:     AA AA 03 00000C 010B SSTP

Sep 27 11:18:45.350:     CFG P:0000 V:02 T:02 F:3D R:200A 0c68.03db.8580 00000000

Sep 27 11:18:45.350:     B:200A 0c68.03db.8580 81.19 A:0000 M:0C00 H:0900 F:0900

Sep 27 11:18:45.350:      T:0000 L:0002 D:000A

Sep 27 11:18:45.350: STP: VLAN0010 rx BPDU: config protocol = rstp,  packet from StackPort1  , linktype SSTP , enctype 3, encsize 22

Sep 27 11:18:45.350: STP: enc 01 00 0C CC CC CD EC E1 A9 B5 A4 00 00 32 AA AA 03 00 00 0C 01 0B

Sep 27 11:18:45.350: STP: Data     000002020E200A0C6803DB858000000000200A0C6803DB8580811B00000C0009000900

Sep 27 11:18:45.355: STP: VLAN0010 St1:0000 02 02 0E 200A0C6803DB8580 00000000 200A0C6803DB8580 811B 0000 0C00 0900 0900

Sep 27 11:18:45.355: RSTP(10): St1 other msg

Sep 27 11:18:45.355: STP SW: PROC RX: 0100.0ccc.cccd<-0c68.03f6.fc00 type/len 0032

Sep 27 11:18:45.355:     encap SNAP linktype sstp vlan 10 len 64 on v10 St1

Sep 27 11:18:45.355:     AA AA 03 00000C 010B SSTP

Sep 27 11:18:45.355:     CFG P:0000 V:02 T:02 F:3D R:200A 0c68.03db.8580 00000000

Sep 27 11:18:45.355:     B:200A 0c68.03db.8580 81.19 A:0000 M:0C00 H:0900 F:0900

Sep 27 11:18:45.355:      T:0000 L:0002 D:000A

Sep 27 11:18:45.355: STP: VLAN0010 rx BPDU: config protocol = rstp,  packet from StackPort1  , linktype SSTP , enctype 3, encsize 22

Sep 27 11:18:45.355: STP: enc 01 00 0C CC CC CD 0C 68 03 F6 FC 00 00 32 AA AA 03 00 00 0C 01 0B

Sep 27 11:18:45.355: STP: Data     000002023D200A0C6803DB858000000000200A0C6803DB8580811900000C0009000900

Sep 27 11:18:45.355: STP: VLAN0010 St1:0000 02 02 3D 200A0C6803DB8580 00000000 200A0C6803DB8580 8119 0000 0C00 0900 0900

Sep 27 11:18:45.360: RSTP(10): St1 other msg

Sep 27 11:18:45.360: RSTP(10): sending BPDU out Gi1/0/2

Sep 27 11:18:45.360: STP SW: TX: 0180.c200.0000<-0c68.03db.8582 type/len 0027

Sep 27 11:18:45.360:     encap SAP linktype ieee-st vlan 10 len 60 on v10 Gi1/0/2

Sep 27 11:18:45.360:     42 42 03 SPAN

Sep 27 11:18:45.360:     CFG P:0000 V:02 T:02 F:3C R:0002 b0fa.eb2b.4b80 00000007

Sep 27 11:18:45.360:     B:200A 0c68.03db.8580 80.02 A:0200 M:0C00 H:0900 F:0900

Sep 27 11:18:45.360: RSTP(10): sending BPDU out Gi1/0/4

Sep 27 11:18:45.360: STP SW: TX: 0180.c200.0000<-0c68.03db.8584 type/len 0027

Sep 27 11:18:45.360:     encap SAP linktype ieee-st vlan 10 len 60 on v10 Gi1/0/4

Sep 27 11:18:45.360:     42 42 03 SPAN

Sep 27 11:18:45.360:     CFG P:0000 V:02 T:02 F:3C R:0002 b0fa.eb2b.4b80 00000007

Sep 27 11:18:45.360:     B:200A 0c68.03db.8580 80.04 A:0200 M:0C00 H:0900 F:0900

Sep 27 11:18:45.360: RSTP(10): sending BPDU out Gi1/0/5

Sep 27 11:18:45.360: STP SW: TX: 0180.c200.0000<-0c68.03db.8585 type/len 0027

Sep 27 11:18:45.360:     encap SAP linktype ieee-st vlan 10 len 60 on v10 Gi1/0/5

Sep 27 11:18:45.360:     42 42 03 SPAN

Sep 27 11:18:45.360:     CFG P:0000 V:02 T:02 F:3C R:0002 b0fa.eb2b.4b80 00000007

Sep 27 11:18:45.360:     B:200A 0c68.03db.8580 80.05 A:0200 M:0C00 H:0900 F:0900

Sep 27 11:18:45.360: RSTP(10): sending BPDU out Gi1/0/7

Sep 27 11:18:45.360: STP SW: TX: 0180.c200.0000<-0c68.03db.8587 type/len 0027

Sep 27 11:18:45.360:     encap SAP linktype ieee-st vlan 10 len 60 on v10 Gi1/0/7

Sep 27 11:18:45.360:     42 42 03 SPAN

Sep 27 11:18:45.360:     CFG P:0000 V:02 T:02 F:3C R:0002 b0fa.eb2b.4b80 00000007

Sep 27 11:18:45.360:     B:200A 0c68.03db.8580 80.07 A:0200 M:0C00 H:0900 F:0900

Sep 27 11:18:45.360: RSTP(10): sending BPDU out St1

Sep 27 11:18:45.360: STP SW: TX: 0100.0ccc.cccd<-0c68.03db.8580 type/len 0032

Sep 27 11:18:45.366:     encap SNAP linktype sstp vlan 10 len 64 on v10 St1

Sep 27 11:18:45.366:     AA AA 03 00000C 010B SSTP

Sep 27 11:18:45.366:     CFG P:0000 V:02 T:02 F:3C R:0002 b0fa.eb2b.4b80 00000007

Sep 27 11:18:45.366:     B:200A 0c68.03db.8580 81.18 A:0200 M:0C00 H:0900 F:0900

Sep 27 11:18:45.366:      T:0000 L:0002 D:000A

Sep 27 11:18:45.376: CSRT:Not expecting a confirmation on VLAN0010

Sep 27 11:18:45.376: CSRT:Not expecting a confirmation on VLAN0010

Sep 27 11:18:45.376: CSRT:Not expecting a confirmation on VLAN0010

CCNA       

CCNA
11 REPLIES

Re: cant firgure this out??

Hi,

you should always configure spanning-tree portfast on edgeports, otherwise it takes 30 seconds for the transition to forwarding state.

*Mar  1 00:49:48.164: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Sw1#show spanning-tree interface Fa0/1

Vlan                Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0001            Desg LIS 19        128.1    P2p

Sw1#show spanning-tree interface Fa0/1

Vlan                Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0001            Desg LRN 19        128.1    P2p

*Mar  1 00:50:15.176: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

Sw1#show spanning-tree interface Fa0/1

Vlan                Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

VLAN0001            Desg FWD 19        128.1    P2p

HTH

Rolf

New Member

cant firgure this out??

yes i know that but once it's learned its doesnt matter. my question is why would some machines go into blocking state and some dont directly plugged in? it make no sense?

CCNA

CCNA

cant firgure this out??

Hi Spivy6666,

there is one command you can apply on all of the edge ports (access layer), that also reduce witing time to port up and also previent all of the end-users to have access to all of the other vlans that configured on your access & destirbution layers.

SW_X (config)# int range fa 0/1-24

SW_X (config-if) #switchport  host

by applying this command you will apply below configuration on each eadg ports:

1- disable EtherChannel.

2- enables portfast.

3- disable Trunking

regards,

cant firgure this out??

Hi,

depending on this output from your switch, I can see that updates to the port states have errored for the indicated instances. Any further state updates on these ports cannot be sent until the error is cleared, in the meantime blocking is most preferable on this port and It is also possible that the current state has not been correctly implemented. in this situation the port is trying to recovery when recovering the existing data from checkpoint following a restart of the MSTP controller process, the indicated port ID has been found to be in use on two or more ports, including that named. The indicated port will not be used by MSTP until the problem is cleared. and maybe this is by using VMware on this PC that also requesting  the informaiton and through the same interface 4/0/34. herein there is a simple test on this port, try to connect another PC or laptop to interface  4/0/34, but be aware that there is  no VM installed on the PC.

should let me know if you need anything else.

good luck,

New Member

cant firgure this out??

Yes that was my next test, but i have to wait until next week. The port is configured like shown.. very simple as you can see.

interface GigabitEthernet3/0/43

switchport access vlan 10

switchport mode access

this is my global config...

spanning-tree mode rapid-pvst

spanning-tree portfast bpduguard default

spanning-tree portfast bpdufilter default

spanning-tree extend system-id

spanning-tree vlan 10,20,30,50,60,70,80 priority 8192

spanning-tree vlan 10,20,30,50,60,70,80 hello-time 9

spanning-tree vlan 10,20,30,50,60,70,80 forward-time 9

spanning-tree vlan 10,20,30,50,60,70,80 max-age 12

CCNA

CCNA

cant firgure this out??

Hi,

correct, you have simple configuration on the interface 3/0/43.

please let me know about the result next week.

should let me know if you need anything else.

regards,

Silver

cant firgure this out??

spanning-tree vlan 10,20,30,50,60,70,80 hello-time 9

spanning-tree vlan 10,20,30,50,60,70,80 forward-time 9

spanning-tree vlan 10,20,30,50,60,70,80 max-age 12

You shouldn't modify the default spanning tree timers. Delete those lines.

I you absolutely must tune the timers and you know what you are doing you may tune them but the values above violate the following rule:


     max_age = (4 x hello) + (2 x dia) – 2

Understanding and Tuning Spanning Tree Protocol Timers

Re: cant firgure this out??

I wonder what you want to achieve with this STP configuration.

Rapid-STP doesn't need to rely on max_age, so why tuning it? Even if you need max_age because you have some 802.1D switches in your bridging domain, you're far away from a reasonable value (like already stated by Peter).

9 seconds hello interval?

Hello interval equal to forward delay?

BPDU filter?

One could think that a random number generator was used to create that config ...

New Member

cant firgure this out??

Ok i removed thoes lines. I added them becuse I wanted to cut down the time of the listening/learning/blockign/disguard stage.. thanks for the advise guys.

CCNA

CCNA
New Member

cant firgure this out??

so i'm asuming i should remove thoes vaules on all my switches?

CCNA

CCNA

cant firgure this out??

so i'm asuming i should remove thoes vaules on all my switches?

Yes, the timer settings should be the same on all the switches within the bridging domain.

But I would suggest to do this outside the business hours.

539
Views
45
Helpful
11
Replies
CreatePlease login to create content