Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cant ping attached device

Hi all,

I'm having problems contacting a device after connecting it to our switch (3560).

I've configured the device with an ip of 10.32.0.26/29 with 10.32.0.25 as the gateway. I've then configured vlan 9 with the gateway address. I can ping the gateway no problem but am unable to ping the device. If I connect the device directly to my pc I can access it no problem.

This setup is exactly the same as other devices that we have configured across our network. Its probably something really basic but I just cant see what the problem is. Vlan 9 has also been added to the vlan database.

interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 9-11,701,987

switchport trunk pruning vlan 2-7,12-700,702-986,988-1001

switchport mode trunk

switchport nonegotiate

bandwidth 30000

speed 100

duplex full

interface Vlan9

ip address 10.32.0.25 255.255.255.248

Arp-Cache

Internet  10.32.0.26              0   Incomplete      ARPA

Thanks.

EDIT: Just to add, the device is not vlan aware so it isnt a configuration issue on it.

Everyone's tags (2)
2 REPLIES

Re: Cant ping attached device

Hi Alan,

If the device is not VLAN aware, wouldn't it be better to use an Access port configuration on the switch?

My understanding is that when a device is not VLAN aware, it will send traffic untagged.On a trunked port, this will default to VLAN 1. If you and the command Switchport trunk native vlan 9 it might spring into life, as by default, the device connected to this port will notbe specifying a VLAN in its frames,

Hope this helps

Jonathan

Re: Cant ping attached device

Hi all,

I'm having problems contacting a device after connecting it to our switch (3560).

I've configured the device with an ip of 10.32.0.26/29 with 10.32.0.25 as the gateway. I've then configured vlan 9 with the gateway address. I can ping the gateway no problem but am unable to ping the device. If I connect the device directly to my pc I can access it no problem.

This setup is exactly the same as other devices that we have configured across our network. Its probably something really basic but I just cant see what the problem is. Vlan 9 has also been added to the vlan database.

interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 9-11,701,987

switchport trunk pruning vlan 2-7,12-700,702-986,988-1001

switchport mode trunk

switchport nonegotiate

bandwidth 30000

speed 100

duplex full

interface Vlan9

ip address 10.32.0.25 255.255.255.248

Arp-Cache

Internet  10.32.0.26              0   Incomplete      ARPA

Thanks.

EDIT: Just to add, the device is not vlan aware so it isnt a configuration issue on it.

Hi,

As per the above input of arp cache incomlpete entry is showing in switch arp table for that particular device, It's not usual to get incomplete arp in the same subnet.This could means some kind of communication error between the 2 devices. Try changing the network cables and the switch port that they are plugged at switch end.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

1839
Views
5
Helpful
2
Replies
CreatePlease to create content