Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cat 2960 - 3750 dot1q error.

Hi there, i have 2 switches, a 2960 and a 3750 connected with trunk links. In the 3750 switch i have the native vlan tagging on. On 2960 i was told by cisco personnel that i doesn't support native vlan tagging. Though, i have placed a sniffer on the 3750 and i get tagged and untagged frames. Isn't it a little strange? Shouldn't the 3750 reject all the untagged frames?

4 REPLIES
Cisco Employee

Re: Cat 2960 - 3750 dot1q error.

Well. 2960 is sending the untagged frame for native vlan across the trunk and is expecting the same from 3750. once the 3750 receives the untagged frame, it will drop it and will result in a trunk port misconfiguration error.

You should enable the native vlan tagging on both the sides. You can also get away with this by using a bogus vlan as a native vlan on the trunk ports. This way all the user data vlans will be tagged across the trunk link.

-amit singh

New Member

Re: Cat 2960 - 3750 dot1q error.

Ηι and thanx for the quick response. Native vlan tagging is enabled on 3750 but not on 2960 cause it doesn't support it. But i can ping from one device to the other.

Cisco Employee

Re: Cat 2960 - 3750 dot1q error.

pings during this config might/might not work but this is not a recommended config. If this condition is true then the switches will be buffering the logs. This would significantly impact the performance over the lan.

Please paste the "show log " and " show config " from both the switches.

-amit singh

New Member

Re: Cat 2960 - 3750 dot1q error.

3750 :

3750#show run

!

no aaa new-model

switch 1 provision ws-c3750g-24ts-1u

switch 2 provision ws-c3750g-24ts-1u

system mtu routing 1500

vtp mode transparent

udld aggressive

ip subnet-zero

no ip domain-lookup

!

!

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

vlan dot1q tag native

!

vlan 2

name Switch

!

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/23

description L2 Trunk Connection to switch - GigEth 0/1

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

!

interface Vlan1

ip address 1.1.1.1 255.255.255.0

!

interface Vlan2

ip address 10.10.7.217 255.255.255.252

2960:

Switch#show run

!

hostname Switch

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

!

!

!

!

no file verify auto

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree portfast default

spanning-tree extend system-id

spanning-tree vlan 2 priority 28672

!

vlan internal allocation policy ascending

!

interface Port-channel1

switchport trunk allowed vlan 2,714,717

switchport mode trunk

!

interface GigabitEthernet0/1

description trunk connection to 3750 gig1/0/23

switchport mode dynamic desirable

!

interface Vlan1

ip address 1.1.1.2 255.255.255.0

no ip route-cache

!

interface Vlan2

description Management VLAN

ip address 10.10.7.218 255.255.255.252

no ip route-cache

!

ip default-gateway 10.10.7.217

321
Views
0
Helpful
4
Replies
CreatePlease to create content