Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cat 3560 voice vlan problem

Hi

I have some problem with Cat 3560 running c3560-ipbase-mz.122-35.SE1. When we configure voice vlan on the access port, and the access port is connected to PCs, we encounter packet 50% drop. The reason we configure voice vlan at this stage is to facilitate IPT deployment for next month.

Once i remove the voice vlan command, everything is back to normal.

Has anyone encounter this problem before? I search the release notes and couldn't find anything on it.

Thanks

Eng Wee

9 REPLIES

Re: Cat 3560 voice vlan problem

Hi

Can u paste the current config of the port.

r u not defining any access vlan on the port..?.

Thanks

Mahmood

New Member

Re: Cat 3560 voice vlan problem

Hi Mahmood,

Yes, there is a switchport access vlan in that port. Sample config of the port

int fa0/0

switchport

switchport access vlan 10

switchport voice vlan 20

switchport host

Re: Cat 3560 voice vlan problem

HI

can u add the below line and check

switchport mode access

Thanks

Mahmood

New Member

Re: Cat 3560 voice vlan problem

Hi,

The command is already there. But still same problem.

Rgds

Hall of Fame Super Gold

Re: Cat 3560 voice vlan problem

Hi Eng Wee,

Have you tried other switch? Do you see any line errors? What is the duplex and speed setting? What is the make/model of the phone?

New Member

Re: Cat 3560 voice vlan problem

Hi..

It's the same with other switches.

Duplex and speed setting is auto.

It is not the phone that is connected to the switch, we are connecting PC's directly to the access port which has "voice vlan" configured. There is no interface error in the access port interface.

I am suspecting some compatibility issue with some NIC...

Rgds

New Member

Re: Cat 3560 voice vlan problem

HI

I have used the 3560 for voice and data.

My configs look something like this:

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

switchport voice vlan 20

srr-queue bandwidth share 1 70 20 10

priority-queue out

mls qos trust dscp

spanning-tree portfast trunk

The SRR and QOS bits are optional but may help with voice quality in future.

rgrds

New Member

Re: Cat 3560 voice vlan problem

Maybe you apply below command to the switchport.

"spanning-tree portfast"

Hall of Fame Super Gold

Re: Cat 3560 voice vlan problem

Hi Eng Wee,

Try upgrading the IOS to 12.2(46).

331
Views
0
Helpful
9
Replies
CreatePlease to create content