Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cat 6500 Per VLAN CAR

Hi All,

Does Cat 6509 has that feature like 3550 / 3560 which can *police* and drop traffic on a per-VLAN basis??

If so, what is that feature called and would anyone know which IOS train supports it??

Cheers,

Hunt

4 REPLIES
Hall of Fame Super Silver

Re: Cat 6500 Per VLAN CAR

Hello Hunt,

see

VLAN based QoS on L2 ports where the QoS policy-map is applied on the SVI

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/qos.html#wp1726124

Router(config-if)# mls qos vlan-based

Enables VLAN-based PFC QoS on a Layer 2 LAN port or a Layer 2 EtherChannel.

Hope to help

Giuseppe

Community Member

Re: Cat 6500 Per VLAN CAR

Hi Giuseppe,

I'm not familar with this so i have put together the following and would appreciate your comment.

If my client wants to limit the traffic to 10MB on fa0/5 (incoming traffic towards 6509)

class-map match-all All-Traffic

description All Traffic

match access-group name All-Traffic

policy-map restrict-traffic

class All-Traffic

police 10000000 1000000 conform-action set-prec-transmit exceed-action drop

police flow 5000000 50000 conform-action set-prec-transmit exceed-action drop

interface fastethernet 0/5

service-policy input restrict-traffic

ip access-list extended All-Traffic

permit ip any any

Would this work??

Cheers,

Hunt

Hall of Fame Super Silver

Re: Cat 6500 Per VLAN CAR

Hello Hunt,

ingress policing at the physical port is supported:

Policers can act on ingress traffic per-port or per-VLAN. For egress traffic, the policers can act per-VLAN only.

note: I think you need to provide a parameter to the set-prec-transmit that is the IP Precedence value you want to set.

see

set-prec-transmit value-Sets the IP precedence and transmits the packet with the new IP precedence value.

http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_n1.html#wp1025197

Besides this, your config looks like correct.

Hope to help

Giuseppe

Community Member

Re: Cat 6500 Per VLAN CAR

Hi

I assume the way i did is by ingress policing at *inbound* physical port.

Is IP precedence 3 the lowest QoS?? Because my client wants their backup traffic to be on the lowest priority??

I have updated the config as follows:-

class-map match-all All-Traffic

description All Traffic

match access-group name All-Traffic

policy-map restrict-traffic

class All-Traffic

police 10000000 1000000 conform-action set-prec-transmit 3 exceed-action drop

police flow 5000000 50000 conform-action set-prec-transmit 3 exceed-action drop

interface fastethernet 0/5

service-policy input restrict-traffic

ip access-list extended All-Traffic

permit ip any any

However, assuming i want to do per-VLAN on egress packets, how should i configure this??

Cheers,

Hunt

425
Views
0
Helpful
4
Replies
CreatePlease to create content