Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

cat3750E Multicast PROBLEM (igmp join)

Hello,

platform: WS-C3750E-24TD 12.2(44)SE2

C3750E-UNIVERSAL-M

running ip multicast rounting (for service iptv)...multicast source work ok and sending to multicast groups all ok!

test lab is:

my pc (vlc-player)<-vlan53->sw1<-vlan5->sw2<-vlan5->-sw3<--vlan100--> source multicast

configurations:

!

interface Vlan53

ip address x.x.157.9 255.255.255.248

no ip redirects

no ip proxy-arp

ip pim sparse-mode

no ip mroute-cache

!

interface Vlan5

ip address x.x.157.65 255.255.255.240

no ip redirects

no ip proxy-arp

ip pim sparse-mode

no ip route-cache cef

ip ospf mtu-ignore

load-interval 60

end

#sh ip pim neighbor

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

P - Proxy Capable, S - State Refresh Capable

Neighbor Interface Uptime/Expires Ver DR

Address Prio/Mode

x.x.157.71 Vlan5 1d05h/00:01:22 v2 1 / S (!! SW2 !!)

x.x.157.72 Vlan5 1d05h/00:01:32 v2 1 / DR S (!! SW3 !!)

sh ip igmp groups

IGMP Connected Group Membership

Group Address Interface Uptime Expires Last Reporter Group Accounted

224.0.1.40 Vlan5 02:36:18 00:02:12 x.x.157.71 Ac

#sh ip igmp interface

Global IGMP State Limit : 1 active out of 1 max

Vlan5 is up, line protocol is up

Internet address is x.x.157.65/28

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 1 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0

Multicast designated router (DR) is x.x.157.72

IGMP querying router is x.x.157.65 (this system)

Multicast groups joined by this system (number of users):

224.0.1.40(1)

Vlan53 is up, line protocol is up

Internet address is x.x.157.9/29

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 0 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0

Multicast designated router (DR) is x.x.157.9 (this system)

IGMP querying router is x.x.157.9 (this

sh ip pim rp

Group: 234.5.2.1, RP: y.y.112.2, v2, uptime 01:31:50, expires 00:02:52

Group: 234.5.2.2, RP: y.y.112.2, v2, uptime 01:31:50, expires 00:02:52

if on svi vlan53 use command:ip igmp static-group <ANY_GROUP>, on my pc see video steam!, else don't it (default) =>

see debug ip igmp:

IGMP(0): Received Leave from x.x.157.12 (Vlan53) for 234.5.2.1

IGMP(0): Received v2 Report on Vlan53 from x.x.157.12 for 234.5.2.4

IGMP(0): Received Group record for group 234.5.2.4, mode 2 from x.x.157.12 for 0 sources

IGMP_ACL(0): Group 234.5.2.4 access denied on Vlan53

access ports on switch to witch connect my PC not filtering multicast traffic,no filters,acl

Why not join to group in normal mode?

1 REPLY
New Member

Re: cat3750E Multicast PROBLEM (igmp join)

ALL thx, problem resolved!

my error - ip igmp limit 1

403
Views
0
Helpful
1
Replies
CreatePlease to create content