Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cat6509 Etherchannel to AIX

Due to the following log messages last Friday night and discovering our AIX connections are Link Aggregated, I am attempting to connection 4 ports to AIX VIO servers using etherchannel. Have not had any success as of yet.

sh log | i %MAC_MOVE-SP-4-NOTIF

Jan 25 16:13:06: %MAC_MOVE-SP-4-NOTIF: Host 0a5d.3c1e.8002 in vlan 1 is flapping between port Gi2/19 and port Gi2/20 - 172.25.3.44

Jan 25 16:13:06: %MAC_MOVE-SP-4-NOTIF: Host 0a5d.3e72.4902 in vlan 1 is flapping between port Gi2/19 and port Gi2/20 - 172.25.3.31

Jan 25 16:13:06: %MAC_MOVE-SP-4-NOTIF: Host 0a5d.3ade.7902 in vlan 1 is flapping between port Gi2/19 and port Gi2/20 - 172.25.3.41

Anyone have knowledge or experience with this? Thank you ahead for any assistance.

Configuration: Cat6509

int port-channel 23

switchport

switchport mode access

no sh

int Gi2/22

switchport

switchport mode access

switchport access vlan 1

spanning-tree portfast

channel-group 23 mode active

int Gi2/24

switchport

switchport mode access

switchport access vlan 1

spanning-tree portfast

channel-group 23 mode active

Configuration: AIX

EtherChannel / Link Aggregation: ent5

Status: Available

Attributes:

adapter_names   ent0,ent1      EtherChannel Adapters

alt_addr  0x000000000000       Alternate EtherChannel Address

auto_recovery   yes                 Enable automatic recovery after failover

backup_adapter  NONE           Adapter used when whole channel fails

hash_mode       default            Determines how outgoing adapter is chosen

interval        long                     Determines interval value for IEEE 802.3ad mode

mode            standard             EtherChannel mode of operation

netaddr         0                        Address to ping

noloss_failover yes                  Enable lossless failover after ping failure

num_retries     3                     Times to retry ping before failing

retry_time      1                      Wait time (in seconds) between pings

use_alt_addr    no                   Enable Alternate EtherChannel Address

use_jumbo_frame no               Enable Gigabit Ethernet Jumbo Frames

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions

Cat6509 Etherchannel to AIX

Hi,

The configuration you've applied to the switches is to enable a standards based Cisco EtherChannel i.e., IEEE 802.3ad (now IEEE 802.1ax) using the Link Aggregation Control Protocol (LACP).

From reading the IBM AIX Configuring an EtherChannel documentation, the way I understand the AIX configuration you've pasted above, it's not running IEEE 802.3ad Link Aggregation with LACP. I believe mode is the important setting here, and the aforementioned document states the following:

  • Mode: You can choose from the following modes:
    • standard: In this mode the EtherChannel uses an algorithm to choose which adapter it will send the packets out on. The algorithm consists of taking a data value, dividing it by the number of adapters in the EtherChannel, and using the remainder (using the modulus operator) to identify the outgoing link. The Hash Mode value determines which data value is fed into this algorithm (see the Hash Mode attribute for an explanation of the different hash modes). For example, if the Hash Mode is standard, it will use the packet's destination IP address. If this is 10.10.10.11 and there are 2 adapters in the EtherChannel, (1 / 2) = 0 with remainder 1, so the second adapter is used (the adapters are numbered starting from 0). The adapters are numbered in the order they are listed in the SMIT menu. This is the default operation mode.
    • round_robin: In this mode the EtherChannel will rotate through the adapters, giving each adapter one packet before repeating. The packets may be sent out in a slightly different order than they were given to the EtherChannel, but it will make the best use of its bandwidth. It is an invalid combination to select this mode with a Hash Mode other than default. If you choose the round-robin mode, leave the Hash Mode value as default.
    • netif_backup: To enable Network Interface Backup Mode, you can configure multiple adapters in the primary EtherChannel and a backup adapter. For more information, see Configuring Network Interface Backup.
    • 8023ad: This options enables the use of the IEEE 802.3ad Link Aggregation Control Protocol (LACP) for automatic link aggregation. For more details about this feature, see IEEE 802.3ad Link Aggregation configuration.

You may want to check with the server team again and confirm that they have the same understanding of an aggregate link as you have. With the setup you've shown applied to the Catalyst switch I think they should be running the AIX server with the mode configured as 802.3ad.

Regards

3 REPLIES

Cat6509 Etherchannel to AIX

Hi,

The configuration you've applied to the switches is to enable a standards based Cisco EtherChannel i.e., IEEE 802.3ad (now IEEE 802.1ax) using the Link Aggregation Control Protocol (LACP).

From reading the IBM AIX Configuring an EtherChannel documentation, the way I understand the AIX configuration you've pasted above, it's not running IEEE 802.3ad Link Aggregation with LACP. I believe mode is the important setting here, and the aforementioned document states the following:

  • Mode: You can choose from the following modes:
    • standard: In this mode the EtherChannel uses an algorithm to choose which adapter it will send the packets out on. The algorithm consists of taking a data value, dividing it by the number of adapters in the EtherChannel, and using the remainder (using the modulus operator) to identify the outgoing link. The Hash Mode value determines which data value is fed into this algorithm (see the Hash Mode attribute for an explanation of the different hash modes). For example, if the Hash Mode is standard, it will use the packet's destination IP address. If this is 10.10.10.11 and there are 2 adapters in the EtherChannel, (1 / 2) = 0 with remainder 1, so the second adapter is used (the adapters are numbered starting from 0). The adapters are numbered in the order they are listed in the SMIT menu. This is the default operation mode.
    • round_robin: In this mode the EtherChannel will rotate through the adapters, giving each adapter one packet before repeating. The packets may be sent out in a slightly different order than they were given to the EtherChannel, but it will make the best use of its bandwidth. It is an invalid combination to select this mode with a Hash Mode other than default. If you choose the round-robin mode, leave the Hash Mode value as default.
    • netif_backup: To enable Network Interface Backup Mode, you can configure multiple adapters in the primary EtherChannel and a backup adapter. For more information, see Configuring Network Interface Backup.
    • 8023ad: This options enables the use of the IEEE 802.3ad Link Aggregation Control Protocol (LACP) for automatic link aggregation. For more details about this feature, see IEEE 802.3ad Link Aggregation configuration.

You may want to check with the server team again and confirm that they have the same understanding of an aggregate link as you have. With the setup you've shown applied to the Catalyst switch I think they should be running the AIX server with the mode configured as 802.3ad.

Regards

New Member

Cat6509 Etherchannel to AIX

Steve, thanks for this information. I have reached out to our server group and will post back the results.

Dave

New Member

Cat6509 Etherchannel to AIX

Update: Based on the information Steve-Fuller provided and research with our AIX team I reconfigured the Port-Channels and added the Channel-group to range interface which corrected the problem.

On the channel-group config statement used "mode on" to permit only Etherchannel.

int port-channel 23

switchport

no ip address

no sh

int Gi2/22

switchport

no ip address

channel-group 23 mode on

int Gi2/24

switchport

no ip address

channel-group 23 mode on

1594
Views
0
Helpful
3
Replies
CreatePlease login to create content