Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Catalyst 2900XL blocks PC?

Hi All,

I have a strange problem on a site of our company.

I try to insert a picture, to make the situation easily understandable.

2900xl.png

The problem:

After I have connected one more PC to the unmanaged switch, it cannot connect to network neither by DHCP IP, nor Static IP. (Physical Link is Ok, but no communication)

Tests made:

- PC1 turned off, to test connection, but PC2 cannot connect

- portfast has been turned off on the port of Cisco (which connects to Mediaconverter), but PC2 cannot connect

- PC2 has been reinstalled, replaced, other network adapter has been inserted, but cannot connect.

- the unmanaged switch has been replaced to a new one, but no success.

PC2 can connect to Cisco only if connected directly to RJ45 port of D-link Mediaconverter. But this is not a solution, because in that office, I would need for both of the PCs.

Has anyone idea how to continue troubleshooting?

Thanks in advance,

Peter

running config of the switch:

System image file is "flash:c2900XL-c3h2s-mz-120.5.2-XU.bin"

cisco WS-C2924C-XL (PowerPC403GA) processor (revision 0x11) with 8192K/1024K byt

es of memory.

Model number: WS-C2924C-XL-EN

#sh run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ********

!

logging buffered 32768 debugging

logging monitor errors

enable secret 5 ******

enable password *******

!

!

!

!

!

!

no spanning-tree vlan 1

ip subnet-zero

!

!

!

interface FastEthernet0/1

spanning-tree portfast

!

interface FastEthernet0/2

spanning-tree portfast

!

interface FastEthernet0/3

spanning-tree portfast

!

interface FastEthernet0/4

spanning-tree portfast

!

interface FastEthernet0/5

spanning-tree portfast

!

interface FastEthernet0/6

spanning-tree portfast

!

interface FastEthernet0/7

spanning-tree portfast

!

interface FastEthernet0/8

spanning-tree portfast

!

interface FastEthernet0/9

spanning-tree portfast

!

interface FastEthernet0/10

spanning-tree portfast

!

interface FastEthernet0/11

spanning-tree portfast

!

interface FastEthernet0/12

!

interface FastEthernet0/13

spanning-tree portfast

!

interface FastEthernet0/14

spanning-tree portfast

!

interface FastEthernet0/15

spanning-tree portfast

!

interface FastEthernet0/16

spanning-tree portfast

!

interface FastEthernet0/17

spanning-tree portfast

!

interface FastEthernet0/18

spanning-tree portfast

!

interface FastEthernet0/19

spanning-tree portfast

!

interface FastEthernet0/20

spanning-tree portfast

!

interface FastEthernet0/21

spanning-tree portfast

!

interface FastEthernet0/22

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/23

spanning-tree portfast

!

interface FastEthernet0/24

!

interface VLAN1

ip address 10.242.7.140 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 10.242.7.1

logging source-interface FastEthernet0/24

!

line con 0

exec-timeout 30 0

transport input none

stopbits 1

line vty 0 4

exec-timeout 30 0

password ********

login

line vty 5 15

exec-timeout 30 0

password ********

login

!

end

13 REPLIES
Cisco Employee

Catalyst 2900XL blocks PC?

Hi Peter,

I guess you need to move the troubleshooting on unmanaged non-Cisco switch as first thing. Blindly replacement seldon works w/o knowing what's going on.

Few suggestions:

- check whether ports connected to PC1 and PC2 are in the same vlan and have the same config

- assign static IP on PC2 in the same subnet of PC1 (be aware of the subnet mask) and ping between PC1 and PC2.

- connect to that switch and check if the MAC table gets correctly populated

Only after these 3 steps are cleared and everything works fine you can move the troubleshooting a step up, either the media converter or the cisco switch.

Riccardo

New Member

Catalyst 2900XL blocks PC?

Hi Riccardo!

Thanks for quick answers.

Some of your suggestions has been tried, and the unmanaged switch has no configuration options.

- the unmanaged switch is a simple, 5port edimax switch, so I cannot configure vlan on it's ports

- PC2 already have static IP (with the same subnet) but ping between PC1 and PC2 does not work

- how can I check MAC table population when connected to the mentioned simple switch?

Thanks

Peter

Cisco Employee

Re: Catalyst 2900XL blocks PC?

Hi Peter, actually I have no clue as I don't know that product.

However if you don't get L2 connectivity between the 2 PCs connected to the same switch the latter is to blame.  Either it works as a hub or a switch for such kind of connectivity there is no need of anything else for the ping to work; so it is not a media converter or a cisco switch issue.

Try and replace that piece of junk opss hardware with something else, such a very basic hub.

PS: I take it for granted that you disabled any type of sw firewalls on your PCs. We would not want that is some kind of fw on the pc which block connectivity.

Riccardo

Catalyst 2900XL blocks PC?

1)  On the unmanaged switch do you get a link light?  Have you swapped ports on the unmanaged switch (putting PC1 into PC2 port and PC2 into PC1s port)?   Have you tested cables giong from unmanaged sw to PC2?

:

To see if the MAC is being learned its:

show mac-address-table interface fa0/24 (if this is the uplink)

When you have a static address in the same vlan as your sw, can you ping it from PC2 through the unmanaged sw?

We have very similiar setups where I work.

Purple

Catalyst 2900XL blocks PC?

  Those little cheap switches only know auto/auto for link detection so make sure nic cards are not hardcoded on the pc's and any windows firewalls are turned off .

Catalyst 2900XL blocks PC?

Ohhh...the oh firewall check mark, forgot about that one.

New Member

Catalyst 2900XL blocks PC?

Hi Jimmy,

1.Yes, the link status light indicates that there is connection between PC2 and unmanaged switch.

(On PC2 Ethernet Status window I can see Sent packets, but no Received packets.)

I have tested it with other cables, but no success. Did the port swap between PC1 / PC2, no success, and if I connect only PC2 to the unmanaged switch still no communication...

from PC2 to VLAN's IP address also fails

the output of the "sh mac-address table" on Fa0/24 (yes, thats the uplink) shows only the MAC address of PC1.

Thanks for ideas

Peter

Re: Catalyst 2900XL blocks PC?

If you hook up any other pc or notebook into the same cable PC2 uses does that PC work?   You dont have any weird port security mac address learning limited on the cisco sw do you (from your configs you dont)?  To make sure no weird items are happening on the cisco sw can you clear arp? 

Right now it appears to me a issue w/PC 2, but you have changed everything out, so odd and interesting at the same time.

Hey...why in the world do you have this

"no spanning-tree vlan 1"

New Member

Catalyst 2900XL blocks PC?

I cannot try at this time, but I will ask somenbody on that site, to check that cable with his notebook.

ARP cleared, no success.

"no spanning-tree vlan1" just remained in the config after several unsuccessful test, but now I ave removed it since.

no effect on connection...

what the hell can be there?

New Member

Catalyst 2900XL blocks PC?

Riccardo,

I will give it a try with a very basic hub, just it's interesting, that it does not work neither with an older nor a newer switch.

(it's a common used network scenario in our infrastructure, and never experienced similar before)

group policy turns the firewall on, when I log into PC2 with local admin, but I turned off to avoid traffic blocking issues. But no success with ping packets.

Hall of Fame Super Gold

Catalyst 2900XL blocks PC?

You have only one HALF of the pair of fibre optic media converter.  You need to have a pair of two at each end.

New Member

Catalyst 2900XL blocks PC?

Hi,

Unfortunately this option has been already tested. Previously, I have used the same type of media converter at the other end of the fiber cable, ant that was connected to the Cisco switch.

Bronze

Re: Catalyst 2900XL blocks PC?

Hi Peter,

Did you try resetting the switch (5 ports one) to default? It should have one of those buttons like home routers, you press it with a pin to reset it.

Did you check the IP, default gateway on PC2?

Is the same as the switch?

If PC1 works, did you swap ports with PC2?

Maybe the 5 port switch needs a firmware update....happens so many times(firmware corruption) with unmanaged switches.

I hope this helps

Eugen

713
Views
5
Helpful
13
Replies
CreatePlease to create content