Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Catalyst 2900XL switch error?

Hi all,

I have acquired a second hand Catalyst 2900 xl (2924) switch and I thought I would just plug in and go.... but it doesn't look right. The LED's are all green solid and nothing can connect through it.

I tried connecting console etc but dont really know what to do as I dont have IP and dont know how to connect to switch without IP.

I have telnet, but not much knowledge, is it worth trying or is it maybe just broken.




Re: Catalyst 2900XL switch error?

Hi there,

This document may help:

Also, you can console into the switch. Did the switch come with a Cisco rollover cable?? If not, and if you don't have the pinouts then this page may be able to help.(

Once you have a rollover cable (or console cable, whatever you want to call it), you can use a terminal emulation program to console into the switch.

Usually, the settings for a terminal (eg VT100) are:

Baud rate 9600

Data 8 bit

parity none

stop 1 bit

flow control Xon/Xoff

Specify the com port you've connected the console cable to.

Hyperterminal in windows can be used for this, although I find that program to be pretty awful. TeraTerm can also be used or putty.. there are loads of Terminal Emulators out there.

Once you have connected the console cable to the console port and the com port of your PC/laptop, start up the terminal program and connect the session.. you may have to press enter a few times to get the blood flowing.

turn off the switch and on again about 30 seconds later.. hopefully you see some text appear.

That ought to get you started Mate.



New Member

Re: Catalyst 2900XL switch error?

Thanks Brad,

that will be helpful.

Do you have a similar device? I am hoping someone will confirm that the solid LEDs are not expectation was that they would be out unless there was activity.


Re: Catalyst 2900XL switch error?

I am not sure exactly, but I think it means the switch is in rommon. Maybe the IOS isn't loading??

You really need to console into the switch to ascertain whats going on.

Or, hopefully, someone else on this forum has come across that problem before.


New Member

Re: Catalyst 2900XL switch error?

Thanks again Brad, I tried consoling via every method I could think of, checked the cable etc.... reminds me of fiddling with modems about 1989!

I read up on the startup for the switch and it is supposed to go red first (it does) and then green and off - one by one.

Each one indicates a POST stage, but it does only 2 out of 10. Once or twice it showed red after 2 steps, the rest of the time it shows solid greens across the board regardless of whether there are any cables plugged in or not.

I have the ios image, but cant make a connection, I am using hyperterminal, 9600/8/none/1/none as per the manual and tried serial port and com1 com2 to no avail.

My feeling at the moment is that I shouldn't have to do any of this, it should just start up, go through ten steps and then show no leds until I plug in a cable, unless someone cleared the flash or it is just broken.... even if the internal settings didn't match my requirements it should still boot up to some sort of operational status, do you agree?


CreatePlease to create content