Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

Hello,

i?ve got some trouble on my switch. Unfortunately I cleared the nvram. Now there is no IOS inside the switch.

I?ve read a lot of documetation, but I cannot load the original IOS Software, which I have saved first (I?m so glad about that) on my Computer, because i cannot use the xmodem comand. monito: comand "xmodem" not found.

I start a Terminal program (Hyperterminal) on COM1. After plugging the cord onto the switch it comes dierectly to rommon 1>, THere is no command like xmodem or smth.

I have installed the Cisco TFTP Server, but i cannot connect the switch to it.

Also if I use the transmit data from the Hyperterminla program - menu - it is not going to start sending the ios - file to the switch.

Is it possible, tha my Bootstrap version which ist not (15a) only 15, will not allow copying IOS by tftp? If it is so, how can i manage to get the ios back into my switch?

thank you in advance

fsinani

8 REPLIES

Re: Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

Hi,

Have you tried:

copy xmodem: flash:cat2900-h2s-mz.112-8.5-SA6.bin

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Community Member

Re: Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

thank you,

but this is his answer:

monitor: comand "copy" not found

Community Member

Re: Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

these are the only comands, listed when i press "?"

alias

boot

break

confreg

cont

context

dev

dir

dis

frame

help

history

meminfo

repeat

reset

set

stack

sync

sysret

unalias

unset

This is my IOS version which is currently outside my switch :-(

cat2948g-in-mz.120-7.W5.15d.bin

Re: Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

Hi,

I am confused you said that you've cleared the NVRAM, this has nothing to do with the IOS (it is on the flash)

Please do "dev" then do "dir" for the devices displayed from the "dev" command, and post the output.

HTH,

Mohammed Mahmoud.

Community Member

Re: Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

rommon 9 > dev

Devices in device table:

id name

bootflash: boot flash

eprom: eprom

rommon 10 > dir bootflash:

device does not contain a valid magic number

dir: cannot open device "bootflash:"

rommon 11 > dir eprom:

File size Checksum File name

9025 bytes (0x2341) 0xe520 uncompress

Community Member

Re: Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

Do you think i could be a problem because of the bootstrap version i mentioned in my subject?

Community Member

Re: Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

Any Ideas? noone?

Community Member

Re: Catalyst 2948g-L3 with Bootstrap 12.0(7)W5(15) lost IOS

Hello Mohammed,

i found something out on the cisco Support:

The booting process of the Catalyst 2948G-L3 and the Catalyst 4908G-L3 is very similar to the booting process of other Cisco IOS routers. One issue is that prior to bootstrap version 12.0(7)W5.15a, xmodem download of the IOS was not supported. Therefore, if there is no IOS image in the bootflash: and the device is in ROMMON mode, then there is no way to recover and the complete device needs to be replaced. ROMMON code is not upgradable in the field. Beginning with bootstrap version 12.0(7)W5.15a, xmodem download is supported.

This is so unbelievable. What can I do now? Would it be updatable by a cisco employee? How much will this cost?

I bought that Switch in order to do some lesson for my CCNA.

thanks for your support

fsinani

447
Views
0
Helpful
8
Replies
CreatePlease to create content