Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Catalyst 2960-CG rspan

I am having a bear of a time getting RSPAN to work on my two catalyst 2960-cg switches.  I am trying to get ports 1&2 on each switch to mirror its traffic to port 7 on sw1 for our IDS service.  Port 8 on each switch is the uplink to eachother.  I can regular span to work all day long.  When I put my laptop into port 7 on sw1 I can see the traffic hitting port 1&2 on that local switch. Attached is my configs for each switch.

SW1

Building configuration...

Current configuration : 2881 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname FATPIPEDC01-SW

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$hK9q$qYiyomRe.1Itc1CaQFOOV1

enable password 7 130C07245D180C2F39217C3A342F

!

!

!

no aaa new-model

!

!

!

!

crypto pki trustpoint TP-self-signed-4261360896

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-4261360896

revocation-check none

rsakeypair TP-self-signed-4261360896

!

!

crypto pki certificate chain TP-self-signed-4261360896

certificate self-signed 01

  30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 34323631 33363038 3936301E 170D3933 30333031 30303031

  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 32363133

  36303839 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100CD6A F318B498 447A8E47 64F48C2F D7DB5715 E5860C9E FC8257AA A5E535AF

  709085C9 BA6D7EC6 AE8ABBCD 192547C9 60B0CB32 D9CE7530 B3D5681F 2AFED30C

  E33B113B 6AF1FE0E AFB9A039 E6181472 07D842C5 8F0A34F8 203E07B0 68A8F763

  6DB601F9 4BB35C55 7516C176 342634D1 C72385AE 7E55F6C6 657B28F4 1836EE75

  EAF50203 010001A3 6F306D30 0F060355 1D130101 FF040530 030101FF 301A0603

  551D1104 13301182 0F464154 50495045 44433031 2D53572E 301F0603 551D2304

  18301680 14BB852C 59E0B311 1CCAC2D1 C2773F42 3C708DA1 29301D06 03551D0E

  04160414 BB852C59 E0B3111C CAC2D1C2 773F423C 708DA129 300D0609 2A864886

  F70D0101 04050003 8181005B 8475006A D7E10B7F 66C7BA57 9D06DAB1 E3AB23B3

  E2314358 850C47E5 AC9DD86E 9C442CED 91318761 609778B5 D4BD8F2E 6166574D

  17F14218 8851A4C8 9D1173D2 933D45FD EF7609CE 36036F54 4CF19F13 91D9A81D

  6278B601 434BA539 B8596191 6CCA192F 413AC4E2 98F0EC7A DA910FFB A155271A

  AE1C3C69 89C96600 AF2259

  quit

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface Vlan1

ip address 10.0.99.1 255.255.255.252

!

ip http server

ip http secure-server

ip sla enable reaction-alerts

!

line con 0

password 7 141E023D5A10222E362D673C231E

line vty 0 4

password 7 120E0D1606593B0B38393D

login

line vty 5 15

password 7 120E0D1606593B0B38393D

login

!

!

monitor session 1 source interface Gi0/1 - 2

monitor session 1 destination remote vlan 300

monitor session 2 destination interface Gi0/7

monitor session 2 source remote vlan 300

end


SW2

Current configuration : 2828 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname FATPIPEDC02-SW

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$UFZG$0KXQnzY7.j2jOs7wr4zaU.

enable password 7 08285C785F0D0D12000E580D2B26

!

!

!

no aaa new-model

!

!

!

!

crypto pki trustpoint TP-self-signed-1347959040

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1347959040

revocation-check none

rsakeypair TP-self-signed-1347959040

!

!

crypto pki certificate chain TP-self-signed-1347959040

certificate self-signed 01

  30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31333437 39353930 3430301E 170D3933 30333031 30303031

  33345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 33343739

  35393034 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100BB04 E760E02E 90833537 693403D3 A8BBE756 7C050DB4 5CDFDDB0 883D27D2

  AA19165A 877213E0 335D76D0 20C6FAE1 89314614 E36258C8 5D7A0BA9 40D2513E

  573588AF 9B79D333 168577DD 55FA5F48 1E16CC57 4F8FC235 80F5CB03 DDA616E7

  21524B3D 13635B25 2D9ED4C8 CD1345E2 5A8F4DAD 919344A1 19C94227 F3649795

  CA0F0203 010001A3 6F306D30 0F060355 1D130101 FF040530 030101FF 301A0603

  551D1104 13301182 0F464154 50495045 44433032 2D53572E 301F0603 551D2304

  18301680 14243158 EABF555E C83B0BB0 29C516F7 3322C737 5A301D06 03551D0E

  04160414 243158EA BF555EC8 3B0BB029 C516F733 22C7375A 300D0609 2A864886

  F70D0101 04050003 8181001C EB2F5E97 085D5016 06AE12BF 88C673FE 30F74CF5

  83542F2F 629164C9 6DDEF010 7A4A3D6A E0412FBB CD170018 8D342EDA CD439DB5

  7E32DD9C 968AF91D 3466776F 98D49B22 654F7313 C88B6C50 85EBF062 F0E24089

  46823BEF C90F44EE 842148D0 F7569FE1 4ABF169D 0AD75667 7209CD94 ABB806AE

  D06B4EFB EDC1FD22 122F55

  quit

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface Vlan1

ip address 10.0.99.2 255.255.255.252

!

interface Vlan300

no ip address

!

ip http server

ip http secure-server

ip sla enable reaction-alerts

!

line con 0

password 7 050216397758460C0B00431B0A01

line vty 0 4

password 7 01040E054F593100335E57

login

line vty 5 15

password 7 01040E054F593100335E57

login

!

!

monitor session 1 source interface Gi0/1 - 2

monitor session 1 destination remote vlan 300

end

Thanks for your help

1 REPLY
Silver

Catalyst 2960-CG rspan

Trunks are working otherwise? Can you do show vlan and show int trunk. I don't see the VLANs in your config. There should be something like:

vlan 300

name xyz

remote-span

Daniel Dib
CCIE #37149

Daniel Dib CCIE #37149 Please rate helpful posts.
173
Views
0
Helpful
1
Replies
CreatePlease login to create content