Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Highlighted
Community Member

Catalyst 2960 EtherChannel config for ESXi

Hi,

 

I have 3 x Cisco 2960 switches connected to each other via PAgP EtherChannels. This works today.

 

I would like to add LACP EtherChannels to one of my 2960 switches to connect my VMWare ESXi (vSphere 6.5) host’s via teamed NICs. The current EtherChannel load-balance method configured on all my switches is src-mac. I would like to change this on the switch connected to the ESXi hosts to IP hash.

My questions as follows:

1) If I change the load-balance algorithm, will my PAgP EtherChannle connections be interrupted?

2) Do I need to change the load-balance method on all my switches to IP hash so that the PAgP EtherChannels all use the same algorithm?

3) Which load balance algorithm matches the ESXi IP hash? Is it src-dst-ip or src-ip?

 

Thanks!


   
 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: Catalyst 2960 EtherChannel config for ESXi

Here is the missing piece:

 

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1022751

 

For anyone else - below the config on the switch side:

Check and match the load balance algorithm on the switch with that of the NIC team (usually route based IP hash)

show etherchannel load-balance

conf t
int po1
switchport mode trunk
switchport trunk native vlan 1000
exit


int range gi0/1-2
shut
switchport mode trunk
switchport trunk native vlan 1000
channel-group 1 mode on
no shut
exit


Confirm with:

sh etherchannel summary

 

10 REPLIES
VIP Super Bronze

Re: Catalyst 2960 EtherChannel config for ESXi

Hi,

If you use command "port-channel load-balance" it will change it for all your protocols including Pagp.

HTH

Green

Re: Catalyst 2960 EtherChannel config for ESXi

Hi,

When you change the load balance hash it affects or etherchannels in your switch

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960/software/release/12-2_55_se/configuration/guide/scg_2960/swethchl.html#78975


Here is a link to an example of Cisco to ESXi-VMWare

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004048

Hope this helps

Regards, Alex. Please rate useful posts.
VIP Purple

Re: Catalyst 2960 EtherChannel config for ESXi

Hello

1) If I change the load-balance algorithm, will my PAgP EtherChannel connections be interrupted?
The change will effect all etherchannels on the switch and I dont think you can change the hash values for the load-balancing and forwarding methods of the switch, but you can I guess change the ratio of the LB by having an old number of links in the PC instead of an even number of links.

2) Do I need to change the load-balance method on all my switches to IP hash so that the PAgP EtherChannels all use the same algorithm?h
You can have different LB methods on different switchs but not on the same switch and it all depend of the type of devices connecting to them and the type of traffic traversing them

3) Which load balance algorithm matches the ESXi IP hash? Is it src-dst-ip or src-ip?
ESXI ip hash I am not familiar with, but if this is just a single host, single mac or ip address or ip then scr-mac or scr-ip  could be applicable.

Lastly you can have PAgP and LACP PC on the same switch, you just need to have the physical ports in each PC configured the same and able to support the link agregation protocol to accomplish connectivity

res
Paul

Please don't forget to rate any posts that have been helpful.

Thanks.
Community Member

Re: Catalyst 2960 EtherChannel config for ESXi

Thanks Alex, I am aware of those links - I understand that the load-balance algorith is global (per switch) - I was trying to find out what the impact would be on exiting EtherChannels (performance, time to reconverge etc.). I have received info on this lower down in the thread. Thanks again for you response.    

Super Silver

Re: Catalyst 2960 EtherChannel config for ESXi

#1 I believe so, but briefly (probably under a few ms).
#2 No, you can use whatever hashing algorithm works best on each switch.
#3 src-dst-ip often works well in most usage cases. If fact, its often a good choice for any Etherchannel hashing, when it's supported.
Community Member

Re: Catalyst 2960 EtherChannel config for ESXi

Thank you Joseph for the clear response. 

My biggest concearn was that changing the load-balancing method on one switch to accomodate the ESXi NIC team, might negatively affect the performance of the PAgP EtherChannels interconnecting the switches (as they will not match on all switches anymore). Again, thanks for the help!

 

Community Member

Re: Catalyst 2960 EtherChannel config for ESXi

Do you perhaps know if any specific configuration needs to be added to the physical interfaces in the NIC team? I was able to change the load balance alrorith without issue. The issue came in when adding the interfaces to the etherchannel. When I used LACP (mode active), the etherchannel will not come up. I then switched to static mode (mode on) - I managed to get the ether channel up, but it did not seem to come up on the ESXi side. Hence my question if these is anywhere else (e.g. physical interfaces) that I might have missed config? Thanks again!      

Community Member

Re: Catalyst 2960 EtherChannel config for ESXi

Here is the missing piece:

 

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1022751

 

For anyone else - below the config on the switch side:

Check and match the load balance algorithm on the switch with that of the NIC team (usually route based IP hash)

show etherchannel load-balance

conf t
int po1
switchport mode trunk
switchport trunk native vlan 1000
exit


int range gi0/1-2
shut
switchport mode trunk
switchport trunk native vlan 1000
channel-group 1 mode on
no shut
exit


Confirm with:

sh etherchannel summary

 

VIP Super Bronze

Re: Catalyst 2960 EtherChannel config for ESXi

With Esxi host, you don't even need to configure any Portchannels.  You can simply configure each uplink to the switch as trunk port and the server will do the load balancing and failover for you. 

HTH

Community Member

Re: Catalyst 2960 EtherChannel config for ESXi

Hi Reza,

I believe an etherchannel is required to connect a single switch to teamed ESXi NICs. That is the reason for this thread as currently, MACs are flapping between the two ports (Gi0/6-7 are the interfaces that the teamed NICs are connected to):

%SW_MATM-4-MACFLAP_NOTIF: Host 000c.2974.51ba in vlan 37 is flapping between port Gi0/6 and port Gi0/7.

Thanks  

1987
Views
1
Helpful
10
Replies
CreatePlease to create content