Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Catalyst 3550-PWR, Aironet 1100 and error disable?

I have a Cisco 3550-PWR running the latest IOS 12.2(25)SEE2. I have 2 Aironet 1100 Access Points both running 12.3(8)JEA and configured identically (except hostnames & BVI IP address). There is a Wireless VLAN defined on the 3550 and each AP is connected to an access port in this VLAN, both ports are configured identically. The switch is running Rapid-PVST and BPDUGuard and BPDUFilter are globally enabled.

When the switch boots one of these ports will always error disable (always the same one) with a BPDU-Guard error. I also get the same behaviour with some 7940 & 7960 IP Phones (all ports with these phones attached error disable with a BPDUGuard error during bootup of the 3550).

As a workaround I have enabled error-disable recovery for BPDU-Guard. I had sort of accepted this as an issue and the workaround is OK, but what is troubling me is the 2nd Aironet 1100 AP was only added recently and it is this one that doesn't cause an error disable issue. The 1st 1100 originally had an 802.11b radio that has since been upgraded to an 802.11g radio so it's Model number (and what is discovered through CDP) is 'Platform: cisco AIR-AP1120B-E-K9'. The 2nd 1100 AP was supplied with an 802.11g radio by default so has a model number (and CDP) of 'Platform: cisco AIR-AP1121G-E-K9'. That is the only difference I can see.

Anyone have any ideas? This only happens when the Catalyst 3550 is booted.

Thanks

Andy

5 REPLIES
Cisco Employee

Re: Catalyst 3550-PWR, Aironet 1100 and error disable?

Hi Andy,

Have you configured "spanning-tree portfast" on both the interfaces on which your APs are connected?

Ankur

Re: Catalyst 3550-PWR, Aironet 1100 and error disable?

Yes, this is enabled globally:

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree portfast default

spanning-tree portfast bpduguard default

spanning-tree portfast bpdufilter default

spanning-tree extend system-id

spanning-tree vlan 10,20,500 priority 24576

Both ports are configured IDENTICALLY, but the behaviour is different for the 2 ports the access points are connected to:

interface FastEthernet0/19

description AP1120G 1

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/22

description AP1120G 2

switchport access vlan 50

switchport mode access

!

The logged message when the port error disables states BPDU received on BPDUGuard port (or something similar). What I can't understand is what is the difference apart from one AP 1100 was shipped with an 802.11b radio and the other an 802.11g radio - why should this cause a port to error-disable or not ???

Andy

Cisco Employee

Re: Catalyst 3550-PWR, Aironet 1100 and error disable?

Hi Andy,

Can you disable BPDU Guard on interface on which APs are connected and I belive problem should be resolve.

Regards,

Ankur

Re: Catalyst 3550-PWR, Aironet 1100 and error disable?

No I think you are missing the point. I know how to workaround the issue and it isn't causing me any problems. What I don't understand is the behaviour -

Identical configurations, identical software versions (on the AP's) one AP causes an Error-Disable condition during the 3550's boot-up, one doesn't.

If I use a 3560-PWR with the same configuration as the 3550 (as far as it can be) then I never see the same issue.

Andy

Re: Catalyst 3550-PWR, Aironet 1100 and error disable?

Has anyone seen this behaviour before? I really don't want to open a TAC case just for this........

Andy

377
Views
0
Helpful
5
Replies
CreatePlease login to create content