Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 7700 Desktops

Hi All,

I am getting numerous link-flaps from a current batch of HP DC7700's which have the Intel NIC Onboard 82566DM Gigabit NIC's using the latest drivers. The system are Intel Core 2 Duo's with VPRO AMT.

If I plug the PC's into a Linksys WRT54G they do not link-flap. Connection is rock solid reliable.

If I force the system to use this driver I have no link flaps:-

e1e5132.sys = Version 9.2.24 Date 2nd Dec 2005 the system does not appear to link-flap.

Drivers that I have testest which link-flap:-

e1e5132.sys = Version 9.5.12 Date 26th July 2006

e1e5132.sys = Version 9.4.21 Date 20th July 2006

Anything later than this driver listed above; the system's link-flap. I have seen a high number of link-flaps per minute.

Cisco IOS I have tried:-

12.0.5-WC17(ED)

12.0.5-WC16(ED)

12.0.5-WC15(ED)

12.0.5-WC11(ED)

I have reset the startup-config's to default.

I have run out of Ideas. I would like to know why this is happening as I prefer not to use a Older driver. This seems like a band-aid to me.

Thanks all.

8 REPLIES
Bronze

Re: Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 770

Shot in the dark, but have you perhaps tried a different batch of DC 7700's?

Have you loaded up the newest driver on one DC7700, and one of the older drivers and compared the two, see if Intel dropped in something new?

Also, have you tried sniffing the traffic coming off the computer? Could well be just a bad driver sending crap frames or packets out.

Oh, and you don't have multiple allowed VLANs assigned to those ports, do you?

New Member

Re: Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 770

Yes I have tried several DC7700's and they all do the same. The older driver is rock solid reliable keeps a connection fine.

Have not sniffed the network. Will dot his next.

One big VLAN so its not that.

Thanks for your help.

New Member

Re: Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 770

Try hard setting speed and duplex on both the desktop and switch interfaces and see if that fixes your problem, if not can you please post a show interface from your switch.

Thanks

New Member

Re: Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 770

locking port settings on both switch and desktop do not help.

FastEthernet0/7 is up, line protocol is up

Hardware is Fast Ethernet, address is 0006.2877.e4c7 (bia 0006.2877.e4c7)

Description:

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Auto-duplex (Full), Auto Speed (100), 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 1000 bits/sec, 1 packets/sec

5 minute output rate 2000 bits/sec, 2 packets/sec

1868434 packets input, 840441615 bytes

Received 6759 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 5039 multicast

0 input packets with dribble condition detected

3611544 packets output, 4042912323 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

show diags link-flaps

FastEthernet0/7 171 0

New Member

Re: Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 770

Vista drivers also link-flap

e1e6032.sys = Version 9.8.20.0 Date 13th April 2007

New Member

Re: Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 770

Hi All,

I have done a packet capture and nothing is causing the link to flap. I see no network traffic before the link-flap.

Any other help would be greatly appreciated.

Thanks

New Member

Re: Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 770

Hi All,

I have done some extensive testing & the WS-C3524-XL-EN overheats when these NIC's are connected to the switch causing link-flaps. 2 IC's on the board get very hot.

WS-C3548-XL-EN have a different cooling system compared to the 3524's which have 4 little fans.

I dont know if it is a design fault or just that my switch has weak fans due to age.

Thanks

New Member

Re: Catalyst 35xx Link Flaps with Intel PRO 1000 NIC & HP DC 770

I saw something in the release notes about this occuring with the 3750 and the Intel NICS you mentioned. As I remember Cisco recommended that you contact and upgrade the Intel NIC driver.

453
Views
0
Helpful
8
Replies
CreatePlease to create content