cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
782
Views
10
Helpful
10
Replies

catalyst 3750 bgp send-community limitation?

I am trying to lab some BGP and have a few old switches available to me.  I have a Catalyst 3750G and a Catalyst 3560, both are the 1st generation so can't run IOS 15.0.  I have therefore upgraded them to 12.2(55)SE11 and enabled the 'routing' SDM profile.  I have created a small network and configured BGP between them which is working fine.  However I need the remote switch to send a community attribute to the other.  I have configured an outbound route-map to match against an IP prefix list and then set a community.  On the other switch I have an inbound route-map that matches this community and then sets a local preference.

Unfortunately this isn't working and it looks like the switch isn't sending the community.  I have stripped back the configuration and configured the route-map to just set the community (rather than matching anything) and it still isn't working:

router bgp 65465
 bgp router-id 10.1.1.1
 bgp log-neighbor-changes
 bgp graceful-restart restart-time 120
 bgp graceful-restart stalepath-time 360
 bgp graceful-restart
 neighbor 10.1.2.1 remote-as 65303
 !
 address-family ipv4
  redistribute connected
  neighbor 10.1.2.1 activate
  neighbor 10.1.2.1 send-community
  neighbor 10.1.2.1 route-map ADVERTISE-OUT out
  no auto-summary
  no synchronization
 exit-address-family
!
route-map ADVERTISE-OUT permit 10
 set community 5555:1111

Is this just a limitation of this platform?  Would this work with Catalyst 3650's?

Cheers

Andy

10 Replies 10

I have done a bit more debugging and sniffing and the switch IS sending the community.  Therefore it must be the route-map on the receiving switch that isn't applying:

router bgp 65303
 no synchronization
 bgp router-id 10.1.1.2
 bgp log-neighbor-changes
 neighbor 10.1.2.2 remote-as 65465
 !
 address-family ipv4
  redistribute connected
  neighbor 10.1.2.2 activate
  neighbor 10.1.2.2 send-community
  neighbor 10.1.2.2 route-map BGP-IN in
  no synchronization
 exit-address-family
!
ip community-list expanded PREF-150 permit _5555:1111_
!
route-map BGP-IN permit 15
 match community PREF-150
 set local-preference 150
!

Hi

Have you tried to execute this command  on both SW as Georg mentioned previously?

ip bgp-community new-format.

and to execute a clear ip bgp *

Regards. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

I have already tried that and it has no effect.  My understanding is that command only changes the readable format of communities in the output and won't change how the router operates?

Please let me lab it and share my outputs.

Regards. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hello,

I wonder if configuring the neighbors with:

neighbor x.x.x.x send-community both

makes a difference.

Hi 

Just a question which prefixes are you advertising with that community? have you verified if the subnets are being received on the remote neighbor?

Regards. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

If I remove the inbound route-map that is configured to match the community or if I add another line to the route-map so that processing continues it works, however the local preference is obviously not set which is what I want to achieve.

I expect this will be something silly like a typo on my part....

I'll keep looking.

Cheers

yeap, try to match any ACL on the route-map with the community.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Apparently the issue is with the regular expression, As I remember _ABC_ is regarding to AS but as 5555:1111 is not a BGP AS the community list should be:

ip community-list standard PREF-150 permit 5555:1111 ... The idea is mark and send the prefixes with LP 150 to the others BGP routers behind the AS 65303, right?. 

My config

R1

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FA0/0
no switchport
ip address 10.1.2.2 255.255.255.0
duplex auto

!
router bgp 65465
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.1.2.1 remote-as 65303
!
address-family ipv4
network 2.2.2.2 mask 255.255.255.255
redistribute connected
neighbor 10.1.2.1 activate
neighbor 10.1.2.1 send-community
neighbor 10.1.2.1 route-map ADVERTISE-OUT out
exit-address-family

!
!
access-list 1 permit 2.2.2.2
!
route-map ADVERTISE-OUT permit 10
match ip address 1
set community 5555:1111
!
route-map ADVERTISE-OUT permit 100

R2

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FA0/0
no switchport
ip address 10.1.2.1 255.255.255.0
duplex auto
!
interface FA0/1
no switchport
ip address 10.1.3.2 255.255.255.0
duplex auto

!
router bgp 65303
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.1.2.2 remote-as 65465
neighbor 10.1.3.1 remote-as 65303
!
address-family ipv4
neighbor 10.1.2.2 activate
neighbor 10.1.2.2 send-community
neighbor 10.1.2.2 route-map BGP-IN in
neighbor 10.1.3.1 activate
neighbor 10.1.3.1 send-community
neighbor 10.1.3.1 next-hop-self
exit-address-family
!

!
ip bgp-community new-format
ip community-list standard PREF-150 permit 5555:1111

!
!
!
route-map BGP-IN permit 15
match community PREF-150
set local-preference 150

route-map BGP-IN permit 100

SW2#SH IP BGp
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*> 2.2.2.2/32 10.1.2.2 0 150 0 65465 i
SW2#
SW2#SH IP BGp 2.2.2.2
BGP routing table entry for 2.2.2.2/32, version 4
Paths: (1 available, best #1, table default)
Advertised to update-groups:
2
Refresh Epoch 2
65465
10.1.2.2 from 10.1.2.2 (2.2.2.2)
Origin IGP, metric 0, localpref 150, valid, external, best
Community: 5555:1111
rx pathid: 0, tx pathid: 0x0

R3

R3#Sh ip bgp
BGP table version is 5, local router ID is 10.1.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*>i 2.2.2.2/32 10.1.3.2 0 150 0 65465 i

R3#SH IP BGP 2.2.2.2
BGP routing table entry for 2.2.2.2/32, version 4
Paths: (1 available, best #1, table default)
Not advertised to any peer
Refresh Epoch 2
65465
10.1.3.2 from 10.1.3.2 (1.1.1.1)
Origin IGP, metric 0, localpref 150, valid, internal, best
Community: 5555:1111
rx pathid: 0, tx pathid: 0x0

Please rate the comment if it is useful :-)  thanks

Please try again. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hello,

try to globally configure:

3750(config)# ip bgp-community new-format.

Review Cisco Networking products for a $25 gift card