Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Catalyst 3750 Switch Stack and VIO Server

I am using 3750 switches stack in the distribution layer. AIX VIO servers are connected on one the 3750 switches. I have port channels configured on the 3750. My network was severely degraded due to spanning tree loops and 3 Vlans were done. On the core I was seeing MAC address flapping for the 3 Vlans. By using Spanning tree commands I was able to point the issue to 3750 switch stack and Port channel that was connected to the AIX VIO server. As soon as I did shutdown on that port channel the network came up. So something in the VIO server was causing bridging loops that brought 3 of our vlan down. I ended up pruning the 3 Vlan from the Port channel.

1-The question is there a recommended configuration on the switch stack that I should follow when connecting to AIX VIO servers?

2- Should I configure LACP when I configure port channels the switch stacks, if yes then I have to have LACP turned on AIX VIO server as well?

3- Prune all unnecessary Vlan from the port channel?

3750 Configuration:

interface GigabitEthernet1/0/15

description VI1O

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,50-53,125

switchport mode trunk

channel-group 7 mode on

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

end

interface Port-channel7

description VIO

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,50-53,125

switchport mode trunk

end

Thank you in advance for your help!

Fasih

1 REPLY
New Member

Re: Catalyst 3750 Switch Stack and VIO Server

I would personally setup 802.3ad LACP between the switch and servers because from my experience I haven't ever seen any problems and all my servers are dual-homed (bonded). Though, I never tried using mode on for bonding.

I'm not sure if your server config understands the native vlan, you'd need to check that. I believe your server is probably vlan tagging all the packets.

For LACP, it would look like this.

interface GigabitEthernet1/0/15

description VI1O

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,50-53,125

switchport mode trunk

channel-protocol lacp

channel-group 7 mode active

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

end

interface Port-channel7

description VIO

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,50-53,125

switchport mode trunk

end

Off coarse you'd have to remove the current portchannel and recreate it for LACP to keep it clean. 3750's like to complain.

You should prune unnecessary vlans from any trunk otherwise your nics will hear the broadcasts/multicasts and pruning on other switches may not work causing a possible STP loop and can cause the problem you described.

1365
Views
3
Helpful
1
Replies
CreatePlease to create content