Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Catalyst 3750G to route between subnets

Hi all,

I have a site with 2 LANs in 2 buildings (connected by fiber) using the following (very rough) configuration and would like to be able to route traffic between the 2 subnets using the Catalyst 3750G's (actually a stack of 3 on each site) so I can build a Gigabit Etherchannel between the 3750G's.

LAN 1 - 10.2.0.0/16

Default Router (10.2.100.1/16)

|

|

|

-------------------------------------------

|

|

Catalyst 3750G (10.2.1.1/16)

| |

| |

| |

| |

| |

Catalyst 3750G (10.3.1.1/16)

|

|

-------------------------------------------

|

|

|

Default Router (10.3.100.1/16)

LAN 2 - 10.3.0.0/16

The ideal solution would allow me to add routes to each LAN's default router to relay the traffic to the 3750G (assuming I'd need a second VLAN from what I've found so far) so I can control what servers/services are available accross this link.

Can someone firstly confirm if this is likely to be possible and provide some pointers for the best configuration..

Thanks

4 REPLIES

Re: Catalyst 3750G to route between subnets

Hi

Why dnot u have a point to point layer 3 link between the two 3570 switches.

Thanks

Mahmood

New Member

Re: Catalyst 3750G to route between subnets

If I understand your design, you could create two interface vlans (svi's) one on each switch for each subnet. You could then Port channel the Gig links between the switches and use a third interface vlan to route between the switches over the Port channel. Then (if you run the EMI code on the switches), you could run a routing protocol like OSPF between all four network devices and share route updates via static route redistribution into OSPF.

New Member

Re: Catalyst 3750G to route between subnets

Hi all and thanks for the replies...

swharvey, this sounds just like what I think I need to achieve to make this work but I've been unable to find any configuration examples for this kind of situation. I can find plenty of examples of routing between VLANs on the same switch but no examples of routing across 2 switches to achieve the same results.. I currently have all of my traffic in VLAN1 on both LANs and if I can avoid having to mave them all it would be a big benefit.

I'm using the SMI version of IOS so is it possible you could let me have an example of the IOS configuration I'd need to make this work?

Thanks,

Silver

Re: Catalyst 3750G to route between subnets

Hi!

Good Day! Since you're using SMI which only supports RIP and static routing, you can try this config. Create a common VLAN to both switches and make their IP addresses the next hop for static routes or use either RIP or RIPv2.

Switch1

Vlan 200

Interface Vlan 200

ip address 10.10.10.1 255.255.255.252

ip route 10.30.10.0 255.255.255.0 10.10.10.2

or (using RIPv2)

router rip

version 2

network 10.10.10.0

network 10.30.10.0

Switch2

Vlan 200

Interface Vlan 200

ip address 10.10.10.2 255.255.255.252

ip route 10.20.10.0 255.255.255.0 10.10.10.1

or (using RIPv2)

router rip

version 2

network 10.10.10.0

network 10.20.10.0

Hope this helps,

Regards,

Albert

318
Views
7
Helpful
4
Replies
CreatePlease login to create content