Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Catalyst 3750X service-policy input not matching traffic

Hi all,

We have a 3750 switch that I would like to monitor volume of traffic in a particular interface. I don't want to perform anything just monitor it. If anyone can help make this work I would appreciate it.

I have make a policy map that just defines some classes.

Before I start explaining, there is actual traffic going through int Gi1/0/5 that should match I have confirmed this with a port mirror.

What have done is setup the following:

policy-map QOS-MONITOR

class Transactional

class Voice

class Mission-Critical

class class-default

class-map match-any Transactional

match ip dscp af21

class-map match-any Mission-Critical

match ip dscp af31

class-map match-any Voice

match ip dscp ef

                

interface GigabitEthernet1/0/5
switchport access vlan 2
switchport mode access
bandwidth 10000
speed 100
duplex full
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
priority-queue out
mls qos trust dscp

service-policy input QOS-MONITOR
end

The problem is I don't have any traffic matched e.g.

GigabitEthernet1/0/5

  Service-policy input: QOS-MONITOR

    Class-map: Transactional (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: ip dscp af21 (18)
        0 packets, 0 bytes
        5 minute rate 0 bps

    Class-map: Voice (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: ip dscp ef (46)
        0 packets, 0 bytes
        5 minute rate 0 bps
      Match: access-group name Voice
        0 packets, 0 bytes
        5 minute rate 0 bps

    Class-map: Mission-Critical (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: ip dscp af31 (26)
        0 packets, 0 bytes
        5 minute rate 0 bps

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
        5 minute rate 0 bps

Everyone's tags (3)
1 REPLY
Silver

Catalyst 3750X service-policy input not matching traffic

The show policy-map command does not work properly on Catalysts. Probably something due to using ASICs. You need to use show mls qos interface statistics instead.

Daniel Dib
CCIE #37149

Please rate helpful posts.

Daniel Dib CCIE #37149 Please rate helpful posts.
419
Views
0
Helpful
1
Replies
CreatePlease to create content